post #1 of Old 03-02-2009, 12:38 PM Thread Starter
liredneck
Registered User
1997 TJ Wrangler 
 
Join Date: Jan 2009
Location: shandaken
Posts: 805
95 4.0 stalls when off the gas

Ok my 4.0 is stalling when I'm not on the gas not all the time butt enough to to bother me . If I putt it neutral it starts right back up most of the time sometimes I have to pull of the road and wate a min or so somtimes I will run at an idell for ever and others it will stall at a red light any body got any idears


97 tj 6 cyl 5 SPd 4" supelift 35" baja claws 8.8/hp 30 ,4.10 lockrite in the rear , RR sye and adams dc shaft ,10k lb viper winch and other crap
liredneck is offline  
post #2 of Old 03-02-2009, 12:43 PM
HD-ZJ
Registered User
1997 ZJ 
 
Join Date: Feb 2009
Location: Concord, NC
Posts: 130
Check vacuum hoses first
PCM connections second
Fuel filter third
HD-ZJ is offline  
post #3 of Old 03-02-2009, 12:50 PM
jimjam515
Registered User
 
Join Date: Apr 2008
Location: UK
Posts: 31
Make sure the throtle body and idle speed control valve are clean, I've just had to replace my ISCV due to it going bad on a '96 Grand,

Regards,

Mark
jimjam515 is offline  
post #4 of Old 03-02-2009, 01:59 PM
HMX
Registered User
1994 ZJ 
 
Join Date: Feb 2009
Location: Bennington, VT
Posts: 32
If none of the above fixes the problem, you might have a bad vehicle speed sensor (VSS). Screws into the transfer case and has a two-wire or three-wire plug. Costs about $60 at Autozone.

dan
HMX is offline  
post #5 of Old 03-03-2009, 09:07 AM Thread Starter
liredneck
Registered User
1997 TJ Wrangler 
 
Join Date: Jan 2009
Location: shandaken
Posts: 805
Tryed the PCM thing on off on off on and the light just stays on no blinky blink could it be the PCM

97 tj 6 cyl 5 SPd 4" supelift 35" baja claws 8.8/hp 30 ,4.10 lockrite in the rear , RR sye and adams dc shaft ,10k lb viper winch and other crap
liredneck is offline  
post #6 of Old 03-03-2009, 09:40 AM Thread Starter
liredneck
Registered User
1997 TJ Wrangler 
 
Join Date: Jan 2009
Location: shandaken
Posts: 805
And when it is running in park tv rpm is just above 0 butt I thought the gauge might be wrong with the 220000 miles of has on the body the motor is new about 1500 miles

97 tj 6 cyl 5 SPd 4" supelift 35" baja claws 8.8/hp 30 ,4.10 lockrite in the rear , RR sye and adams dc shaft ,10k lb viper winch and other crap
liredneck is offline  
post #7 of Old 03-04-2009, 03:22 AM Thread Starter
liredneck
Registered User
1997 TJ Wrangler 
 
Join Date: Jan 2009
Location: shandaken
Posts: 805
Did all of that anything eles

97 tj 6 cyl 5 SPd 4" supelift 35" baja claws 8.8/hp 30 ,4.10 lockrite in the rear , RR sye and adams dc shaft ,10k lb viper winch and other crap
liredneck is offline  
post #8 of Old 04-20-2009, 04:15 PM
projectawesome
Registered User
 
Join Date: Apr 2009
Location: orlando
Posts: 2
i have a 02 doing the same thing did you have any luck?
projectawesome is offline  
post #9 of Old 04-20-2009, 06:45 PM
98BlackZJ
Registered User
1998 ZJ 
 
Join Date: Sep 2008
Location: Monticello
Posts: 314
Mine acted like that when the TPS went bad.
98BlackZJ is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
94 4.0 stalls pettit5 ZJ Grand Cherokee Forum 15 09-09-2013 05:52 PM
4.0 sometimes stalls... christine1003 ZJ Grand Cherokee Forum 7 12-23-2009 04:26 PM
Please HELP my 95 Zj stalls wrestlerobx ZJ Grand Cherokee Forum 43 05-18-2008 08:58 PM
93 ZJ stalls robin58 ZJ Grand Cherokee Forum 3 01-22-2007 05:27 PM
Zj Stalls!!! joeyschribar ZJ Grand Cherokee Forum 13 04-11-2006 04:18 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome