JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   ZJ Grand Cherokee Forum (http://www.jeepforum.com/forum/f13/)
-   -   94zj 42re stuck in first gear (http://www.jeepforum.com/forum/f13/94zj-42re-stuck-first-gear-1511487/)

rob4x4 04-19-2013 09:42 AM

94zj 42re stuck in first gear
 
Hi! I have a 94 GC zj 4.0l with the 42re transmission. In the beginning when I bought the car the ATF level was low, so I changed the fluid and filter. The problem then was it would kinda skip over 2nd gear and go right to 3rd gear. And it would not kickdown/downshift from 3rd to 2nd gear. When I manually put it in 2nd gear it worked fine. I tried adjusting the TVcable many times with no luck. So I read some, and came to the conclusion that the governer pressure solenoid and sensor had to be replaced. I just did that now, and now it wont shift out of 1st gear when I start in Drive. If I start with the gearstick in 2, I can put it in drive(at speed) and it will upshift normally. When I do that, it will now downshift and kickdown to 2nd gear, did not do that before the solenoid replacement. BUT, it will not upshift from 2nd gear, just stays in 2nd like it stays in 1st when I start off in Drive. I use ATF+4

What do I do know? Never tought the problem would get worse when shifting the solenoid pack. This is what I used, shifted all the parts here: http://www.cascadetransmissionparts....cekit9697.aspx

mig1289 04-19-2013 09:47 AM

Have you tried adjusting the shifter linkage? My friends wj would say it was in 2nd gear because something was misaligned even though it drove normal

rob4x4 04-19-2013 01:42 PM

No, might look at it, but I tried something now that made me suspicous. I disconnected the cable to the output speed sensor to see if there was any difference. Well there was no difference! What does that mean? Faulty wiring somewhere? Or perhaps the new sensor does not work, Ill try put the old one back in, and see what happens.

rob4x4 04-20-2013 08:35 AM

Tired putting the old output speed sensor in, but there is no difference. Any ideas?

ratmonkey 04-20-2013 01:07 PM

use the key trick and watch the OD OFF light for codes being flashed.
is your check engine light on as well?

rob4x4 04-20-2013 03:40 PM

No check engine light on. Get no codes from the check engine light with the key trick, only code 55 wich means end of code blinking. And the OD OFF light does not flash when I do the key trick. Anyway, I found the TCU and unplugged it, took a test drive and in Drive only 3rd gear worked and the manually 2nd gear. Plugged the TCU back in, and now it aint stuck in first anymore, but it wont kickdown from 3rd to 2nd or from 2nd to 1st. In other words it is back in the condition before I changed the governor pressure solenoid and sensor and the rest of the kit. Omg, what is going on?

ratmonkey 04-20-2013 03:42 PM

check the tv cable adjustment

rob4x4 04-21-2013 04:38 AM

Tried that too..

ratmonkey 04-21-2013 01:11 PM

when you had the pan off to do the solenoids, did you find anything in the pan? have you adjusted the front band?

rob4x4 04-22-2013 04:23 AM

There was some small pices of metal, non magnetic. Looked like small aluminium bits. Probably about 10 pieces. I have adjusted the front band according to specs. I mean arent the changes big for this to be a electric problem when the shifting changes after just unplugging and plugging back in the TCM?

ratmonkey 04-22-2013 04:33 AM

What did the pieces look like? Anything like that in the pan is bad news.

rob4x4 04-22-2013 08:08 AM

They looked kinda like these in the picture I found on google, only not that many. http://mbworld.org/forums/attachment...-dsc00360k.jpg

Moparmissus 04-27-2013 02:58 PM

1) Stuff in the pan is bad. 2) I had a transmission with similar shifting issues - torque converter solenoid was bad. Good luck!

ratmonkey 04-28-2013 06:51 AM

Does the od off light come on when you hit the button?

rob4x4 04-29-2013 08:32 AM

Yep, the OD/off light comes on when I push the button, and overdrive does not engage when it is off, like it should.


The time now is 05:52 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.