94 ZJ cranks but won't stay running - JeepForum.com

 
LinkBack Thread Tools
post #1 of 11 Old 05-03-2013, 06:14 AM Thread Starter
wtb300
Registered User
1994 ZJ 
 
Join Date: May 2013
Location: Winston Salem
Posts: 24
94 ZJ cranks but won't stay running

I'm looking to buy a 94 ZJ I found for 1200. The add says it will start but won't stay running. Would this be a quick fix at a good price or is it something serious and expensive to fix. Sorry I don't have more details other than its the 5.2 motor.

wtb300 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 05-03-2013, 06:28 AM
jnowak
Registered User
1993 ZJ 
 
Join Date: Nov 2011
Location: dahlonega
Posts: 495
Price seems a little high for a semi running vehicle. Most of the the time something like that is an easy fix. But can be expensive. One test you can do is start it with the gas pedal pressed on a little. If it starts and continues to run with the gas pedal depressed its the iac. Easy fix/cheap. Then to drive home youll have to drive two footed at stops.
jnowak is offline  
post #3 of 11 Old 05-03-2013, 09:21 AM Thread Starter
wtb300
Registered User
1994 ZJ 
 
Join Date: May 2013
Location: Winston Salem
Posts: 24
I found one that runs for 800 but overdrive and speedometer don't work.... Any thoughts on that?
wtb300 is offline  
post #4 of 11 Old 05-03-2013, 06:29 PM
jnowak
Registered User
1993 ZJ 
 
Join Date: Nov 2011
Location: dahlonega
Posts: 495
Hard to say. Don't want to say yes and it be a pos. Depending on the tranny, sounds like governor selenoid has gone out. Never done one on these but I know you got to dive into the tranny a little. Not a removal but take pan off and a few more steps. Or its a torque converter not going into lock up. $150 plus removal of tranny. And the Speedo not working is the the rear sensor in the tranny/transfer case(can't remember what its actual name is, output shaft speed sensor????????). Is easy fix, but I think it about $50 for the sensor.

But for $800 you have $400 more to play with to get it right. My 2 cents
jnowak is offline  
post #5 of 11 Old 05-05-2013, 10:54 AM
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Posts: 19,793
Quote:
Originally Posted by wtb300 View Post
I found one that runs for 800 but overdrive and speedometer don't work.... Any thoughts on that?
speed sensor needs to work for the overdrive to engage, same problem with related symptoms.

'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline  
post #6 of 11 Old 05-05-2013, 12:23 PM
LunaMoona
Registered User
1993 ZJ 
 
Join Date: Aug 2010
Location: Durango, Colorado
Posts: 124
Why don't you spend a bit more money for one that isn't a piece of ****?
LunaMoona is offline  
post #7 of 11 Old 05-05-2013, 12:42 PM Thread Starter
wtb300
Registered User
1994 ZJ 
 
Join Date: May 2013
Location: Winston Salem
Posts: 24
Aren't you a helpful one. A) those are my local options for what I want, 94 zj 5.2 motor. B) I enjoy tinkering.
wtb300 is offline  
post #8 of 11 Old 05-05-2013, 02:01 PM
underpowered
Bouncin' on a Budget
 
underpowered's Avatar
1998 ZJ 
 
Join Date: Nov 2005
Location: northern kentucky
Posts: 3,037
the first one could be an alarm related issue. my 95 did the exact same thing, disabled the alarm and all is well.

1998 ZJ-- lowered a touch

2005 GMC 2500HD 496 C.I.

Fat Amy-1989 K5 blazer. Linked, lifted, 38.5's on won tons. Big Girls can play in the woods too.
underpowered is offline  
post #9 of 11 Old 05-05-2013, 02:03 PM Thread Starter
wtb300
Registered User
1994 ZJ 
 
Join Date: May 2013
Location: Winston Salem
Posts: 24
I need to disable the one on mine now. Is there a thread on that?
wtb300 is offline  
post #10 of 11 Old 05-05-2013, 02:08 PM
underpowered
Bouncin' on a Budget
 
underpowered's Avatar
1998 ZJ 
 
Join Date: Nov 2005
Location: northern kentucky
Posts: 3,037
inside the drivers door, there is a purple wire with a white stripe. ground it out and it will completely disable the alarm system.

1998 ZJ-- lowered a touch

2005 GMC 2500HD 496 C.I.

Fat Amy-1989 K5 blazer. Linked, lifted, 38.5's on won tons. Big Girls can play in the woods too.
underpowered is offline  
post #11 of 11 Old 05-05-2013, 03:51 PM Thread Starter
wtb300
Registered User
1994 ZJ 
 
Join Date: May 2013
Location: Winston Salem
Posts: 24
Worked like a charm
wtb300 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome