94 Grand won't start no check engine light - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 94 Grand won't start no check engine light

BLACK FRIDAY SPECIALS!! You asked, we deliver!Rough Country Lift Kits and Parts!XJ Rail Sale!

Reply
Unread 11-24-2005, 06:44 PM   #1
fflint_410
Registered User
 
Join Date: May 2005
Location: Southern, NJ
Posts: 1
94 Grand won't start no check engine light

I have a 94 Grand Cherokee that won't start when you first turn on the ignition. The check engine light is not coming on for the 3 seconds that it shopuld and neither the fuel pump nor any other relay appears to be getting energized. You can crank it all you want and no joy.

If you wait with the key in the on position for 30 seconds or so the check engine will come on and the fuel pump and other relays engized and the car starts up and runs fine. You can then restart the car with no trouble.

Any ideas. Any help help would be appreciated.

fflint_410 is offline   Reply With Quote Quick reply to this message
Unread 11-24-2005, 08:11 PM   #2
CajunWon
Registered User
 
Join Date: Jun 2005
Location: Raleigh
Posts: 229
Have the Fuel Pump and ASD relays tested. They're in the PDC behind the battery.

Next check connector just over the fuel tank.

Next you're replacing the fuel pump for $90 or the entire assembly for ~$250.
__________________
94 ZJ w/95 4oh; NP231; LS w/3.73; headlight harness; Edelbrock IAS/Procomp ES9000 F/R; MSD w/Magnecor
CajunWon is offline   Reply With Quote Quick reply to this message
Unread 11-24-2005, 10:57 PM   #3
Woody
Retired back to Bowties
 
Woody's Avatar
1985  
 
Join Date: Sep 2004
Location: North Pole, Alaska, Alaska
Posts: 7,079
Won, hold up!

If the check engine light does not immediately illuminate when you turn on the key, the PCM is not getting going correctly. The ASD and fuel pump relays will not help if the computer isn't powering up. This is a write up that if followed should fix your problem for only a few dollars.

If you want to swap a few relays around that's fine, but this has the most likely chance of fixing your problem.
__________________
Woody
1985 1 ton K-5, Detroit diesel, 36" tires (going bigger when money permits), 4-speed manual swap, Rockwell T-case, Hybrid lift, 12.5K winch.
Woody is offline   Reply With Quote Quick reply to this message
Unread 11-24-2005, 11:52 PM   #4
-Joe-
Registered User
1995 ZJ 
 
Join Date: Jan 2005
Location: Lexington, KY
Posts: 4,634
http://www.trendit.co.za/capacitor.htm

Heres an article on what to look for. Its a really common problem with computer electronics. Regardless of age, ive replaced them on motherboards only a year or two old. The only problem with just replacing bad caps are that once they reach a point of being bad they can cause other components to fail and replacing them wont fix the problem

The pcm should have a rubbery insulation on the entire board, but the caps are visable.
__________________
- Joe -

'95 Jeep Grand Cherokee Laredo I6 4.0L
242TC - Extreme Engineering 2" Front Lift/1.75" Rear Lift - ES9000 Shocks + JKS BPEs
Moog Cargo Control Springs
Magnaflow Converter - Dynomax Muffler
235/75/15 AT Uniroyal Liberator Tires
-Joe- is offline   Reply With Quote Quick reply to this message
Unread 11-25-2005, 10:10 AM   #5
greasefingers
Registered User
1994 ZJ 
 
Join Date: Sep 2003
Location: Northern VA, USA, NJ
Posts: 8,237
Here someone who just fixed this by replacing the PCM. His problems are just like yours.

http://www.jeepforum.com/forum/showt...=211787&page=1
__________________
Cheers Steve

94 Black Laredo 4-Liter with QuadraTrac (42RE trans & NP249 TC) 200,000 + miles purchased new

88 Cherokee 2-door with 5speed manual 139K miles(deceased) purchased new
greasefingers is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.