94 grand cherokee starts then stalls. please help!! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 94 grand cherokee starts then stalls. please help!!

Dual Color LED Light Bars White/AmberTJ 5.25" Speaker Adapters - NalinMFGAlloy USA Still Available

Reply
Unread 07-07-2006, 10:11 PM   #1
-darren-
Registered User
 
Join Date: Jul 2006
Location: new jersey
Posts: 3
94 grand cherokee starts then stalls. please help!!

i have a 94 grand cherokee that will stall after 3-5 seconds of running.

its kind of like how a car would act if it had a vacuum leak, but all vacuum lines seem to be fine.

could someone please help me out with some suggested ideas to help diagnose the problem??

-darren- is offline   Reply With Quote
Unread 07-07-2006, 10:12 PM   #2
GreenDean
Registered User
1995 ZJ 
 
Join Date: Feb 2005
Location: New Jersey, Exit 105
Posts: 1,918
which engine do you have?
GreenDean is offline   Reply With Quote
Unread 07-07-2006, 10:50 PM   #3
-darren-
Registered User
 
Join Date: Jul 2006
Location: new jersey
Posts: 3
the inline 6 engine
-darren- is offline   Reply With Quote
Unread 07-08-2006, 05:55 AM   #4
OH-ZJ-IO
Registered User
 
Join Date: Aug 2003
Location: Central OH
Posts: 472
Quote:
Originally Posted by -darren-
i have a 94 grand cherokee that will stall after 3-5 seconds of running.

its kind of like how a car would act if it had a vacuum leak, but all vacuum lines seem to be fine.

could someone please help me out with some suggested ideas to help diagnose the problem??
Hey!

Does it run at all...I mean, is all it does is start then stall and you can't get anything else out of it? Over and over, the same thing? Won't continue running at all?

If so, are your lights (all of them, headlights, taillights, interior lights, all very faintly) flashing when the key is on? Hard to see/notice in the daylight.

If so, the only problem is your security system needs to be reset. It's actually doing it's job. This is a simple fix...with all doors closed, go to the driver's side door or the hatch and, with the key, lock and unlock the door. (May have to do this a couple of times and/or try different doors.) This resets/turns off the security breach notice which is the flashing lights and disabling the motor from running so no one steals your ZJ.

If not, then you do have a bigger problem that I haven't experienced....yet .

Al
OH-ZJ-IO is offline   Reply With Quote
Unread 07-24-2006, 09:57 PM   #5
-darren-
Registered User
 
Join Date: Jul 2006
Location: new jersey
Posts: 3
it was my crank position sensor.
-darren- is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.