'94 Grand Cherokee Shifting Problem! Changed Trans still not shifting! - Page 3 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > '94 Grand Cherokee Shifting Problem! Changed Trans still not shifting!

FS: Jeep Fog Light LED Bulbs! Several Brightness Options! SPARTAN LOCKERS are on sale BIG TIME at ROCKRIDGE 4WD!Yukon Ultimate 35 axle kit for c/clip axles with Yukon Zip

Reply
Unread 04-07-2010, 09:48 PM   #31
baxy
Registered User
 
Join Date: Mar 2009
Location: cranbrook
Posts: 1,443
gov solenoid just set gov pressure which in laymans terms is road speed input to the VB
the sensor just feeds back to the computer to verify that the solenoid did what it was told , the computer doesn't even use the sensor data to adjust the gov solenoid

baxy is offline   Reply With Quote
Unread 04-09-2010, 10:32 AM   #32
motoxracer1551
Registered User
 
Join Date: Dec 2009
Location: Long Island, NY
Posts: 16
Bump!

Should I try another TCU? New solenoids? The wiring is all good, connector was cleaned and greased. I also tried clearing the TCU codes by taking the battery off, but they still showed up before even driving it.
__________________
1993 Jeep Grand Cherokee I6
1995 3000GT VR4 - FAST!!
motoxracer1551 is offline   Reply With Quote
Unread 04-09-2010, 03:47 PM   #33
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Location: , Pennsylvania
Posts: 19,796
all of the solenoids going bad at once is extremely rare. look for a bad wire, fuse, relay, or the tcu.
__________________
'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline   Reply With Quote
Unread 04-09-2010, 04:02 PM   #34
YrbkMgr
Registered User
2002 WJ 
 
Join Date: Mar 2010
Location: Chicago
Posts: 94
How do you check for a bad relay?
__________________
2002 Grand Cherokee Laredo v6 4.0L
YrbkMgr is offline   Reply With Quote
Unread 04-10-2010, 02:44 PM   #35
motoxracer1551
Registered User
 
Join Date: Dec 2009
Location: Long Island, NY
Posts: 16
I took the TCU out. Opened it up and the circuit board is all corroded. Now i can't seem to find one though. Nothing on ebay. If anyone has one or knows where i can get one LMK ASAP!!

TCU# 56027316
__________________
1993 Jeep Grand Cherokee I6
1995 3000GT VR4 - FAST!!
motoxracer1551 is offline   Reply With Quote
Unread 04-12-2010, 09:10 AM   #36
Bigwidge
Registered User
1996 ZJ 
 
Join Date: Apr 2010
Location: Maryland
Posts: 171
I still have no idea what to do, when i do the key on off thing, i dont get a code, but my jeep still wont shift in the winter and some days in the summer, anyone know what could be causing this and maybe where i should start looking?
Bigwidge is offline   Reply With Quote
Unread 04-12-2010, 10:26 AM   #37
YrbkMgr
Registered User
2002 WJ 
 
Join Date: Mar 2010
Location: Chicago
Posts: 94
Do you have a Check Engine Light on? You might consider bringing it to Autozone and have them check any cods with their scanner. See what it turns up.
__________________
2002 Grand Cherokee Laredo v6 4.0L
YrbkMgr is offline   Reply With Quote
Unread 04-12-2010, 05:07 PM   #38
motoxracer1551
Registered User
 
Join Date: Dec 2009
Location: Long Island, NY
Posts: 16
changed the tcu. It works good now. But sometimes when I come to a complete stop it starts in 2nd gear. Then sometimes it will go to 1 after a second or just stay in 2nd. Also is there a way to make 1-2 shift happen a little later? It shifts and it feels like the motor is struggling because it shifted a little to early into 2nd.
__________________
1993 Jeep Grand Cherokee I6
1995 3000GT VR4 - FAST!!
motoxracer1551 is offline   Reply With Quote
Unread 04-12-2010, 05:20 PM   #39
JrMechanic
Registered User
1993 ZJ 
 
Join Date: Oct 2008
Location: Lima, Ohio
Posts: 3,368
Adjust the TV cable.
__________________
Want to swap an NP242 or NP231 into your ZJ? Here's how:
http://www.jeepforum.com/forum/f13/n...pdated-685644/
JrMechanic is offline   Reply With Quote
Unread 04-12-2010, 08:18 PM   #40
motoxracer1551
Registered User
 
Join Date: Dec 2009
Location: Long Island, NY
Posts: 16
I tried adjusting it. The main problem I'm having now is sometimes it starts in 2nd from a dead stop. the 1-2 shift is good now though. I heard something about a check valve in the cooler lines for this problem. What should I do next?
__________________
1993 Jeep Grand Cherokee I6
1995 3000GT VR4 - FAST!!
motoxracer1551 is offline   Reply With Quote
Unread 04-13-2010, 05:50 AM   #41
greasefingers
Registered User
1994 ZJ 
 
Join Date: Sep 2003
Location: Northern VA, USA, NJ
Posts: 8,237
So where did you find another tcu?
__________________
Cheers Steve

94 Black Laredo 4-Liter with QuadraTrac (42RE trans & NP249 TC) 200,000 + miles purchased new

88 Cherokee 2-door with 5speed manual 139K miles(deceased) purchased new
greasefingers is offline   Reply With Quote
Unread 04-13-2010, 10:22 AM   #42
motoxracer1551
Registered User
 
Join Date: Dec 2009
Location: Long Island, NY
Posts: 16
Quote:
Originally Posted by greasefingers View Post
So where did you find another tcu?
Got it at a local junkyard. Make sure you open it up quick though before you buy it and make sure the board is clean and nothing was leaking.
__________________
1993 Jeep Grand Cherokee I6
1995 3000GT VR4 - FAST!!
motoxracer1551 is offline   Reply With Quote
Unread 04-13-2010, 11:45 AM   #43
Bigwidge
Registered User
1996 ZJ 
 
Join Date: Apr 2010
Location: Maryland
Posts: 171
I had it at a transmission shop about a year ago, and the guy put one of those computer scanner things, he didnt say of anything turning up, but he did mention something about that he would have to go more in depth with it some other time and that he thaught it might be somehow falling into the failsafe mode, any ideas on why the warm and cold weather can change how it shifts if its the failsafe? But thanks i will go to autozone and get them to test it out
Bigwidge is offline   Reply With Quote
Unread 04-13-2010, 02:23 PM   #44
Krziekracker
Registered User
1994 ZJ 
 
Join Date: Feb 2010
Location: York, Pa
Posts: 30
I had the same problem with my 94, since I replaced the TCM, I haven't had a problem with the tranny.......knock on wood lol.
Krziekracker is offline   Reply With Quote
Unread 04-13-2010, 03:33 PM   #45
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Location: , Pennsylvania
Posts: 19,796
Quote:
Originally Posted by Bigwidge View Post
I had it at a transmission shop about a year ago, and the guy put one of those computer scanner things, he didnt say of anything turning up, but he did mention something about that he would have to go more in depth with it some other time and that he thaught it might be somehow falling into the failsafe mode, any ideas on why the warm and cold weather can change how it shifts if its the failsafe? But thanks i will go to autozone and get them to test it out
temp and gov pressure sensor is all one unit. one side or the other of that can fail. if the tranny thinks it is below a certain temp(0* i think) it will stay in limp mode till warm.
__________________
'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.