post #1 of Old 07-02-2013, 07:08 PM Thread Starter
Lostone01
Registered User
 
Join Date: Jul 2013
Location: G-ville
Posts: 2
94 Grand Cherokee Limited starting/alarm issues

I have an issue with my 1994 Grand Cherokee Limited. I recently had oil change, tune-up and alignment done to my Jeep and now am having issues with it starting and the alarm going off. I don't think the recent work has anything to do with it but am trying to give all info. I went out today and it would not start, so I replaced the battery with a new on. Same problem. It acts like the battery is dead, won't start, won't turn over and the alarm goes off. The headlights/flashers were flashing and now just the flashers. They do go off when I lock/unlock the door (I do not have a key fob...was never given one when I bought this a year ago).
Anything I do is setting off the alarm...I disconnected the battery and re-connect it, the alarm went off...I turned on headlights (which are not coming on now) and the alarm went off....when I turn the key just to accessory, the alarm goes off...I do still have door buzzer and under hood lights though...lol...but everything else is acting like a dead battery
If I disconnect the alarm on the rear tailgate and loop the wires, will that disable the alarm and allow the Jeep to start?

Lostone01 is offline  
post #2 of Old 07-03-2013, 06:48 PM Thread Starter
Lostone01
Registered User
 
Join Date: Jul 2013
Location: G-ville
Posts: 2
I disabled the alarm at the tailgate and replaced the battery with a new one but still nothing. It still acts like a dead battery. I get a couple of clicks out of the starter and then nothing. Any ideas at all?
Lostone01 is offline  
post #3 of Old 07-03-2013, 08:48 PM
dellis
Registered User
1998 ZJ 
 
Join Date: Feb 2013
Location: Vienna
Posts: 313
If your battery is good, then I'm suspecting either your battery connection or your starter. Double check the connection to your battery - you may not have it properly tightened. The clicking description, however, makes me think your starter is suspect. A starter is easy to remove and test at your local parts store. Probably coated in lots of oil.
dellis is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome