94 Grand Cherokee Limited starting/alarm issues - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 94 Grand Cherokee Limited starting/alarm issues

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineSavvy Billet LED Tail LightsLight up the holidays with LED lights from JeepHut

Reply
Unread 07-02-2013, 08:08 PM   #1
Lostone01
Registered User
 
Join Date: Jul 2013
Location: G-ville, PA
Posts: 2
94 Grand Cherokee Limited starting/alarm issues

I have an issue with my 1994 Grand Cherokee Limited. I recently had oil change, tune-up and alignment done to my Jeep and now am having issues with it starting and the alarm going off. I don't think the recent work has anything to do with it but am trying to give all info. I went out today and it would not start, so I replaced the battery with a new on. Same problem. It acts like the battery is dead, won't start, won't turn over and the alarm goes off. The headlights/flashers were flashing and now just the flashers. They do go off when I lock/unlock the door (I do not have a key fob...was never given one when I bought this a year ago).
Anything I do is setting off the alarm...I disconnected the battery and re-connect it, the alarm went off...I turned on headlights (which are not coming on now) and the alarm went off....when I turn the key just to accessory, the alarm goes off...I do still have door buzzer and under hood lights though...lol...but everything else is acting like a dead battery
If I disconnect the alarm on the rear tailgate and loop the wires, will that disable the alarm and allow the Jeep to start?

Lostone01 is offline   Reply With Quote Quick reply to this message
Unread 07-03-2013, 07:48 PM   #2
Lostone01
Registered User
 
Join Date: Jul 2013
Location: G-ville, PA
Posts: 2
I disabled the alarm at the tailgate and replaced the battery with a new one but still nothing. It still acts like a dead battery. I get a couple of clicks out of the starter and then nothing. Any ideas at all?
Lostone01 is offline   Reply With Quote Quick reply to this message
Unread 07-03-2013, 09:48 PM   #3
dellis
Registered User
1998 ZJ 
 
Join Date: Feb 2013
Location: Vienna, VA
Posts: 313
If your battery is good, then I'm suspecting either your battery connection or your starter. Double check the connection to your battery - you may not have it properly tightened. The clicking description, however, makes me think your starter is suspect. A starter is easy to remove and test at your local parts store. Probably coated in lots of oil.
dellis is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.