94 5.2l issues when going to overdrive and shifting - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 94 5.2l issues when going to overdrive and shifting

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineOfficial Chassis Saver Rust Preventive Truck & Auto UnFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 08-14-2013, 01:31 AM   #1
blober54
Registered User
1995 ZJ 
 
Join Date: Aug 2013
Location: Salem, Oregon
Posts: 5
94 5.2l issues when going to overdrive and shifting

New member to the site btw, but have been on here several times reading up on plenty of things :-)

Little background on the jeep...

So I picked up a 94 Grand Cherokee (ZJ) 5.2 litre jeep for my wife and it had a bad tranny in it, the bell housing had a crack and the torque converter is stuck to the tranny and won't slide off. Also the crank position sensor was broken.

Well I replaced all that, a new cps, and picked up a tranny from my local pick n pull junk yard. Came with a warranty and I'm still under warranty so I can return it if it is faulty but I want to figure out if its something not too serious that maybe I can swap with the other tranny or pick up a part.

Here's the issues....

After putting in the new cps and the tranny with torq. conv. the jeep ran great, shifted perfectly and everything. Drove it for about a week around town and made a couple trips out of town shifting through all the gears and overdrive. Put about 300-500 miles on it.

Just this last weekend it was me and my wife's 5th year anniversary so we were going to go camping and decided to go to the dunes here in oregon and pull a trailer with a little honda 300 in it, light trailer, I can move it by hand when empty with ease. And driving around town and on the highway can't even tell that their is a trailer behind us :-)

Well when we got about 30 mins from home cruising at about 62mph on cruise control the whole jeep jumped, acted like I hit a small speed bump or rock in the road or something, caught us by surprise. So I took it off cruise control and after we got down to around 40-45 I accelerated back up to 60, and around when overdrive kicks in it started sounding like the gears or front drive line or something was grinding, and then it wouldn't let me speed up anymore... started acting like I was on the breaks or the motor died, so I put it into neutral and the motor was still running so that was not an issue.

long story short....

I had a buddy that was out that way already luckily and he jumped in the jeep with me to see how it was acting and he suggested to turn off overdrive, after doing that the jeep ran fine and shifted great again. So we decided to drive it back home and barrow his truck to use for the weekend and still go camping.

When back in town after stopping at a red light I wasn't able to go... acted like the tranny was slipping, so we figured out that it was not shifting down to 1st, and I had to manually put it into 1st, then 2nd then drive to keep driving, and keep overdrive off.

So..... what is causing it to not to want to shift automatically and for overdrive to not engage properly? Would this be an easy fix? Or is the tranny total crap? Their are no tranny codes showing and the only engine code showing is 12, and that is for if the battery has been disconnected within the last 50 key cycles... (I replaced the battery terminals on it to make sure she had good charging since it was a little corroded :-)...)

Any help is greatly appreciated, if I can avoid swapping out tranny's it would be nice since it was time consuming to pull but not awe full if needed :-)

Thanks

blober54 is offline   Reply With Quote
Unread 08-14-2013, 08:41 PM   #2
blober54
Registered User
1995 ZJ 
 
Join Date: Aug 2013
Location: Salem, Oregon
Posts: 5
bump
blober54 is offline   Reply With Quote
Unread 08-15-2013, 09:44 AM   #3
tucsonzj
Registered User
1995 ZJ 
 
Join Date: Jul 2012
Location: Boston, MA
Posts: 1,845
kick down cable adjustment? bands in the tranny? did you use atf 4 for your fluid?
__________________
1995 ZJ Limited-3.5" Rubicon Express, 33x12.5s and some other stuff. Maybe half of it works, but it stops so that helps.

Build thread Here

Quote:
Originally Posted by riot1987 View Post
I learned to tuck my stick....
Quote:
Originally Posted by kg6mov View Post
Yeh, washing it inside and out is on my to-do, eventually, maybe, if I have time, OOOH angle grinder.

RIP Ratmonkey-5/27/13. You will be missed.
tucsonzj is offline   Reply With Quote
Unread 08-15-2013, 11:29 AM   #4
blober54
Registered User
1995 ZJ 
 
Join Date: Aug 2013
Location: Salem, Oregon
Posts: 5
we put in walmart tranny fluid. Says compatable with atf4... if I have time today after work I'm going to go pick up a cleaner and run that then flush the system out and put in new/better/the stuff needed... actual atf in their, been thinking and talked to a few people and they said it could be the cheap crap gunked up alittle bit.
blober54 is offline   Reply With Quote
Unread 08-15-2013, 11:42 AM   #5
tucsonzj
Registered User
1995 ZJ 
 
Join Date: Jul 2012
Location: Boston, MA
Posts: 1,845
Quote:
Originally Posted by blober54 View Post
we put in walmart tranny fluid. Says compatable with atf4... if I have time today after work I'm going to go pick up a cleaner and run that then flush the system out and put in new/better/the stuff needed... actual atf in their, been thinking and talked to a few people and they said it could be the cheap crap gunked up alittle bit.
Don't do tranny flushes, just an fyi. These jeeps are very picky about fluids and sensors being mopar (for sensors) and high quality fluids
__________________
1995 ZJ Limited-3.5" Rubicon Express, 33x12.5s and some other stuff. Maybe half of it works, but it stops so that helps.

Build thread Here

Quote:
Originally Posted by riot1987 View Post
I learned to tuck my stick....
Quote:
Originally Posted by kg6mov View Post
Yeh, washing it inside and out is on my to-do, eventually, maybe, if I have time, OOOH angle grinder.

RIP Ratmonkey-5/27/13. You will be missed.
tucsonzj is offline   Reply With Quote
Unread 08-15-2013, 12:52 PM   #6
blober54
Registered User
1995 ZJ 
 
Join Date: Aug 2013
Location: Salem, Oregon
Posts: 5
ok, makes sense, I'll prolly pull as much as I can through the fill tube with a hose and a vacuum setup with a brake bleeder (saw the idea on youtube haha) and then refill it back up with proper fluid and see if she acts any better.

https://www.youtube.com/watch?featur...&v=yn_NlxVjF8M
blober54 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.