'94 4.0L won't fire til you touch brake pedal & wierd stuff. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > '94 4.0L won't fire til you touch brake pedal & wierd stuff.

RCI FUEL CELL BRACKET - Perfect for the back of your JeepARTEC LABOR DAY SALE - 15% offNitro Gear Packages Now Available at Rockridge 4wd

Reply
Unread 09-06-2013, 07:32 PM   #1
Maine1994ZJ
Registered User
1993 ZJ 
 
Join Date: Feb 2013
Location: Phippsburg, Maine
Posts: 744
'94 4.0L won't fire til you touch brake pedal & wierd stuff.

Okay, so I thought my wife was crazy, but her '94 4.0L ZJ will turn over fine but won't fire until you push the brake pedal..... Strangest thing I've ever encountered....
Well except the strange sound the buzzer makes and the idiot lights flickering wildly when you shut the key off......
I'm thinking I need to take the dash apart and check connectors and grounds?
Unless someone has experienced these particular quirks before, and can point me in the right direction? Possibly?

I couldn't find anything in the search or FAQs.....

__________________
'93 V8 ZJ Mountain Goat Edition.
Maine1994ZJ is offline   Reply With Quote
Unread 09-09-2013, 05:50 PM   #2
Maine1994ZJ
Registered User
1993 ZJ 
 
Join Date: Feb 2013
Location: Phippsburg, Maine
Posts: 744
Bump!
__________________
'93 V8 ZJ Mountain Goat Edition.
Maine1994ZJ is offline   Reply With Quote
Unread 09-09-2013, 06:23 PM   #3
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,384
pull the connector off the brake switch on the pedal. then see if it will crank.

if it does check each contact on the harness to ground.

do your brake light work?

no diagram so not much help
ZeeJay1997 is online now   Reply With Quote
Unread 09-09-2013, 06:58 PM   #4
Maine1994ZJ
Registered User
1993 ZJ 
 
Join Date: Feb 2013
Location: Phippsburg, Maine
Posts: 744
Quote:
Originally Posted by ZeeJay1997 View Post
pull the connector off the brake switch on the pedal. then see if it will crank.

if it does check each contact on the harness to ground.

do your brake light work?

no diagram so not much help
Yes, brake lights work correctly. Along with cruise control & torque convertor lockup.

Will disconnect and check it out in the mernin'.

Thanks! It's a place to start!!!
__________________
'93 V8 ZJ Mountain Goat Edition.
Maine1994ZJ is offline   Reply With Quote
Unread 09-19-2013, 10:01 AM   #5
Maine1994ZJ
Registered User
1993 ZJ 
 
Join Date: Feb 2013
Location: Phippsburg, Maine
Posts: 744
Problem solved!
Once I figured it out I was completely shocked...

The screw that the ground for the remote starter went under had come lose, making for a half-assed ground.
So I put a larger diameter screw in the hole and cranked it down tight, making sure the ground wire was firmly in place.

I knew grounds would cause gremlins, but that was NUTS!!!

No more hard starts/no starts without touching the brake pedal, no more flashing dash lights and dieseling when shut off..... because of ONE loose wire...
__________________
'93 V8 ZJ Mountain Goat Edition.
Maine1994ZJ is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.