'94 4.0L won't fire til you touch brake pedal & wierd stuff. - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 09-06-2013, 07:32 PM Thread Starter
Maine1994ZJ
Registered User
1993 ZJ 
 
Join Date: Feb 2013
Location: Phippsburg, Maine
Posts: 845
'94 4.0L won't fire til you touch brake pedal & wierd stuff.

Okay, so I thought my wife was crazy, but her '94 4.0L ZJ will turn over fine but won't fire until you push the brake pedal..... Strangest thing I've ever encountered....
Well except the strange sound the buzzer makes and the idiot lights flickering wildly when you shut the key off......
I'm thinking I need to take the dash apart and check connectors and grounds?
Unless someone has experienced these particular quirks before, and can point me in the right direction? Possibly?

I couldn't find anything in the search or FAQs.....


'93 V8 ZJ Mountain Goat Edition.
'95 V8 ZJ Limited, '97 4.0L ZJ TSi
'96 4.0L 2wd XJ, '88 4.2L YJ
Maine1994ZJ is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 09-09-2013, 05:50 PM Thread Starter
Maine1994ZJ
Registered User
1993 ZJ 
 
Join Date: Feb 2013
Location: Phippsburg, Maine
Posts: 845
Bump!

'93 V8 ZJ Mountain Goat Edition.
'95 V8 ZJ Limited, '97 4.0L ZJ TSi
'96 4.0L 2wd XJ, '88 4.2L YJ
Maine1994ZJ is offline  
post #3 of 5 Old 09-09-2013, 06:23 PM
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 8,664
pull the connector off the brake switch on the pedal. then see if it will crank.

if it does check each contact on the harness to ground.

do your brake light work?

no diagram so not much help
ZeeJay1997 is offline  
post #4 of 5 Old 09-09-2013, 06:58 PM Thread Starter
Maine1994ZJ
Registered User
1993 ZJ 
 
Join Date: Feb 2013
Location: Phippsburg, Maine
Posts: 845
Quote:
Originally Posted by ZeeJay1997 View Post
pull the connector off the brake switch on the pedal. then see if it will crank.

if it does check each contact on the harness to ground.

do your brake light work?

no diagram so not much help
Yes, brake lights work correctly. Along with cruise control & torque convertor lockup.

Will disconnect and check it out in the mernin'.

Thanks! It's a place to start!!!

'93 V8 ZJ Mountain Goat Edition.
'95 V8 ZJ Limited, '97 4.0L ZJ TSi
'96 4.0L 2wd XJ, '88 4.2L YJ
Maine1994ZJ is offline  
post #5 of 5 Old 09-19-2013, 10:01 AM Thread Starter
Maine1994ZJ
Registered User
1993 ZJ 
 
Join Date: Feb 2013
Location: Phippsburg, Maine
Posts: 845
Problem solved!
Once I figured it out I was completely shocked...

The screw that the ground for the remote starter went under had come lose, making for a half-assed ground.
So I put a larger diameter screw in the hole and cranked it down tight, making sure the ground wire was firmly in place.

I knew grounds would cause gremlins, but that was NUTS!!!

No more hard starts/no starts without touching the brake pedal, no more flashing dash lights and dieseling when shut off..... because of ONE loose wire...

'93 V8 ZJ Mountain Goat Edition.
'95 V8 ZJ Limited, '97 4.0L ZJ TSi
'96 4.0L 2wd XJ, '88 4.2L YJ
Maine1994ZJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome