93 ZJ fuel pump wiring problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 93 ZJ fuel pump wiring problems

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsSpiderwebshade @ JeepHut.com

Reply
Unread 04-06-2008, 09:08 PM   #1
xjawgi
Registered User
 
Join Date: Jan 2006
Posts: 9
93 ZJ fuel pump wiring problems

I need some help because im stumped with this problem..any suggestions would be appreciated.

Its a 93 zj 4.0 w/ about 159k. The other day i was getting off the highway and the jeep just died out of no where. It would crank but not start up. I popped the hood, hit the shrader valve and nothing, even while cranking the engine. Listed to the tank to see if i heard any humming and nothing. Tried hitting the tank with a hammer to activate the fuel pump - and nothing. So i had to bite the bullet and have it towed home.

Got it home, took a test light to the fuel pump connected at the back of the jeep and i am only getting a DIM light which happens to be for the fuel gauge. I checked the fuel pump relay and the 2 fuses, and those are good. I even swapped them out with ones i know work (i have an identical zj same year and engine that runs.) So i dropped the tank, pulled the pump and hooked the pump up to the other jeep, and the pump is good.

I pulled the distribution center away from the housing to check the wiring to see if any wiring is burnt, and its all nice and clean. I checked all the grounds and those are all tight and clean. I also swapped the auto shutdown relay and swapped it out with another and still nothing.

I put a test light to the 20A fuse labed ENG. CONTRL and its not lighting up like the other fuses are - does anyone know if that could be the problem? I even swapped the fuse with a new one and still no light.

Ive had over 10 jeeps and none have been this aggravating - any help would be appreciated!

xjawgi is offline   Reply With Quote Quick reply to this message
Unread 04-06-2008, 10:57 PM   #2
-Joe-
Registered User
1995 ZJ 
 
Join Date: Jan 2005
Location: Lexington, KY
Posts: 4,634
check for engine codes? some sensors can cause a no start..

The pump will only run for 1-2 seconds when the key is turned until the engine is started then it runs constantly.
__________________
- Joe -

'95 Jeep Grand Cherokee Laredo I6 4.0L
242TC - Extreme Engineering 2" Front Lift/1.75" Rear Lift - ES9000 Shocks + JKS BPEs
Moog Cargo Control Springs
Magnaflow Converter - Dynomax Muffler
235/75/15 AT Uniroyal Liberator Tires
-Joe- is offline   Reply With Quote Quick reply to this message
Unread 04-07-2008, 03:26 PM   #3
xjawgi
Registered User
 
Join Date: Jan 2006
Posts: 9
Quote:
Originally Posted by -Joe- View Post
check for engine codes? some sensors can cause a no start..

The pump will only run for 1-2 seconds when the key is turned until the engine is started then it runs constantly.
Alright ill do that. Thanks
xjawgi is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.