93 Grand Cherokee Laredo wont start - JeepForum.com
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 93 Grand Cherokee Laredo wont start

SWAG Off Road, Cyber Monday Sale, Our Only Sale Of The YeaSwag off road cyber monday sale, our only sale of the yearAll Bilstein shocks & struts - Lowest Prices Ever and

Unread 04-17-2013, 01:21 PM   #1
Registered User
Join Date: Mar 2007
Location: California
Posts: 4
93 Grand Cherokee Laredo wont start

A few months ago I had a problem starting the vehicle, so I took it to the shop and had the starter and battery replaced. Things have been running well till this morning. I went to start the car and the battery seemed to have a low charge, which is why I thought it wouldnt crank over. So I put the battery on a charger and it is fully charged, but I do not get any type of "sound" indicating the vehicle is going to start. Not even the usual click click sound. I am at a loss as to what this may be and could use some help figuring this out. Any help is appreciated.

HateMachine is offline   Reply With Quote Quick reply to this message
Unread 04-17-2013, 01:50 PM   #2
Registered User
1994 ZJ 
Join Date: Mar 2013
Location: Sonora, California
Posts: 314
Check the wiring on the starter, where it connects to the starter. My friend's truck had that problem the other day and, somehow, one of the wires on his starter had come off.

Sent from my iPhone using JeepForum
JohnCrabtree is offline   Reply With Quote Quick reply to this message
Unread 04-17-2013, 07:41 PM   #3
Registered User
2000 WJ 
Join Date: Feb 2012
Location: sarasota, florida
Posts: 259
Make sure battery terminals are clean take the ground and positive off and use a wire brush to them! And make sure all the starter wires look ok let me know how it goes
wyattwj123 is offline   Reply With Quote Quick reply to this message

start problems

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools

Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.