93 4.0 GC - No Spark - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 93 4.0 GC - No Spark

Introducing MONSTALINERô UV Permanent DIY Roll On Bed LineGrizzly Lockers available at Rockridge4wd.comThe ULTIMATE "Selectable" Locker System! Brough

Reply
Unread 11-18-2007, 12:22 PM   #1
Rockdaddy
Registered User
1993 XJ Cherokee 
 
Join Date: Oct 2005
Posts: 23
93 4.0 GC - No Spark

Iím having a problem with my 93 4.0 GC 107K miles, not starting/dieing on the road at times; the control module/brain on the firewall has already been replaced.
Iíve found when it doesnít start; it has no spark.
Checking for voltage at the 2 wires at the coil I have no voltage with the ignition on or cranking. Could the problem be with the crankcase positioning sensor?

Rockdaddy is offline   Reply With Quote Quick reply to this message
Unread 11-20-2007, 05:55 PM   #2
greasefingers
Registered User
1994 ZJ 
 
Join Date: Sep 2003
Location: Northern VA, USA, NJ
Posts: 8,237
The CPS crank shaft position sensor is notorious for causing stalling and engine no-start issues.
__________________
Cheers Steve

94 Black Laredo 4-Liter with QuadraTrac (42RE trans & NP249 TC) 200,000 + miles purchased new

88 Cherokee 2-door with 5speed manual 139K miles(deceased) purchased new
greasefingers is offline   Reply With Quote Quick reply to this message
Unread 11-20-2007, 06:02 PM   #3
John in MA
Registered User
1994 ZJ 
 
Join Date: Jun 2006
Location: MA, USA
Posts: 831
What he said. You're not a 4.0 Jeep owner until that thing dies. I did mine with a couple long extensions without even jacking the truck up, easy fix. Get the dealer part and make sure you get the cardboard spacer, too.

Oh yeah, before you run out and spend money, pull the codes. Just in case.
John in MA is offline   Reply With Quote Quick reply to this message
Unread 11-20-2007, 07:46 PM   #4
greasefingers
Registered User
1994 ZJ 
 
Join Date: Sep 2003
Location: Northern VA, USA, NJ
Posts: 8,237
So John Ö how many times have you asked people to pull the codes lately?

It is always a good start to pull the codes first (found in the FAQ section) and make sure that the battery is up to snuff, when trouble-shooting electrical issues. These two may not get you anywhere but at least you are being pro-active about your method-for-madness.
__________________
Cheers Steve

94 Black Laredo 4-Liter with QuadraTrac (42RE trans & NP249 TC) 200,000 + miles purchased new

88 Cherokee 2-door with 5speed manual 139K miles(deceased) purchased new
greasefingers is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.