5.9 zj shifting issues - JeepForum.com

 
LinkBack Thread Tools
post #1 of 8 Old 06-19-2011, 08:38 AM Thread Starter
nwfjarhead
Registered User
2000 XJ Cherokee 
 
Join Date: Mar 2009
Location: fort walton beach
Posts: 595
5.9 zj shifting issues

Every now and than when I leave from a stop it doesn't want to shift out of first. When it does this I have to stop and put it into park for a few seconds and than try again. Usually when I do this it works and shifts fine. Any ideas on what could be causing this? I was thinking of having it rebuilt and a shift kit installed but wanted to figure this out first so I can make sure it is addressed during the rebuild. thanks for any help.

nwfjarhead is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 06-19-2011, 08:56 AM
5.9 ANDY
zj tractor
 
5.9 ANDY's Avatar
1998 ZJ 
 
Join Date: Jun 2007
Location: southern afganistan
Posts: 5,227
got flud in it?

hard working private first class in the United States Marine Corps.

Quote:
Originally Posted by shift_grind View Post
It's threads like this that make me wonder why people lift there jeeps
its comments like this that make me wonder why some people are jerks.

build thread:http://www.jeepforum.com/forum/f197/...ndard-1056365/
5.9 ANDY is offline  
post #3 of 8 Old 06-19-2011, 12:04 PM Thread Starter
nwfjarhead
Registered User
2000 XJ Cherokee 
 
Join Date: Mar 2009
Location: fort walton beach
Posts: 595
it does. I was told it could be the speed sensor but I thought the problem should be more consistant if it was.
nwfjarhead is offline  
post #4 of 8 Old 06-20-2011, 01:34 AM Thread Starter
nwfjarhead
Registered User
2000 XJ Cherokee 
 
Join Date: Mar 2009
Location: fort walton beach
Posts: 595
bump........
nwfjarhead is offline  
post #5 of 8 Old 06-20-2011, 03:30 AM
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Posts: 19,793
Check fluid in n with trans hot and engine running.

Sounds like gov sensor and solenoid if it isn't low fluid.

'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline  
post #6 of 8 Old 06-20-2011, 05:43 AM Thread Starter
nwfjarhead
Registered User
2000 XJ Cherokee 
 
Join Date: Mar 2009
Location: fort walton beach
Posts: 595
whats the gov sensor?
nwfjarhead is offline  
post #7 of 8 Old 06-25-2011, 05:27 AM Thread Starter
nwfjarhead
Registered User
2000 XJ Cherokee 
 
Join Date: Mar 2009
Location: fort walton beach
Posts: 595
changed gov sensor and transducer to no avail. clutches are bad. its getting tore down and rebuilt now. thanks for the help.
nwfjarhead is offline  
post #8 of 8 Old 07-15-2011, 06:55 PM Thread Starter
nwfjarhead
Registered User
2000 XJ Cherokee 
 
Join Date: Mar 2009
Location: fort walton beach
Posts: 595
I figured i would update. I got it rebuilt. its better than new now. and a bit stouter now. thanks for the help.
nwfjarhead is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Shifting issues on 4lo Timo_90xj ZJ Grand Cherokee Forum 9 02-21-2012 10:07 AM
zj shifting issues bigsteve89 ZJ Grand Cherokee Forum 2 02-07-2011 01:15 PM
Shifting issues The_Scout ZJ Grand Cherokee Forum 1 04-18-2010 06:33 AM
More shifting issues SWDoodle ZJ Grand Cherokee Forum 4 12-20-2009 05:27 PM
shifting issues coonash ZJ Grand Cherokee Forum 10 09-13-2005 06:37 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome