5.9 serpentine belt... help! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 5.9 serpentine belt... help!

Spartan Locker Promo Running now @ ROCKRIDGE 4WD plus FREEG2 Disc Brake Conversion Kit for Jeep Wrangler YJ TJ LJ ChTJ Wrangler 4" Rough Country Suspension Lift Kits in

Reply
Unread 12-27-2007, 10:44 AM   #1
aletheuontes
Registered User
 
Join Date: Dec 2007
Location: Colorado
Posts: 1
5.9 serpentine belt... help!

ok guys... my first thread and I need some help because this is driving me crazy!

I got my 5.9 in February 07 and about a month later, the serpentine belt started squealing. I used some belt conditioner and that helped for about a day, then it started back up. After a few weeks, the squeal only got worse... so I finally replaced the tensioner. This lessened the noise, but the squeal was still present. The local garage suggested replacing the belt, so I did and it was fixed! Or so I thought...

Not too long after this, my rear-end gave out so the jeep was parked for a few months. But I just put a new rear-end on it and am driving it again (yay!). But now, after driving about 200 miles, the stupid belt is squealing again!!!!!!!

WHY???

The only thing I can figure now is that I have a pulley that is causing the belt to wear unevenly....?

Please help!

aletheuontes is offline   Reply With Quote Quick reply to this message
Unread 12-27-2007, 11:12 AM   #2
micifus
Original GC'er
 
micifus's Avatar
1993 ZJ 
 
Join Date: May 2006
Location: Upstate, NY
Posts: 2,955
Very well could be your water pump. With the belt off check the shaft to the WP see if there is any play
__________________
1993 Jeep Grand Cherokee Limited 4.0L I6
- OME Springs - 30"x9.5" Yokohamma's A/T-S -RE Shocks - JKS Quicker Disconnects - FM70 - E-Fan Conversion - 249->242 Swap -

1970 Jeepster Commando 225 V6
32"x11.5" BFG A/T
4" Lift



"For every one thing I fix two things break"
micifus is offline   Reply With Quote Quick reply to this message
Unread 12-27-2007, 11:27 PM   #3
Nurburgringer
Registered User
1998 ZJ 
 
Join Date: Nov 2007
Posts: 238
could also be the idler pulley and/or tensioner pulley bearings are shot. They are pretty cheap at Rockauto.com and easy to replace, I just did both on my 5.9 as a preventative measure at the same time I did the water pump (Pepboys) and ASP underdrive crank pulley (Summitracing.com) to replace my bent stock one.
Obviously a new belt at the same time is also a smart move.
Kurt
Nurburgringer is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.