5.9 limited AC blows warm at idle - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 5.9 limited AC blows warm at idle

Save 17.76% for the 4th of july with ruffstuff specialtiesIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed LineSave on AEM Intakes from XT!

Reply
Unread 06-28-2015, 05:38 PM   #1
Jd_joe
Registered User
1993 ZJ 
 
Join Date: Feb 2015
Location: Grand forks, North dakota
Posts: 27
5.9 limited AC blows warm at idle

I just picked up a 1998 5.9 limited. A/C blows cold at speed. I did notice after idling for a while waiting for a car wash, it was suddenly blowing cold. Normally thought, it blows warm at idle even after driving for some time and coming to a stop. I do hear the high e fan kick in some times. Not sure if its doing it every time it's supposed to or if thats related?

Jd_joe is offline   Reply With Quote Quick reply to this message
Unread 06-28-2015, 06:31 PM   #2
kg6mov
Hears the voices
 
kg6mov's Avatar
1996 ZJ 
 
Join Date: Nov 2012
Location: Cupertino, CA
Posts: 6,021
With the engine cold, ac off, hood open, start the jeep. The efan should be off. Hit the AC button, the efan should kick on at high speed. If it doesn't you either have no high speed, or the pressure switch on the AC line is dead and not kicking the fan on with the AC.

The high speed is supposed to come on with AC, it sounds like for one of the above reasons it isn't and after you idled for a while the low speed kicked on, pulling air through the condenser and giving you AC>
__________________
1996 ZJ Green Laredo V8, 2.5" OME and Bilsteins, 33's, Holes drilled in the roof.
1998 ZJ Platinum Limited 5.9, Backyard parts fodder
1987 Mercedes 300D Turbo, the diesel daily, 30mpg in style

Quote:
Originally Posted by Texas ZJ1 View Post
I heard someone yell "mall crawler" from the back porch. I'll go see who said that. Be right back.
kg6mov is offline   Reply With Quote Quick reply to this message
Unread 06-28-2015, 08:52 PM   #3
Jd_joe
Registered User
1993 ZJ 
 
Join Date: Feb 2015
Location: Grand forks, North dakota
Posts: 27
Turns out you're right. Started vehicle with A/C off. Kicked A/C on, compressor kicks in and was cycling every 30 seconds roughly. Fan was doing nothing. I took off for a drive. Cools at speed. Fan also seems to cycle when coolant temp gets over 210. I assume its the low speed fan position I'm hearing? How can I diagnose the issue? Fan, wiring, relay, low freon level, etc....?
Jd_joe is offline   Reply With Quote Quick reply to this message
Unread 06-28-2015, 08:52 PM   #4
StPaul59
Registered User
1998 ZJ 
 
Join Date: Mar 2013
Location: St Paul, MN
Posts: 444
Im pretty sure the AC only activates the low speed on the fan..
StPaul59 is offline   Reply With Quote Quick reply to this message
Unread 06-28-2015, 09:04 PM   #5
SchizophrenicMC
Registered User
1997 ZJ 
 
Join Date: May 2012
Location: Arlington, Texas
Posts: 3,351
Quote:
Originally Posted by StPaul59 View Post
Im pretty sure the AC only activates the low speed on the fan..
No, the A/C activates the high speed fan setting. That's pretty well standard.
__________________
1997 Grand Cherokee Orvis Edition

Because tacky green leather is SUPER COOL
SchizophrenicMC is offline   Reply With Quote Quick reply to this message
Unread 06-28-2015, 09:56 PM   #6
kg6mov
Hears the voices
 
kg6mov's Avatar
1996 ZJ 
 
Join Date: Nov 2012
Location: Cupertino, CA
Posts: 6,021
Yep AC should be kicking on the high speed of the fan. Low speed comes on at about 210.

The first step would be to see if the high speed kicks on at all. If you disconnect the lower radiator hose switch and jump it with a piece of wire and then start the jeep it should kick the fan on on high. If it doesn't then check that the relay triggers then check power to motor, then replace motor. If it does turn on then you may just need the ac pressure switch.
__________________
1996 ZJ Green Laredo V8, 2.5" OME and Bilsteins, 33's, Holes drilled in the roof.
1998 ZJ Platinum Limited 5.9, Backyard parts fodder
1987 Mercedes 300D Turbo, the diesel daily, 30mpg in style

Quote:
Originally Posted by Texas ZJ1 View Post
I heard someone yell "mall crawler" from the back porch. I'll go see who said that. Be right back.
kg6mov is offline   Reply With Quote Quick reply to this message
Unread 06-29-2015, 05:42 AM   #7
Jd_joe
Registered User
1993 ZJ 
 
Join Date: Feb 2015
Location: Grand forks, North dakota
Posts: 27
Awesome! Just the advice i needed. I'll get to it. Thanks!
Jd_joe is offline   Reply With Quote Quick reply to this message
Unread 06-29-2015, 05:51 AM   #8
Marcos
Registered User
1993 ZJ 
 
Join Date: Mar 2005
Location: Germantown, MD
Posts: 855
Quote:
Originally Posted by SchizophrenicMC View Post
No, the A/C activates the high speed fan setting. That's pretty well standard.
On this application, it kick on the low speed. The wiring diagram in the FSM is wrong. I've "dissected" one of these wiring harnesses and the A/C switch is spliced in parallel with the upper hose switch, which controls the low speed.

This chart is correct, however.

Marcos is offline   Reply With Quote Quick reply to this message
Unread 06-29-2015, 06:50 AM   #9
KJK
Registered User
1998 ZJ 
 
Join Date: Jan 2007
Location: Dallas, Texas
Posts: 982
My fan runs on the low speed when the AC is on.
__________________
5.9 ZJ SCT tuned PCM/ KJK CAI/ Thorley headers with 3" Magnaflow cat and muffler/ Modded kegger/ TransGo shift kit/ Vanco brake kit/ Braided steel brake lines/ Mopar cupholder insert!
KJK is offline   Reply With Quote Quick reply to this message
Unread 06-29-2015, 12:07 PM   #10
jeepjeepster
Registered User
 
Join Date: Dec 2004
Location: , Ky
Posts: 2,270
Same here.. Fan on low with A/C on.

My fan kicks on low at around 195F. Much sooner than that diagram says.
__________________
1994 ZJ-I6 w/216,000 mi
1998 ZJ 5.9 w/65,155 mi Slate Black
2004 KJ w/90,300 mi
jeepjeepster is offline   Reply With Quote Quick reply to this message
Unread 06-29-2015, 05:09 PM   #11
Jd_joe
Registered User
1993 ZJ 
 
Join Date: Feb 2015
Location: Grand forks, North dakota
Posts: 27
Ok, so which switch should i jump to simulate coming on with the a/c? When the fan does come on, it sounds like high. Possibly no low?
Jd_joe is offline   Reply With Quote Quick reply to this message
Unread 06-29-2015, 07:40 PM   #12
StPaul59
Registered User
1998 ZJ 
 
Join Date: Mar 2013
Location: St Paul, MN
Posts: 444
Quote:
Originally Posted by SchizophrenicMC View Post
No, the A/C activates the high speed fan setting. That's pretty well standard.
No. Not standard for the 98.
StPaul59 is offline   Reply With Quote Quick reply to this message
Unread 06-29-2015, 07:41 PM   #13
StPaul59
Registered User
1998 ZJ 
 
Join Date: Mar 2013
Location: St Paul, MN
Posts: 444
Quote:
Originally Posted by Jd_joe View Post
Ok, so which switch should i jump to simulate coming on with the a/c? When the fan does come on, it sounds like high. Possibly no low?
Low speed is the upper hose sensor.
StPaul59 is offline   Reply With Quote Quick reply to this message
Unread 06-29-2015, 08:58 PM   #14
Jd_joe
Registered User
1993 ZJ 
 
Join Date: Feb 2015
Location: Grand forks, North dakota
Posts: 27
I jumped the upper hose wiring harness. Nothing at the fan. Can i swap the high and low relays side to side and see if the low side of the fan takes off?
Jd_joe is offline   Reply With Quote Quick reply to this message
Unread 06-29-2015, 10:32 PM   #15
kg6mov
Hears the voices
 
kg6mov's Avatar
1996 ZJ 
 
Join Date: Nov 2012
Location: Cupertino, CA
Posts: 6,021
Yes, the relays should just swap. I would just put a finger on the low speed relay while somebody hits the AC button. You should feel the click.
__________________
1996 ZJ Green Laredo V8, 2.5" OME and Bilsteins, 33's, Holes drilled in the roof.
1998 ZJ Platinum Limited 5.9, Backyard parts fodder
1987 Mercedes 300D Turbo, the diesel daily, 30mpg in style

Quote:
Originally Posted by Texas ZJ1 View Post
I heard someone yell "mall crawler" from the back porch. I'll go see who said that. Be right back.
kg6mov is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.