5.9 "liftgate ajar" intermittent electrical issue - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 08-13-2011, 11:19 AM Thread Starter
Adwex
Registered User
1998 ZJ 
 
Join Date: Dec 2010
Location: Ronkonkoma
Posts: 134
5.9 "liftgate ajar" intermittent electrical issue

Hey all,

Recently my 5.9 is getting a "liftgate ajar" indication when the liftgate (rear hatch) is closed. This is a pain in the neck because:

a) I can't leave the doors locked or the alarm horn will sound (even though it's disarmed...but that's another subject)

b) The interior lights are on or flashing on/off at a random rate (extremely annoying and dangerous at night). When leaving the vehicle, I have to disconnect the battery so it doesn't drain.

I have the wiring diagrams, and it implies that there is a short to ground somewhere in the circuit. The diagram also shows that the "liftgate" switch is in parallel with the "liftglass" switch, so it could be either circuit.

Any suggestions where to begin before I start troubleshooting? Any particular components with a history of failure?

Adwex is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-13-2011, 02:35 PM
kachink
Registered User
1998 ZJ 
 
Join Date: Sep 2010
Location: Lake Forest
Posts: 774
When mine did this the switch that sensed if the lift glass was open was loose in its housing. A couple of whacks with a punch while holding it in a vice snugged it up and solved the problem.
kachink is offline  
post #3 of 3 Old 08-13-2011, 07:00 PM
MeanGreenZJ
Web Wheeler
 
Join Date: Apr 2011
Location: Mean Street in a desperate part of town
Posts: 1,710
What the guy above said. If you don't want to whack it or replace it, simply disconnect the plug going to the lift glass switch. To test it push and pull on the glass and see if the VIC beeps at ya. Lastly to stop the interior lights from flashing on/off till you can deal with the problem just press on the cargo light to turn it off.
MeanGreenZJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
2008 WK "Liftgate Open" message MI_Offroad WK Grand Cherokee & XK Commander Forum 10 11-16-2013 04:30 PM
08 Overland HEMI with intermittent "no starting" issue eric02910_HEMI WK Grand Cherokee & XK Commander Forum 18 11-27-2011 10:56 AM
"Liftgate Ajar" message... Mike97ZJ ZJ Grand Cherokee Forum 5 02-20-2011 09:27 AM
Liftgate ajar sensor 97JGCL jdjeep ZJ Grand Cherokee Forum 2 02-24-2007 09:00 PM
burning "smell" issue and "gas pedal vibration" issue in 07 gc laredo beepbeep13 WK Grand Cherokee & XK Commander Forum 4 01-08-2007 06:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome