5.2L 318 Electrical Plug ID - JeepForum.com
 
LinkBack Thread Tools
post #1 of 13 Old 06-18-2017, 03:41 PM Thread Starter
GSXRSTORM
Registered User
1994 ZJ 
 
Join Date: Feb 2016
Location: Chandler
Posts: 21
5.2L 318 Electrical Plug ID

I did an engine swap from a 95 5.2L 318 to a 94 5.2L 318 with my mechanic friend, we got most of the way done and it's running and drivable (yes it's throwing off a check engine light) and then he got deployed for the next 8 months. So while he is gone I've been working on the interior however this one Plug keeps bugging me and I am trying to find where it goes...any help or suggestions would be greatly appreciated.

Attached Thumbnails
IMG_0493_1497818485995.JPG  
GSXRSTORM is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 06-18-2017, 06:21 PM
wingless
Web Wheeler
 
wingless's Avatar
1994 ZJ 
 
Join Date: Sep 2007
Location: Florida
Posts: 2,341
Welcome to the forum.

It looks like the EGR valve connector plug.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wingless is offline  
post #3 of 13 Old 06-19-2017, 12:42 PM Thread Starter
GSXRSTORM
Registered User
1994 ZJ 
 
Join Date: Feb 2016
Location: Chandler
Posts: 21
It looks exactly like the EGR sensor plug on the other side and is what I initially thought as well. I thought maybe I got it on the wrong side but if I switch the sensor to this side I run into the same problem on the other side.
GSXRSTORM is offline  
 
post #4 of 13 Old 06-19-2017, 02:09 PM
wingless
Web Wheeler
 
wingless's Avatar
1994 ZJ 
 
Join Date: Sep 2007
Location: Florida
Posts: 2,341
What does "the other side" mean?

There is only one EGR valve and only one EGR connector.

It is on the passenger side.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wingless is offline  
post #5 of 13 Old 06-19-2017, 07:31 PM Thread Starter
GSXRSTORM
Registered User
1994 ZJ 
 
Join Date: Feb 2016
Location: Chandler
Posts: 21
Ah, I have the EGR valve connector plug on the driver side of the engine. So I will put it over to the passenger side and trace back the plug on the driver side and find out where it goes.
GSXRSTORM is offline  
post #6 of 13 Old 06-19-2017, 08:46 PM
wingless
Web Wheeler
 
wingless's Avatar
1994 ZJ 
 
Join Date: Sep 2007
Location: Florida
Posts: 2,341
This shows the rear engine connectors.

There is the EGR connector on the passenger side, the evaporator purge solenoid vacuum port connector on the driver's side, the idle air control throttle body connector in the middle and the distributor camshaft position sensor in the middle.




To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by wingless; 10-17-2017 at 09:31 PM. Reason: Replaced PB extortion w/ Flickr
wingless is offline  
post #7 of 13 Old 06-19-2017, 09:46 PM Thread Starter
GSXRSTORM
Registered User
1994 ZJ 
 
Join Date: Feb 2016
Location: Chandler
Posts: 21
Wingless, thank you so much that completely clears up so much...Will have to get home and check a few things now and fix them tomorrow.
GSXRSTORM is offline  
post #8 of 13 Old 06-20-2017, 08:18 AM
wingless
Web Wheeler
 
wingless's Avatar
1994 ZJ 
 
Join Date: Sep 2007
Location: Florida
Posts: 2,341
Glad to help.

The image shows the TSB 18-48-98 for the spark plug wire routing.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wingless is offline  
post #9 of 13 Old 06-20-2017, 09:52 AM Thread Starter
GSXRSTORM
Registered User
1994 ZJ 
 
Join Date: Feb 2016
Location: Chandler
Posts: 21
Now that I am reading this I am glad that I kept everything from the old build because now I am finding all these parts and now it's just a matter of fixing these small issues.
GSXRSTORM is offline  
post #10 of 13 Old 06-20-2017, 11:30 AM Thread Starter
GSXRSTORM
Registered User
1994 ZJ 
 
Join Date: Feb 2016
Location: Chandler
Posts: 21
Hey Wingless, by chance do you have a picture of the front of the engine...at this point I'm wanting to make sure I have everything set up correctly?
GSXRSTORM is offline  
post #11 of 13 Old 06-20-2017, 12:26 PM
wingless
Web Wheeler
 
wingless's Avatar
1994 ZJ 
 
Join Date: Sep 2007
Location: Florida
Posts: 2,341
Here are more images.

Good luck.







To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by wingless; 10-17-2017 at 09:29 PM. Reason: Replaced PB extortion w/ Flickr
wingless is offline  
post #12 of 13 Old 06-23-2017, 01:16 PM Thread Starter
GSXRSTORM
Registered User
1994 ZJ 
 
Join Date: Feb 2016
Location: Chandler
Posts: 21
thank you

Wingless thank you again so much, your pictures helped out and I was able to get everything fixed up and now no more engine light...for now.

Again thank you.
GSXRSTORM is offline  
post #13 of 13 Old 06-23-2017, 01:39 PM
wingless
Web Wheeler
 
wingless's Avatar
1994 ZJ 
 
Join Date: Sep 2007
Location: Florida
Posts: 2,341
You are welcome.

Glad to help.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wingless is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome