5.2 Misfire after new plugs and wires - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 5.2 Misfire after new plugs and wires

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineRubicon Express Suspensions from CCOR 706-207-4140Smittybilt Hard Tops @ Oconee Off-Road! 706-534-9955

Reply
Unread 01-24-2014, 02:47 PM   #1
evan1395
Registered User
1996 ZJ 
 
Join Date: Nov 2009
Location: Paradise, California
Posts: 1,021
5.2 Misfire after new plugs and wires

So the owner I just bought this off of left (8) Champion Double Platinum plugs new in box in the center console. So I went out and bought a new set of wires and figured id just use these spark plugs (even after i read how I should use copper plugs in the 5.2)

Well I got everything all wired up and the new Double Platinum plugs all seated...went to go fire it up and it's got a misfire....somewhere. I checked for codes and all its throwing is code #12. Which has something to do with the battery. It had this code before I had done this plug and wire job.

My question is, the plugs I pulled out were autolite 3924's, which are copper plugs, correct?
Could have switching from copper plugs to double platinum cause a misfire? I have no money left for the next 2 weeks, so I am hoping to trouble shoot this problem within the next couple weeks.

evan1395 is offline   Reply With Quote
Unread 01-24-2014, 02:52 PM   #2
jm8881
Registered User
1996 ZJ 
 
Join Date: Oct 2005
Location: , California
Posts: 409
what are the part numbers for the new plugs? They might not even be for the jeep. Also double check your firing order to make sure you didn't mix up any wires.
jm8881 is offline   Reply With Quote
Unread 01-24-2014, 02:55 PM   #3
evan1395
Registered User
1996 ZJ 
 
Join Date: Nov 2009
Location: Paradise, California
Posts: 1,021
The Champion box says 7071 and RC12PYP underneath it. They were gapped waaay up at .045". I had to close the gap down to .035".
Anyone have a link ro picture of the firing order? I did each wire one at a time, but who knows maybe I did mess up somewhere?
evan1395 is offline   Reply With Quote
Unread 01-24-2014, 03:41 PM   #4
jm8881
Registered User
1996 ZJ 
 
Join Date: Oct 2005
Location: , California
Posts: 409
Quote:
Originally Posted by evan1395 View Post
The Champion box says 7071 and RC12PYP underneath it. They were gapped waaay up at .045". I had to close the gap down to .035".
Anyone have a link ro picture of the firing order? I did each wire one at a time, but who knows maybe I did mess up somewhere?
I believe this is right:



And that part number should be correct for multiple years of the magnum 5.2l.
jm8881 is offline   Reply With Quote
Unread 01-24-2014, 03:44 PM   #5
dusterdude
Registered User
1996 ZJ 
 
Join Date: Jan 2012
Location: hopewell, va
Posts: 2,044
The 3924's are the proper plug
dusterdude is offline   Reply With Quote
Unread 01-24-2014, 04:16 PM   #6
evan1395
Registered User
1996 ZJ 
 
Join Date: Nov 2009
Location: Paradise, California
Posts: 1,021
I corrected the wiring diagram and it is back to normal. Im still ginna pull these double plats and throw in my autolites 3924's.

I noticed when i had the air cleaner off the TB...it was a Holley Brand throttle body. This isnt factory, is it?
evan1395 is offline   Reply With Quote
Unread 01-24-2014, 04:28 PM   #7
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss, MD
Posts: 16,039
It's factory alright. My 95 5.2 said Holly on it. I don't believe my 5.9's TB said holly though. Can't tell now anyway because I cut all the excess metal off and sanded it smooth.
PolkaPower is offline   Reply With Quote
Unread 01-24-2014, 07:29 PM   #8
newfieZJ
Registered User
1995 ZJ 
 
Join Date: May 2008
Location: , Alberta
Posts: 6,455
Quote:
Originally Posted by evan1395 View Post
Im still ginna pull these double plats and throw in my autolites 3924's.
Not sure why you would do that . I have been running those plugs for 3-4 years and now have them in 2 5.9's . I did Champ copper cores , tried Autolites , dbl plats gave better mpgs , performance , quick starts , and last a lot longer .

You don't want them , send 'em to me
newfieZJ is offline   Reply With Quote
Unread 01-24-2014, 07:39 PM   #9
Scopez
Registered User
1994 ZJ 
 
Join Date: Oct 2011
Location: Aiken, SC
Posts: 1,713
Quote:
Originally Posted by PolkaPower
It's factory alright. My 95 5.2 said Holly on it. I don't believe my 5.9's TB said holly though. Can't tell now anyway because I cut all the excess metal off and sanded it smooth.
Should be factory, my 01 ram is a 5.9 and it's Holley. Same TB between the 5.2 and 5.9.
__________________
94 ZJ Laredo. 5.2 Crate engine. 6in JKS SA Lift. 33in Destination MTs. ARB Front Bumper.
Scopez is offline   Reply With Quote
Unread 01-25-2014, 02:46 PM   #10
Exdecuk
Registered User
1998 ZJ 
 
Join Date: Dec 2011
Location: London, England
Posts: 410
Quote:
Originally Posted by Scopez View Post
Should be factory, my 01 ram is a 5.9 and it's Holley. Same TB between the 5.2 and 5.9.
Yep, far as i know the factory TB is Holley but not the same as my aftermarket Holley.
__________________
A man will pay $2 for a $1 item he needs.

A woman will pay $1 for a $2 item that she doesn't need but it's on sale.
Exdecuk is offline   Reply With Quote
Unread 01-25-2014, 06:14 PM   #11
evan1395
Registered User
1996 ZJ 
 
Join Date: Nov 2009
Location: Paradise, California
Posts: 1,021
Well, I pulled those double plats and installed the coppers all gapped at .035". Runs soooo much smoother. Checked the gapping on all the double plats as i was pulling them, they were all spot on. I guess THIS 5.2 just didnt like the double plats. I dont know.

So next on my list is my rear axle bearing(s). The right rear is howling and I may as well do both while im at it. Is there a write up for this anywhere?
evan1395 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.