4wd not working properly - JeepForum.com

LinkBack Thread Tools
post #1 of 7 Old 06-19-2006, 08:34 AM Thread Starter
Registered User
Join Date: Jun 2006
Location: Florida
Posts: 3
4wd not working properly

I just bought a 1999 Jeep Grand Cherokee Limited with the Quadra track 2 system. The all time 4wd works great. However when I put the jeep into 4 lo and start to proceed forward it pops out and goes into nuetral. I have tried many different things to get it to stay in 4lo and it will just not stay. Has anyone else had this problem? What did you do to fix it?

cc1410 is offline  
Sponsored Links
post #2 of 7 Old 06-19-2006, 08:37 AM
Registered User
anticrombie's Avatar
1996 ZJ 
Join Date: Jul 2004
Location: Raleigh NC
Posts: 3,027
I believe that you're supposed to change into it going like 5 miles an hour or something.
anticrombie is offline  
post #3 of 7 Old 06-19-2006, 08:44 AM
Smith Erick
Registered User
Smith Erick's Avatar
Join Date: Nov 2005
Location: Greensboro, NC
Posts: 208
While moving 2-3 MPH Change it

"Smith Erick"
2004 Jeep Grand Cherokee Special Edition--4.7L V8
15% Tint, Front Tow Hooks, Skid Plates
Yakima Towers and Bars
Uniden Pro510 CB with taillight mounted 3ft. Fire Stik Antenna
Full Aftermarket Infinity Speakers w/ JL 10W7
Kevin's Round Bar Rock Sliderz powdercoated Black
Kevins 2.5 BB w/ Procomp MX-6 shocks
JKS Quicker Disconnects
Addco Rear Sway Bar w/ Energy Bushings
TransGo Shift Kit
Kolak Exhaust
15in Crager Streetlocks
31"x10.5" Firestone Destination M/T's
Smith Erick is offline  
post #4 of 7 Old 06-19-2006, 08:49 AM
Mr. Hyde!
ArloGuthroJeep's Avatar
2004 WJ 
Join Date: Mar 2005
Location: Boulder
Posts: 23,085
I doubt that is the problem. If you don't change it while moving most of the time it won't shift into it or it'll grind the gears. It won't cause it to pop out. I think the linkage is out of adjustment and needs to be tightened up. If you take off the "thing holder" just below the cigarette/power outlets and unscrew the two screws you can pry out that piece and see the linkage for the transmission (on the right) and the TC (on the left). I haven't seen how you adjust it there but my bet is that it needs to be tightened up.

'04 WJ, 6" Clayton LA's, 242 SYE, 35" BFG MT KM2's, 4.56 gears, & D44a locked
'14 WK2 Limited w/5.7L, ORAI, & Tow Package
ArloGuthroJeep is offline  
post #5 of 7 Old 06-19-2006, 09:13 AM Thread Starter
Registered User
Join Date: Jun 2006
Location: Florida
Posts: 3
When you say shift while moving, do you put it in neutral and then shift it into
4wd or do you keep it in drive?
cc1410 is offline  
post #6 of 7 Old 06-19-2006, 09:34 AM
Registered User
1991 YJ Wrangler 
Join Date: Jul 2003
Location: Albany, NY
Posts: 548
put the tranny in neutral, then shift the tcase.

are you sure youre pulling the lever all the way down into gear? sounds dumb, but i know a lot of jeeps where you think it is in 4 low, but it pops out into neutral.

'91 YJ. Slightly Modified
'04 WJ. Columbia Edition 4.7 HO. 2" BB, 2" OME. 265/65/16 Icelander MT
MuddyV8YJ is offline  
post #7 of 7 Old 06-27-2006, 01:12 PM
Registered User
97zjjeeper's Avatar
1997 ZJ 
Join Date: May 2005
Location: Joplin Missouri
Posts: 398
i am having that same thing happen to me put the TC in 4LO the dash light turns on then i put the tranny into drive from neutral the TC shifter pops forward and u can hear this grinding noise

i was thinking the linkage may need to be adjusted buy putting the TC in N and setting the linkage up under and center the N up with the linkage


BLACK 97 ZJ 4.0L-42re-242-DANA 30/35 (3.73)
MODS) 2in lift-30x9.5x15 BFG A/T-15x8 Pacer Wheels-K&N Intake-1in TB Spacer-40Series Flowmaster-Hi-Flow Cat-JKS Trackbar-Sliderz-BDS adj CA-BDS SS-Cobra19 ULTRA III-FireStick4FT-PA Horn-Hella500 DL-Roof Rack-TC Skid-Gastank Skid
97zjjeeper is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
ABS code 30 Pump circuit not working properly jnnym21 ZJ Grand Cherokee Forum 0 07-31-2008 04:37 PM
1997 Fobs not working properly rossb ZJ Grand Cherokee Forum 1 01-25-2007 10:00 AM
working properly? Cherokee_lu ZJ Grand Cherokee Forum 2 05-25-2006 08:49 PM
Rear wiper not working properly 1st95gc ZJ Grand Cherokee Forum 16 10-10-2004 06:25 PM
Door locks still not working properly. HELP!!! CHICHE 8 ZJ Grand Cherokee Forum 6 07-02-2004 07:46 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome