42re slipping into "neutral" at highway speeds? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 42re slipping into "neutral" at highway speeds?

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineSavvy Billet LED Tail LightsWant to be able to SEE? DOT Approved Headlights for under

Reply
Unread 12-08-2011, 07:06 PM   #1
nicecj7
Registered User
 
Join Date: Feb 2005
Posts: 17
42re slipping into "neutral" at highway speeds?

While driving along in my 1998 Gc I6 above 50-70mph the tranny will slip out of gear like its in neutral and i will have to let off the gas and slow down then a munute later after i slow down or coast it will go back to normal . All other driving is fine and all the shifts are perfect . whats going on do i need a rebuild ?

__________________
1999 Grand Cherokee 4.7, Qudra Drive , Kolak 3" exhaust , K&N intake, Addco rear sway bar,upgraded calipers w/ Bembo Rotors and 18x9 Moda R6 rims
1999 mustang cobra
1988 mustang w/EFI 393w sold!
http://community.webshots.com/user/svt393
nicecj7 is offline   Reply With Quote Quick reply to this message
Unread 12-08-2011, 07:31 PM   #2
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,862
Judging from this, if the fluid is not low, the answer to your question is yes. The OD unit can be rebuilt separately.
slips-od.jpg  
ZeeJay1997 is online now   Reply With Quote Quick reply to this message
Unread 12-08-2011, 07:38 PM   #3
nicecj7
Registered User
 
Join Date: Feb 2005
Posts: 17
great thanx for the help .... i wish it was somthing easy
__________________
1999 Grand Cherokee 4.7, Qudra Drive , Kolak 3" exhaust , K&N intake, Addco rear sway bar,upgraded calipers w/ Bembo Rotors and 18x9 Moda R6 rims
1999 mustang cobra
1988 mustang w/EFI 393w sold!
http://community.webshots.com/user/svt393
nicecj7 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.