4.7 WJ 15lbs of fuel pressure...??? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 4.7 WJ 15lbs of fuel pressure...???

FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectJKS Now Available at www.baseline4x4.com, Trackbars, SkidsFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 08-31-2009, 05:44 PM   #1
cblades83
Registered User
 
Join Date: Aug 2009
Location: fl
Posts: 3
4.7 WJ 15lbs of fuel pressure...???

What would cause this, I have been lurking around and reading all the post on related problems but still no answers. I dropped the tank and installed and new fuel pump assembly yesterday. Still low pressure while running then after i shut off the engine and the pressure drops fast. She has a rough idle but the seems to clear out, but I have to ease the pedal to rev to higher rpms, just cant go to WOT. Any ideas? Thanks!

cblades83 is offline   Reply With Quote
Unread 08-31-2009, 05:46 PM   #2
dougy147
Registered User
2007 JK Wrangler 
 
Join Date: Jan 2005
Posts: 648
Have you changed the fuel filter? I believe the pressure regulator is integrated with the filter in the WJs.
__________________
The Past
95 ZJ Laredo 4.0
00 WJ Laredo 4.0 & 4.7
08 WK Laredo 4.7 (traded for tin can)
The Present
07 JK Unlimited Sahara
dougy147 is offline   Reply With Quote
Unread 08-31-2009, 05:52 PM   #3
UrbanOffRoad124
Registered User
2002 WJ 
 
Join Date: Jun 2008
Location: Fremont, CA
Posts: 133
Yep, the pressure regulator is part of the filter. That might be your problem. Change that filter / regulator.
__________________

'02 WJ | 4.7HO | Limited | QDII | 3.5" Lift (BB+OME Springs) | JKS TB | JKS Quick Disco's | JKS BPE's | RC Nitro 9000's | Rusty's SS | K&N FIPK | 40 Series Delta | Cat-Delete |

Coming soon: 31" KM2's | 15x8 Cragar V-5's

Nightcrew #236 | Blue Jeep Club #232

"those who do, can't explain; those who don't, can't understand"
UrbanOffRoad124 is offline   Reply With Quote
Unread 08-31-2009, 06:00 PM   #4
cblades83
Registered User
 
Join Date: Aug 2009
Location: fl
Posts: 3
I give that a shot
cblades83 is offline   Reply With Quote
Unread 08-31-2009, 06:47 PM   #5
redwolf698
Registered User
2004 WJ 
 
Join Date: Dec 2001
Location: Fuquay Varina, NC
Posts: 112
I agree with these guys, fuel filter is the likely culprit. If that's not it, check for restrictions in the lines, kinks, bends, etc.
__________________
Daniel J Fenti
Owner - NC Transmission
2004 WJ Overland lightly modified
Boat Drinks OffRoad Co-Founder
redwolf698 is offline   Reply With Quote
Unread 08-31-2009, 07:16 PM   #6
cblades83
Registered User
 
Join Date: Aug 2009
Location: fl
Posts: 3
thanks guys for the help, try to see what happen's and keep yall updated
cblades83 is offline   Reply With Quote
Unread 05-24-2013, 04:20 PM   #7
corymonster
Registered User
2002 WJ 
 
Join Date: Jun 2011
Location: Long Beach, CA
Posts: 109
what ever happened here? im in the same boat, but I changed my filter about a year ago, and i just put in a new pump. long crank to start, and rough idle. bad gas mileage. wont accelerate properly
__________________
[url]http://www.jeepforum.com/forum/f22/corymonsters-blue-thing-1325736/[/url]
corymonster is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.