4.7 engine swap won't run code P1389 ASD - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 4.7 engine swap won't run code P1389 ASD

Currie Antirock, Currectlync & Lift Kits on Sale!Oconee Off-Road Free Shipping Lifts Tires Bumpers Tops andIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 11-25-2008, 08:37 AM   #1
meat27
Registered User
 
Join Date: Apr 2008
Location: AL
Posts: 17
4.7 engine swap won't run code P1389 ASD

Just dropped a replacement 4.7L into an '01 GC Ltd.

The motor spins over but won't run.

It stores code P1389. I have found the definition for the code, but I don't have any experience with an "Auto Shutdown..........."

Any ideas on where to start?????


Last edited by meat27; 11-25-2008 at 08:48 AM..
meat27 is offline   Reply With Quote Quick reply to this message
Unread 11-25-2008, 08:44 AM   #2
-Joe-
Registered User
1995 ZJ 
 
Join Date: Jan 2005
Location: Lexington, KY
Posts: 4,634
P1389 (M)
No ASD Relay Output Voltage At PCM

No Z1 or Z2 voltage sensed when the auto shutdown relay is energized.



P1389 (M)
No ASD Relay Output Voltage At PCM

An open condition detected In the ASD relay output circuit.






Loose connection or bad relay?
__________________
- Joe -

'95 Jeep Grand Cherokee Laredo I6 4.0L
242TC - Extreme Engineering 2" Front Lift/1.75" Rear Lift - ES9000 Shocks + JKS BPEs
Moog Cargo Control Springs
Magnaflow Converter - Dynomax Muffler
235/75/15 AT Uniroyal Liberator Tires
-Joe- is offline   Reply With Quote Quick reply to this message
Unread 11-25-2008, 08:50 AM   #3
meat27
Registered User
 
Join Date: Apr 2008
Location: AL
Posts: 17
Just found the problem.

I had seen other people swapping the relays, so I did that, still had problem, and jumped on here.

Then took another look and found and ASD 30A fuse blown. Swapped it and runs good. Duh. Sorry I jumped on here without going through the fuses first.

Thanks for the advice Joe
meat27 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.