4.0L has Spark/fuel...No RPM, No Start - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 4.0L has Spark/fuel...No RPM, No Start

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineFS: Jeep Fog Light LED Bulbs! Several Brightness Options! Clayton Off Road JK Short Arm Suspension Kits

Reply
Unread 01-01-2013, 09:23 PM   #1
beta2225
Registered User
1993 ZJ 
 
Join Date: Apr 2011
Location: st george, utah
Posts: 5
4.0L has Spark/fuel...No RPM, No Start

Hello, I need some help diagnosing an issue...I havent been able to find my exact problem on here after a few hours of searching. I have a 93 jeep grand 4.0L. The other night I came home from work and my jeep was running fine, then the next morning it wouldnt start. When I try and start my jeep, There is no reading at all on the RPM gauge. I thought it may be the CPS, which has gone out before, but it wasnt the issue after testing. The jeep does get good spark at the plugs, and I can hear the fuel pump prime itself before turning the key. The jeep doesnt even try and start at all...it just cranks. Could it be low fuel pressure? But Would that cause the RPM gauge to not read anything during cranking? What about the sensor that has to do with the auto transmission being in neutral or park that ive read about on here? Tomorrow Im going to rent a fuel pressure gauge from oreilly and make sure Im getting enough pressure....I really appreciate any help, thank you!!

beta2225 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.