4.0 start only after check engine light - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 4.0 start only after check engine light

THE NEW! VANCO DUAL MODE 15/16″ Big Brake Kit w/BlaSavvy Billet LED Tail LightsCurrie

Reply
Unread 07-20-2009, 05:18 PM   #1
marinejeep6122
Registered User
1993 ZJ 
 
Join Date: Apr 2009
Location: jacksonville, nc
Posts: 7
4.0 start only after check engine light

my 4.0 hasnt been running very well lately. one day on the road it just up and dies on me. towed it back the next day and tried to start and nothing, tried again later and only after the check engine light comes on does it crank over and start. other then that it just cranks and cranks. the whole starting only after the check light comes on has been the norm while ive owned it.
replaced wires, plugs, fuel filter, crank position sensor. i get pressure in the fuel line. when it does start it will run totally fine for 10-20 minutes. ive been leaning towards a dying ECM. any other ideas? checked all fuses and all are good.

marinejeep6122 is offline   Reply With Quote Quick reply to this message
Unread 07-20-2009, 07:12 PM   #2
marinejeep6122
Registered User
1993 ZJ 
 
Join Date: Apr 2009
Location: jacksonville, nc
Posts: 7
also usually the main fuse box clicks and then a couple quick short clicks then the light comes on
marinejeep6122 is offline   Reply With Quote Quick reply to this message
Unread 07-20-2009, 07:42 PM   #3
RJV
Registered User
2003 TJ Wrangler 
 
Join Date: Nov 2007
Location: HOUSTON, TX
Posts: 122
why is the check engine light on, what code is stored ecm?
RJV is offline   Reply With Quote Quick reply to this message
Unread 07-21-2009, 02:25 PM   #4
marinejeep6122
Registered User
1993 ZJ 
 
Join Date: Apr 2009
Location: jacksonville, nc
Posts: 7
when i can actually get codes, its just 12 (ecm lost power within the last 50 key cycles) and 55 (end codes). i try to check after it dies but a cant pull anything up. i did check the cap and rotor last night and noticed the rotor has a nice divit in it and a nice chunk missing. maybe this causes the stalling?
marinejeep6122 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.