4.0 Stalling when stopping/stopped/idle, and loss of power/bucking when accelerating? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 4.0 Stalling when stopping/stopped/idle, and loss of power/bucking when accelerating?

Rough Country Deals at JeepHut.comSave at JeepHut on Smittybilt Soft topsUp to $75 Cash Back on Your ARB Fridge Freezer Purchase

Reply
Unread 06-08-2012, 08:16 PM   #1
JeepinJordan
Registered User
1996 ZJ 
 
Join Date: Jan 2012
Location: Surprise, Arizona
Posts: 118
4.0 Stalling when stopping/stopped/idle, and loss of power/bucking when accelerating?

Could it be a bad tps or cps, something else? It starts up and runs fine when it wants to, but then at any random stop light, it just studders and stalls. When it does that I just start it back up and it sometimes gives me trouble staying on. Few minutes ago it stalled when I was braking to a stop sign. Also, today it had a hard time accelerating, like it was running out of gas and bucking. This started happening about a month ago, more frequent recently. No CEL or any indication light.

96 GC, 4.0, Has 183,000 miles. Thanks.

EDIT: Forgot to mention, I recently cleaned out my IAC and TB.

EDIT: I started it up today, checked sensors cold and warm (the stalling was worse when driving warm) and nothing seemed to stall out or hesitate. So then my last test was the PCM and the second I touched the first closest connector, it stalled out. PCM IS THE CULPRIT HERE

EDIT: SAME DAY. Let it cool down and then tryed the PCM test again. It did not try to die when touching the connection this time. Cleaned the PCM ground by the oil dipstick tube, started it up and drove for a little. Died two times around my community, started right up. Drove back home and let it run in my driveway, while trying to mess with the pcm for the third time. Did not try to stall.

EDIT: SAME DAY. reset the PCM, followed this: http://www.jeepforum.com/forum/f13/q...et-pcm-948495/
Seems to run fine, no stalling yet, drove it around the block a good 4-5 miles

JeepinJordan is offline   Reply With Quote
Unread 06-08-2012, 08:26 PM   #2
vol96
Registered User
1997 ZJ 
 
Join Date: Apr 2005
Posts: 58
wiggle some wires at the sensors that would be my guess since it sounds random and sudden.
vol96 is offline   Reply With Quote
Unread 06-08-2012, 08:37 PM   #3
hdrocknroll
Registered User
1995 ZJ 
 
Join Date: Dec 2011
Location: Flint, MI
Posts: 2,271
Take a look at my thread !
NO, start,started, now it's dying. While Ideling
__________________
Always !! Keep A Firm Grip On Your Tool !!

Watch Out For The Air Hose Gone Wild!! Or Wear A Cup,: True Story


[QUOTE=rooster51;13297693] Whats the worse that can happen? Your jeeps already broke.



[/QUOTE]
hdrocknroll is offline   Reply With Quote
Unread 06-08-2012, 09:02 PM   #4
JeepinJordan
Registered User
1996 ZJ 
 
Join Date: Jan 2012
Location: Surprise, Arizona
Posts: 118
Quote:
Originally Posted by hdrocknroll View Post
So the sensors didn't do a damn thing? Just bad connections? I thought it was my battery terminals and posts last week because it wouldnt start up at all and the under hood light was flickering dim, all after a day of stalling at every stoplight. So i used a battery terminal brush and cleaner. started up and ran fine for a couple of days, but then the stalling started to happen again.
__________________
-Bone stock 1996 Jeep Grand Cherokee Laredo 4.0L
JeepinJordan is offline   Reply With Quote
Unread 06-08-2012, 09:08 PM   #5
JeepinJordan
Registered User
1996 ZJ 
 
Join Date: Jan 2012
Location: Surprise, Arizona
Posts: 118
IT DOES THIS! I cant believe I found this on youtube, its exactly the same.

http://www.youtube.com/watch?feature...5IVqURR2E&NR=1
__________________
-Bone stock 1996 Jeep Grand Cherokee Laredo 4.0L
JeepinJordan is offline   Reply With Quote
Unread 06-08-2012, 09:52 PM   #6
hdrocknroll
Registered User
1995 ZJ 
 
Join Date: Dec 2011
Location: Flint, MI
Posts: 2,271
If I remember right those guys want you to pay them to tell you to put zip ties on your PCM.
Don't pay them.
It could be your crank sensor, it could be your PCM, it could be you need to clean your grounds,it could be a fuel problem, or something else.
But it won't cost you anything you clean your grounds.
I just thought it would be good to read my thread to get some ideas.
Good luck
__________________
Always !! Keep A Firm Grip On Your Tool !!

Watch Out For The Air Hose Gone Wild!! Or Wear A Cup,: True Story


[QUOTE=rooster51;13297693] Whats the worse that can happen? Your jeeps already broke.



[/QUOTE]
hdrocknroll is offline   Reply With Quote
Unread 06-08-2012, 10:07 PM   #7
JeepinJordan
Registered User
1996 ZJ 
 
Join Date: Jan 2012
Location: Surprise, Arizona
Posts: 118
Quote:
Originally Posted by hdrocknroll View Post
If I remember right those guys want you to pay them to tell you to put zip ties on your PCM.
Don't pay them.
It could be your crank sensor, it could be your PCM, it could be you need to clean your grounds,it could be a fuel problem, or something else.
But it won't cost you anything you clean your grounds.
I just thought it would be good to read my thread to get some ideas.
Good luck
Oh no, I checked the website and it was sketch as hell. But yes I will check the grounds and putt putt around untill it starts acting up again. I just would like to know what sensor it is more likely to be. Not trying to replace something I dont need with something not OEM.
__________________
-Bone stock 1996 Jeep Grand Cherokee Laredo 4.0L
JeepinJordan is offline   Reply With Quote
Unread 06-08-2012, 10:14 PM   #8
hdrocknroll
Registered User
1995 ZJ 
 
Join Date: Dec 2011
Location: Flint, MI
Posts: 2,271
I would say most likely sensor would be crank sensor
__________________
Always !! Keep A Firm Grip On Your Tool !!

Watch Out For The Air Hose Gone Wild!! Or Wear A Cup,: True Story


[QUOTE=rooster51;13297693] Whats the worse that can happen? Your jeeps already broke.



[/QUOTE]
hdrocknroll is offline   Reply With Quote
Unread 06-08-2012, 10:23 PM   #9
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,340
Did you wiggle the PCM plugs while idling? Sounds familiar.
ZeeJay1997 is online now   Reply With Quote
Unread 06-08-2012, 10:27 PM   #10
JeepinJordan
Registered User
1996 ZJ 
 
Join Date: Jan 2012
Location: Surprise, Arizona
Posts: 118
Quote:
Originally Posted by ZeeJay1997 View Post
Did you wiggle the PCM plugs while idling? Sounds familiar.
yeah, did nothing.
__________________
-Bone stock 1996 Jeep Grand Cherokee Laredo 4.0L
JeepinJordan is offline   Reply With Quote
Unread 06-09-2012, 09:50 AM   #11
JeepinJordan
Registered User
1996 ZJ 
 
Join Date: Jan 2012
Location: Surprise, Arizona
Posts: 118
Well guys its not any sensors. It is my PCM. Warmed it up and messed with every sensor, then last I messed with the PCM connections and it kept stalling out.

I have work tonight, any info on how to rig this for a day or two untill I get a day off. I've seen zip ties?
I will probably end up cleaning out the pcm before I buy a new one. Just dont think I have time today.
JeepinJordan is offline   Reply With Quote
Unread 06-09-2012, 09:56 AM   #12
JeepinJordan
Registered User
1996 ZJ 
 
Join Date: Jan 2012
Location: Surprise, Arizona
Posts: 118
Advixe would be appreciated. I never cleaned one, only seen a write up with only words, no pictures. If the cleaning doesnt work, where should I go about getting a new PCM without being raped, lol I hear they arent cheap.
__________________
-Bone stock 1996 Jeep Grand Cherokee Laredo 4.0L
JeepinJordan is offline   Reply With Quote
Unread 06-09-2012, 10:53 AM   #13
Oldfrog
Web Wheeler
1997 ZJ 
 
Join Date: Feb 2008
Location: Louisiana/Texas
Posts: 3,785
Cleaning the plugs only resets it most of the time, because you'll need to disconnect the battery before cleaning it.
Go get an "A-1 Cardone" brand PCM from Oreilly's for $249 or so and be done with it. Do NOT order one online from either of those outfits in Florida.

There's also a good write up on this site showing how to fix it yourself if you're so inclined.
__________________
Cajun Recipes and Fishing tips

Words of wisdom, Posted by Zeejay:
"..it's not air, it is the opposite of air... suckage so to speak."

Stalling? Work through Zeejay's list
Oldfrog is offline   Reply With Quote
Unread 06-09-2012, 10:59 AM   #14
JeepinJordan
Registered User
1996 ZJ 
 
Join Date: Jan 2012
Location: Surprise, Arizona
Posts: 118
Read my recent EDITS. I am lost!
__________________
-Bone stock 1996 Jeep Grand Cherokee Laredo 4.0L
JeepinJordan is offline   Reply With Quote
Unread 06-27-2013, 06:34 PM   #15
Jcamaro123
Registered User
1995 ZJ 
 
Join Date: Mar 2013
Location: Souderton, pa
Posts: 17
please advise on where this write up is...

Quote:
Originally Posted by Oldfrog View Post
There's also a good write up on this site showing how to fix it yourself if you're so inclined.
where's this write up - I would like to try this. Thank You
(My 95 GC 5.2 is stalling out at stop sign)
Jcamaro123 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.