4.0 Lost Power, thoughts? - JeepForum.com

LinkBack Thread Tools
post #1 of 2 Old 08-22-2013, 04:55 PM Thread Starter
Registered User
1996 ZJ 
Join Date: Apr 2013
Location: Tucson
Posts: 176
4.0 Lost Power, thoughts?

It was 99 today and I drove about 20-30 miles in about 4 hours (delivery driver). I was just cruising at about 35mph when all of a sudden there was no throttle response. All the gauges were fine beforehand. Engine temp didn't go above 210-215 once. Now when I was trying to restart it the temp gauge was dead which is odd since my engine was obviously hot. My first thought is that my thermostat went out but I replaced that around 2 months ago. This happened about an hour ago so once the sun drops and my engine has cooled off I'll try starting it and brining it home.

Any thoughts/advice?


Out doing Jeep things..

Sent from my Nexus S using JeepForum

Matte Black '96 ZJ 4.0
IRO 3.5" Benchmark Lift, Bilstein 5100's, 31x10.5x15 Westlake SL369 A/T's, Moog Super Trail Boss SS, KOR Rad Support, Chopped-up Front Bumper
zRoxxah is offline  
Sponsored Links
post #2 of 2 Old 08-22-2013, 06:40 PM
Registered User
1997 ZJ 
Join Date: Dec 2008
Posts: 8,721
wiggle the connectors on the PCM or just disconnect and reconnect them. sounds like bad solder joints or connectors.
ZeeJay1997 is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome