4.0 getting terrible gas mileage.. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 4.0 getting terrible gas mileage..

Trick Tabs - NalinMFG.comWarn, Smitybilt, Engo, Rugged Ridge Winches at CCORClayton Off Road XJ Long Arm Suspension Systems!

Reply
Unread 07-21-2013, 01:21 PM   #1
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
4.0 getting terrible gas mileage..

My moms mentioned to me her 4.0 was getting bad gas mileage so I took it for a spin and I have been driving it around for awhile and I noticed the same thing..

The overhead is pretty accurate on my both my Jeeps usually off by only about .5mpg.. Her 4.0 gets good mileage on the freeway, we did 2 800 mile trips recently and she got about 20-21mpg going 70mph with cruise control on.. However in the city her mileage is worse then my 5.9.. I cant get it to go over 12mpg.. in fact its more around 11-11.5mpg

Any idea's on why the highway is good but city is bad ? Granted there are a lot of stop lights in this town I live, but I've driven the 4.0 before I had my 5.9 I was easily able to get 15-16mpg city with this thing..

The spark plugs are fairly new champion copper plugs, the wires/rotor/distributor and ignition coil are probly 4 years old now. It doesn't burn oil at least from what I have seen on the dipstick.. Nore does it burn coolant that I know of.. I cant think of why the mileage would be worse then niner lol

__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote
Unread 07-21-2013, 01:30 PM   #2
RoldGold
Registered User
1996 ZJ 
 
Join Date: Jun 2013
Location: Philadelphia, PA
Posts: 283
How old are the oxygen sensors? Maybe it's running rich, but that wouldn't really explain why the mileage suffers in the city and not on the highway. Something to keep in mind though, you could always unplug the upstream sensor and see how it runs.
__________________
1996 Grand Cherokee Limited 4.0L
PSC Steering Gear; NP249 w/ new VC; Moog TRE's, Track Bar, Stabilizer bar bushings and endlinks, control arm bushings
Still no lift, and almost no paint on the hood
RoldGold is offline   Reply With Quote
Unread 07-21-2013, 05:39 PM   #3
Oldfrog
Web Wheeler
1997 ZJ 
 
Join Date: Feb 2008
Location: Louisiana/Texas
Posts: 3,640
My first guesses are TPS, Bad gas, upstream o2 sensor.
( or the gold bullion in the cargo area !)
__________________
Cajun Recipes and Fishing tips

Words of wisdom, Posted by Zeejay:
"..it's not air, it is the opposite of air... suckage so to speak."

Stalling? Work through Zeejay's list
Oldfrog is online now   Reply With Quote
Unread 07-21-2013, 06:20 PM   #4
JasonStebbins
Registered User
1997 ZJ 
 
Join Date: Jan 2009
Posts: 3,138
A bad IAC would cause the system to run rich to balance the fuel/air ratio. I also agree that upstream oxygen sensor would do something similar. How is the condition of the exhaust system? After four years I would replace the ignition system again personally, but that's just how I am. Have the fuel injectors/intake/intake manifold ever been cleaned thoroughly?
JasonStebbins is offline   Reply With Quote
Unread 07-22-2013, 11:06 AM   #5
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
I have used seafoam in the engine once in the past maybe a year or two ago.. Not that long ago. But no I have never had the throttle body off and cleaned it before. The O2 sensors are original, The exhaust system is new. It has a new muffler, and the cat is only maybe 2-3 years old. The Jeep does have an issue where when you drive to say a stop light and slow down and stop sometimes the Jeep idles really low like its going to die but then goes back to normal.. From what I read that's typical of these 4.0's and no one really knows why it does that I guess. The engine has like 203k miles on it now original tranny too and it runs ok

Maybe I should look into replacing the O2 sensor, and taking the throttle body off and cleaning the crap out of it.. I tried to remove the IAC and TPS along time ago but the bolts are pretty much like welded on over the years they keep stripping my torx bits and now the bolts themselves are stripping where the bit goes in.. So if I take the throttle body off maybe I can carve a ( l ) in it for a flat head screw driver or something.

What would unplugging the Upstream O2 sensor do ? What would I be looking for besides a check engine light lol ?
__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote
Unread 07-22-2013, 11:42 AM   #6
Donnyd21
Registered User
1998 ZJ 
 
Join Date: Sep 2012
Location: Moore, Oklahoma
Posts: 165
DO NOT unplug and run it, just replace it and call it a day. Stay with OEM.
Donnyd21 is offline   Reply With Quote
Unread 07-22-2013, 04:08 PM   #7
RoldGold
Registered User
1996 ZJ 
 
Join Date: Jun 2013
Location: Philadelphia, PA
Posts: 283
Quote:
Originally Posted by Donnyd21 View Post
DO NOT unplug and run it, just replace it and call it a day. Stay with OEM.
This is not a problem. You can run your car with the o2 sensor unplugged safely. I have done it before, with the sensor unplugged for about 2 weeks.

Unplugging the upstream sensor tells the computer to run in open loop mode, or in other words, the computer sends the default amount of fuel (12.7:1 I think, something like that) and doesn't adjust that amount from any of the sensor data. This is useful in determining whether the upstream o2 sensor is causing your fuel system to run rich or lean. If, after unplugging the o2 sensor, the Jeep runs more smoothly and problem free, you can confidently identify the upstream o2 sensor as the problem causing sensor and therefore know to replace it. If there is no change, then replacing the upstream o2 sensor is not necessary.

Unplugging the sensor will definitely give you a CEL/MIL, because the computer is expecting that sensor to be working, which is won't be. Installing the new sensor could be tough though, those sensors tend to get melted into the exhaust pipe because of the heat. I had to bring my Jeep to a garage because I don't have a lift and couldn't get enough leverage on the ground, and didn't want to use a torch so close to the fuel lines.

You have to replace the upstream sensor with an NTK or Mopar sensor. I am running an NTK upstream sensor and a Denso downstream sensor. The downstream sensor is of less importance because, to the best of my knowledge, only measures catalytic converter efficiency; still I don't recommend using a Denso sensor, Jeep's are finicky about sensors for whatever reason, and the general consensus here is that Mopar or NTK is the way to go.

EDIT: After re-reading your post, I experienced the EXACT same symptoms when my o2 sensor was failing, near stalling at stop lights and poor gas mileage. I'd have to give it a good amount of throttle before it responded and resolved it's temporary stalling. I can almost guarantee those o2 sensors are in need of replacement, especially after 200k+ miles. The IAC can be cleaned, but the TPS can only be replaced. It can't hurt to clean out the throttle body and IAC, and you can test the TPS with a voltmeter, the procedure is explained in the FSM.
__________________
1996 Grand Cherokee Limited 4.0L
PSC Steering Gear; NP249 w/ new VC; Moog TRE's, Track Bar, Stabilizer bar bushings and endlinks, control arm bushings
Still no lift, and almost no paint on the hood
RoldGold is offline   Reply With Quote
Unread 07-22-2013, 09:47 PM   #8
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
Yea I know how to test the tps I've done it on my 5.9, and I've cleaned my 5.9's IAC before, and I replaced my 5.9's upstream like 2-3 weeks ago with a NTK brand.. Thankfully I didn't need to use any muscle at all to get it to unscrew... Altho my 5.9 has no rust.. the 4.0 on the other hand... is starting to rust lol.. so I bet that one will be a pain. we'll see.. I just have no money atm.. I spent $200 on a new muffler and to get it installed, and I spent $65 on a new power steering pump to pass inspection which is now leaking at the 2nd day... GAHHH these damn ZJ's are making me gray and old fast.. the Just empty every pocket thing is 1000% true.. I literally spend every dime on both of them to maintain them
__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote
Unread 07-22-2013, 11:14 PM   #9
98GCLimited
Registered User
1998 ZJ 
 
Join Date: Jun 2009
Location: LHC, AZ
Posts: 480
My 4.0 gets 12mpg at best calculated by miles driven vs gallons used not the overhead crap. Its got new plugs cap/rotor and wires less than 6k miles ago, 703 injectors, and got new mopar o2 sensors up n downstream less than 2k miles ago but is on 31s with heavy cragar wheels and 3:55s and lifted 3.5" so I figure thats about as good as Im going to get for in town mileage.
98GCLimited is offline   Reply With Quote
Unread 07-23-2013, 06:54 AM   #10
RoldGold
Registered User
1996 ZJ 
 
Join Date: Jun 2013
Location: Philadelphia, PA
Posts: 283
Well keep us informed candyman, I'm curious what the fix is.

My 96 4.0 started out at 12mpg when I bought it, on stock wheels and stock everything with 3.55.

Since I've cleaned the IAC, and replaced the o2 sensors (downstream was completely missing), 703 injectors, brought me to 14-15mpg.

Weirdly, after replacing the viscous coupler, the mileage jumped up to about 18mpg. I can't be sure on this since I don't have a large enough sample size to be sure, but that's about what I'm calculating now. I guess the shot viscous coupler absorbed a lot of power.
__________________
1996 Grand Cherokee Limited 4.0L
PSC Steering Gear; NP249 w/ new VC; Moog TRE's, Track Bar, Stabilizer bar bushings and endlinks, control arm bushings
Still no lift, and almost no paint on the hood
RoldGold is offline   Reply With Quote
Unread 07-23-2013, 10:30 PM   #11
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
Well Our 4.0 has the select trac. I've replaced the viscous coupler in my 5.9 I didn't gain any mpg doing that on that Jeep.. As for the computer being crap on calculating mpg.. Perhaps when your lifted and have bigger tires it is.. But with stock or near stock size (she has 29's I have close to 31's on my 5.9) its very accurate.. I've measured my tank on my 5.9 like 6 times in a row and always get around 11-11.5mpg.. The overhead is always reading 10.9-11.6 mpg so its really only off by about .5mpg.

I haven't done that check with the 4.0 in sometime tho, but last I did it was accurate too
__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote
Unread 07-24-2013, 08:10 AM   #12
JS97ZJ
Registered User
1997 ZJ 
 
Join Date: Dec 2009
Location: Dingmans Ferry, PA
Posts: 2,015
It's been discussed by many that the cooper plugs is the way to go with these ZJ's. But through reading many posts over the years, it seems that most people here have problems with the cooper plugs in the V8's.
When I first got my Z with 35k on it (2000), it was getting 11 mpg. I did the obvious, plugs (cooper), wires, cap, rotor etc. but only increased it to 15-16mpg.
It wasn't until I installed platinum plugs (not Bosch) that I started getting 19-20 mpg. And I've been using them ever since. My Jeep has 238,000 on it and still gets that mpg's. I also use only 87 oct. (anything higher screws up the mileage and performance) and dump a couple of bottles of injector cleaner every 6 months.
6 months ago I had to put in a new exhaust system and soon after lost the leads to the down stream 02 sensor to the drive shaft. So I can only say that the downstream sensor is only monitoring the cat because the mileage hasn't changed one bit. Ratmonkey once said that it effected the performance and mpg, because it fine tuned the burn. I haven't witnessed that at all.
Everything on my engine is original to the vehicle except the 02's and alternator and water pump.
I keep the IAC, CCV and clean all the obvious stuff that would effect mileage.
JS97ZJ is offline   Reply With Quote
Unread 07-24-2013, 04:18 PM   #13
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
I've never heared of cooper plugs.. Do you mean Copper lol ? I use Champion Coppers in my I6 and my V8.. YC12 or was it LC12 I cant remember off hand
__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote
Unread 07-24-2013, 09:50 PM   #14
JS97ZJ
Registered User
1997 ZJ 
 
Join Date: Dec 2009
Location: Dingmans Ferry, PA
Posts: 2,015
Quote:
Originally Posted by Candymancan View Post
I've never heared of cooper plugs.. Do you mean Copper lol ?
You just passed the comprehension part of the ZJ forum.........

But seriously try a set of platinum's on that 4.0.
JS97ZJ is offline   Reply With Quote
Unread 07-24-2013, 10:11 PM   #15
newfieZJ
Registered User
1995 ZJ 
 
Join Date: May 2008
Location: , Alberta
Posts: 6,391
Don't overlook a brake drag issue . Perhaps a caliper is starting to stick a little , might not be noticeable so much on the hwy , in the city you always got your foot in the brake . That could kill a few mpg's .

Quote:
But seriously try a set of platinum's on that 4.0.
I run Champion dble platinum's in my V8's . I tried stock , tried NGK , these out perform everything . Took 40K out of the first set and they were still fine . Didn't even see an improvement over the new . Should have left them in for another 20K+ . Mileage is great too , no complaints .

Candyman , I also agree the overhead is semi-accurate . I find a little more off than .5mpg but never calculated it out to be more than 2 off , stock or lifted jeeps with proper speedo gear . On mine , the overhead is always lower than the calculated , even on my new Ram .
newfieZJ is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.