4.0 GC Quits running - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 4.0 GC Quits running

Nitro Gear Packages Now Available at Rockridge 4wdPoison Spyder JK LED Taillight Wiring HarnessZONE 4.25" combo lift for TJ available at Rockridge4w

Reply
Unread 12-06-2006, 02:50 PM   #1
simsup
Registered User
 
Join Date: Dec 2006
Location: Houston
Posts: 1
4.0 GC Quits running

My 1999 GC Laredo quits running (turns off). It was just a idle but now it happens when going 45-50 mph. The code that is set is P320. After it quits you can crank the engine and it just cranks and nother happens. Seems that turning the key off then back on then cranking will allow it to start. This restart only takes a 5 secs or so. Not sure if the key off thing is a clue or not. Code says crank sensor not seen during cranking. I have checked the cable and ground. Seem good. I am thinking about swapping the crank sensor out. Fuel pressure is good.
So can these crank sensors fail intermittent and if it did should I get some other codes? This is the only one that I get. Also I have reset the codes and when it quits the P320 reappears. Any ideas out there?

simsup is offline   Reply With Quote Quick reply to this message
Unread 12-06-2006, 02:54 PM   #2
ArloGuthroJeep
Mr. Hyde!
 
ArloGuthroJeep's Avatar
2004 WJ 
 
Join Date: Mar 2005
Location: Boulder, CO
Posts: 23,084
Replace the CPS and go from there.
__________________
'04 WJ, 6" Clayton LA's, 242 SYE, 35" BFG MT KM2's, 4.56 gears, & D44a locked
'14 WK2 Limited w/5.7L, ORAI, & Tow Package
ArloGuthroJeep is offline   Reply With Quote Quick reply to this message
Unread 12-06-2006, 03:02 PM   #3
mdsuave13
Registered User
1997 ZJ 
 
Join Date: Sep 2006
Location: Maryland
Posts: 746
yea.. the codes that come up, come up for a reason usually, unless you completely submerge your jeep in water during a river crossing, and everything starts coming up till it all dries out
__________________
Safari'd out ZJ.
mdsuave13 is offline   Reply With Quote Quick reply to this message
Unread 10-21-2014, 06:31 AM   #4
clcrump
Registered User
 
Join Date: Jul 2013
Posts: 7
Simsup,
Did you ever get this problem figured out? My 2002 jeep wrangler is doing what sounds like the exact same thing. What did you find?
clcrump is offline   Reply With Quote Quick reply to this message
Unread 10-21-2014, 03:34 PM   #5
mikem350
Registered User
1994 ZJ 
 
Join Date: Sep 2014
Location: Sunrise, FL
Posts: 82
First thing is to scan for codes...and try to clear them! The engine computer self diagnoses. Then repost for advice....
__________________
Proud owner of TWO 4.0 Laredos
Red 94 w/133k, mint!
Silver 98 w/249k runs as new!
mikem350 is offline   Reply With Quote Quick reply to this message
Unread 10-21-2014, 11:49 PM   #6
shaban
Registered User
1996 ZJ 
 
Join Date: May 2012
Location: Yarraville, VIC, AU
Posts: 464
Use Mopar sensors, others may work but can give a lot of troubles.
shaban is offline   Reply With Quote Quick reply to this message
Unread Yesterday, 08:21 PM   #7
clcrump
Registered User
 
Join Date: Jul 2013
Posts: 7
It's not showing any codes ... Except when I turned the key off and on three times, it showed p0320. Is that for the crank sensor?
clcrump is offline   Reply With Quote Quick reply to this message
Unread Yesterday, 08:40 PM   #8
shaban
Registered User
1996 ZJ 
 
Join Date: May 2012
Location: Yarraville, VIC, AU
Posts: 464
That's:

P0320 Ignition/Distributor Engine Speed Input Circuit Malfunction

Possibly the crank sensor or cam angle sensor in the distributor.

I'd replace the crank angle with a new Mopar part and go from there.
shaban is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.