4.0 Engine Sqeaking/Noise? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 4.0 Engine Sqeaking/Noise?

FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits

Reply
Unread 09-13-2009, 07:37 PM   #1
easydog84
Registered User
1998 ZJ 
 
Join Date: Sep 2009
Location: VA
Posts: 1
4.0 Engine Sqeaking/Noise?

Hello,
I have a 98 ZJ 4.0, that has a squeaking noise. It all started after I replaced some parts. The following is what has happened and any help would be appritated. The radiator was leaking. I replaced the radiator and desided to do the water pump and thermostat at the same time. So I replaced all that and then test drove the jeep and it was running fine. All of a sudden a couple days later it started squeaking. I then desided to jump in and see what is going on. I thought at first maybe I had a defective water pump, and had a couple of people take a look at it and say it looked defective. So I pulled the pump back off and took the water pump back and replaced it again. The sqeaking was still there. Then I thought well maybe it's the idler pulleys going bad so I replaced both of the pulleys.(The adjustable one and the stationary one) That did not take care of it. I started testing where the noise was coming from, I thought it was the A/C unit. I went down to advanced auto parts and picked up an A/C eliminator pulley and tried that. Still there. At that point I was very frustrated and pulled the altenator off and took that down to advanced auto parts and had that tested. That turned out good. Now at this point I was thinking it was the power steering pump pulley but I would think if that was going bad I would here it squeal when turning the wheel. And it squeals no matter what is going on. I rinsed off the belt before I put it back on this time and the noise was gone. Then I am guessing here that after the belt dried off it started sqealing again. So I sprayed some water on the belt while the jeep was running and the noise went away. Then it would come back. It does that all the time. After I spray a little water or PB blaster on the belt, the noise will go away. Then come back after a souple of minutes. And that's where I am at.

easydog84 is offline   Reply With Quote
Unread 09-13-2009, 07:41 PM   #2
jmfirefighter20
Registered User
2012 JK Wrangler 
 
Join Date: Feb 2007
Location: Raymond, NH
Posts: 84
Maybe try a different belt? Did you put on a new belt when you did all the work? Try a Goodyear Gatorback belt....they're supposed to be better than the standard ribbed ones, I use one (but didn't have a squeaking noise or anything before hand...my belt was going.) The belt was about $26 or &28 and some change at Autozone.
__________________
'12 JKU

'90 Jeep Wrangler YJ
1975 IHC Fleetstar 2010A Fire truck
'01 Jeep GC Laredo (SOLD)
1962 IHC BC-160 Fire Hose Wagon (SOLD)
jmfirefighter20 is offline   Reply With Quote
Unread 09-13-2009, 08:25 PM   #3
gy2000
Registered User
1998 TJ Wrangler 
 
Join Date: Mar 2009
Location: York, ON
Posts: 4
My was doing the samething. but I'm sure the power steering pully went bad. When the rpm goes higher, it sounds louder.
gy2000 is offline   Reply With Quote
Unread 09-14-2009, 09:02 PM   #4
rooster51
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Virginia Beach
Posts: 1,634
you need to re-tighten your belt by adjusting your tensioner pully. when you worked on your waterpump the belt was cold. After driving it a couple days your belt has heated-up and streched a bit.
yes, ive done this the past 3 times ive moved/removed/replaced my belt for any reason.
__________________
Terry
rooster51 is offline   Reply With Quote
Unread 09-14-2009, 11:09 PM   #5
Myetball
Registered User
1998 ZJ 
 
Join Date: Aug 2007
Location: San Antonio, TX
Posts: 105
I went through the same problem recently. Would squeal non-stop when hot and only sometimes when cold. Cost me a new water pump and reman alternator and replaced the fan clutch under warranty. Still squealed like crazy. Finally got under the Jeep with a piece of hose, one end jammed in my ear, the other probing around for the source. Turned out sound was coming from the harmonic balancer. Bought a new one and a new timing cover seal.

When I pulled it apart I noticed absolutely zero oil getting to the seal from inside the cover. The seal was well worn and had worn a nice shiny groove in the balancer. Since the seal wasn't getting any oil, I lubed the new one with some grease and installed the new balancer. Squeal gone.
Myetball is offline   Reply With Quote
Unread 09-15-2009, 06:37 AM   #6
doublejz
Registered User
2004 WJ 
 
Join Date: Jun 2007
Location: PA
Posts: 484
Every time I got the sqeaking with my 4.0 zj it turned out to be the water pump. Maybe you got a bad one when you replaced yours. Which I later found that I had a bad harominic balancer aka crank pulley which was causing the belt to wobble and therefore taking out the waterpump.
__________________
04 WJ with some stuff - see here
doublejz is offline   Reply With Quote
Unread 09-15-2009, 07:12 PM   #7
sandman
Registered User
1993 ZJ 
 
Join Date: Apr 2007
Location: Wilsonville, Oregon
Posts: 5,354
does everything spin true? when i had a squeak it was my harmonic balancer and when i looked at it spinning i could tell it had a slight wobble.
__________________
1993 Jeep ZJ. 4.0
sandman is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.