2nd thread - Pulling trans codes (O/D Off light always on) No first or OD? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 2nd thread - Pulling trans codes (O/D Off light always on) No first or OD?

FS: Wranger BRIGHT License Plate LED! Just $3! Great valueThanksgiving/Black Friday/Cyber Monday Deals at JeepinOutfBlack Friday Sale!!

Reply
Unread 09-24-2014, 06:33 PM   #1
JaimeZX
Registered User
1995 ZJ 
 
Join Date: Sep 2014
Location: Arlington, VA
Posts: 49
2nd thread - Pulling trans codes (O/D Off light always on) No first or OD?

Did some research at work, but it hasn't scratched my itch.

'95 ZJ Laredo (if that matters.)
42RE tranny.

Symptoms:
1) Pulling away from a stop it feels like I'm in 2nd gear.
2) Tranny never shifts into overdrive.
3) O/D Off light illuminated at all times.

CEL is not illuminated.

I read to pull the ECM codes, turn the key to the "run" position and then off again four times, then at the fifth, leave it on. The CEL will blink out the codes.
I read to pull the TCM codes, turn the key to the "run" position and then off again two times, then at the third, leave it on. The O/D Off light will blink out the codes.

RESULTS:
* It does not matter whether I turn the key on/off two, three, four, or five times. I get the same result.
* The O/D Off light does not blink, it stays on solid.
* The CEL gives me 12, 55.

NOW
ECM code 12 is "Battery power disconnected in last 50 key cycles." Now why that matters I have no idea, but it's true that the Jeep has a new battery as of about a month ago, which may well be fewer than 50 cycles.
TCM code 12 is "Output shaft sensor input."

Not sure what I'm missing here. If my technique sounds poor I can post a vid.

Thanks in advance!

JaimeZX is offline   Reply With Quote Quick reply to this message
Unread 09-24-2014, 08:43 PM   #2
herqulees
Registered User
1997 ZJ 
 
Join Date: Aug 2012
Location: Nashville, Tennessee
Posts: 177
Quote:
Originally Posted by JaimeZX View Post
Did some research at work, but it hasn't scratched my itch.

'95 ZJ Laredo (if that matters.)
42RE tranny.

Symptoms:
1) Pulling away from a stop it feels like I'm in 2nd gear.
2) Tranny never shifts into overdrive.
3) O/D Off light illuminated at all times.

CEL is not illuminated.

I read to pull the ECM codes, turn the key to the "run" position and then off again four times, then at the fifth, leave it on. The CEL will blink out the codes.
I read to pull the TCM codes, turn the key to the "run" position and then off again two times, then at the third, leave it on. The O/D Off light will blink out the codes.

RESULTS:
* It does not matter whether I turn the key on/off two, three, four, or five times. I get the same result.
* The O/D Off light does not blink, it stays on solid.
* The CEL gives me 12, 55.

NOW
ECM code 12 is "Battery power disconnected in last 50 key cycles." Now why that matters I have no idea, but it's true that the Jeep has a new battery as of about a month ago, which may well be fewer than 50 cycles.
TCM code 12 is "Output shaft sensor input."

Not sure what I'm missing here. If my technique sounds poor I can post a vid.

Thanks in advance!
Your transmission lost contact with its output shaft. Code 12 - No Output Shaft Sensor Signal. Doing a quick search I came up with this diagram on Google for where to find the sensor.

Check the wiring for damage and unplug/clean/replug the sensor to see if that helps, if not replace the sensor and it's pretty much guaranteed you're good to go.
herqulees is offline   Reply With Quote Quick reply to this message
Unread 09-24-2014, 09:02 PM   #3
JaimeZX
Registered User
1995 ZJ 
 
Join Date: Sep 2014
Location: Arlington, VA
Posts: 49
Okay - that is perfectly logical. I'm still just confused why everywhere I've looked it says the O/D Off light is supposed to blink, but in my case it's the CEL.

I will def. check that wiring this weekend.
JaimeZX is offline   Reply With Quote Quick reply to this message
Unread 09-25-2014, 01:06 PM   #4
zjosh93
Registered User
1993 ZJ 
 
Join Date: Aug 2010
Location: Austin
Posts: 1,300
The OD light will blink the trans codes. How long are you waiting for the trans codes. IMS on my 93 it blinks the ECM codes with the check engine light first then the TCM codes on the OD light. Your 95 might be different because your TCM is part of the ECM and on the 93 it's separate. Even with no codes the OD light should still give you a 55. Might check the wiring and plugs on the trans as they can get dirty and loose.
zjosh93 is offline   Reply With Quote Quick reply to this message
Unread 09-25-2014, 01:16 PM   #5
JaimeZX
Registered User
1995 ZJ 
 
Join Date: Sep 2014
Location: Arlington, VA
Posts: 49
Interesting; did not know it blinked afterwards. I was just turning the ignition off after the CEL blinked. Thanks!
__________________
Set your radio clock!! http://www.jeepforum.com/forum/f13/1993-zj-radio-cassette-clock-623659/
JaimeZX is offline   Reply With Quote Quick reply to this message
Unread 09-25-2014, 01:24 PM   #6
zjosh93
Registered User
1993 ZJ 
 
Join Date: Aug 2010
Location: Austin
Posts: 1,300
I think it did on mine but that was a while back. Here's a video of how it's supposed to go:

On that ZJ it seems to blink pretty soon after the key is turned.
zjosh93 is offline   Reply With Quote Quick reply to this message
Unread 09-25-2014, 02:23 PM   #7
JaimeZX
Registered User
1995 ZJ 
 
Join Date: Sep 2014
Location: Arlington, VA
Posts: 49
Welp. I'll try again this evening and we'll see what happens. I may also video.
__________________
Set your radio clock!! http://www.jeepforum.com/forum/f13/1993-zj-radio-cassette-clock-623659/
JaimeZX is offline   Reply With Quote Quick reply to this message
Unread 09-25-2014, 11:18 PM   #8
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss, Italy
Posts: 16,372
Trans starting in second with o.d. locked out means it's in limp mode.
PolkaPower is online now   Reply With Quote Quick reply to this message
Unread 09-26-2014, 06:24 AM   #9
JaimeZX
Registered User
1995 ZJ 
 
Join Date: Sep 2014
Location: Arlington, VA
Posts: 49
Right.

There is always the possibility that I *am* doing this right, and that 5-turns is giving me ECM codes and 3-turns is giving me TCM codes, and I *just happen to have* a 12 on both, so it *appears* it's the same...
I'll look underneath tonight to see if I can figure this out.
__________________
Set your radio clock!! http://www.jeepforum.com/forum/f13/1993-zj-radio-cassette-clock-623659/
JaimeZX is offline   Reply With Quote Quick reply to this message
Unread 09-26-2014, 06:32 PM   #10
inkedrockstaar
Registered User
1994 ZJ 
 
Join Date: Sep 2014
Location: mount vernon, ohio
Posts: 13
i was having about the same problem as yours but mine is a 94. I junk-yarded a few tcm's and one happened to solve my problems but my o/d light didn't work at all, even when cycling the key. and if you put mine in drive it would go into 3rd gear, no 4th or o/d. manually shifting into 1st would put it in 2nd.. but I don't remember what year they stopped with the tcm and ecm being different. Just throwing it out there if you have a tcm. maybe it malfunctioned? and I think the tcm was in zjs 42re i6 until 96?

Last edited by inkedrockstaar; 09-26-2014 at 06:34 PM.. Reason: incomplete
inkedrockstaar is offline   Reply With Quote Quick reply to this message
Unread 09-26-2014, 06:39 PM   #11
zjosh93
Registered User
1993 ZJ 
 
Join Date: Aug 2010
Location: Austin
Posts: 1,300
It's three turns for both the engine and trans codes. Just checked mine. The trans codes are at the same time as the engine codes.
zjosh93 is offline   Reply With Quote Quick reply to this message
Unread 09-26-2014, 08:05 PM   #12
inkedrockstaar
Registered User
1994 ZJ 
 
Join Date: Sep 2014
Location: mount vernon, ohio
Posts: 13
12 and 55?
inkedrockstaar is offline   Reply With Quote Quick reply to this message
Unread 09-26-2014, 09:20 PM   #13
zjosh93
Registered User
1993 ZJ 
 
Join Date: Aug 2010
Location: Austin
Posts: 1,300
12, 14, 21, 55 on the check engine.
24, 55 on the OD light.
zjosh93 is offline   Reply With Quote Quick reply to this message
Unread 09-26-2014, 09:27 PM   #14
herqulees
Registered User
1997 ZJ 
 
Join Date: Aug 2012
Location: Nashville, Tennessee
Posts: 177
Only info I can find on code 24 is "24 - Overdrive override (control switch) lamp output", not too sure what to decipher just from that...
herqulees is offline   Reply With Quote Quick reply to this message
Unread 09-26-2014, 09:37 PM   #15
zjosh93
Registered User
1993 ZJ 
 
Join Date: Aug 2010
Location: Austin
Posts: 1,300
Eh, I was messing around on it a couple weeks ago and had a bunch of stuff unplugged. I was just posting because the OP was having trouble getting the OD light codes. I just need to unplug the battery to erase the codes.
zjosh93 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.