from 235s to 31s. made my jeep slow - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 06-29-2008, 07:12 PM Thread Starter
GrandJC78
Registered User
1996 ZJ 
 
Join Date: Nov 2007
Location: Illinois
Posts: 135
from 235s to 31s. made my jeep slow

1996 Jeep Grand Cherokee I6 4.0l

just replaced the crankshaft position sensor because it wouldnt even start. we hooked up a powertech programmer and the code p0320 Ignition/distributor engine speed input circuit. does anybody know what this means? i read that it might have something to do with the crankshaft position sensor. check engine light is not on. im running 31 by 10.50 15 tires and am thinking this may be part of the reason. would any of the sensors prevent it from being fast. when i put the pedal to the floor it redlines at like 3700 rather than 5800 and is just overall slow. anyone have any opinions/suggestions? thanks. also has k and n intake and new plugs and wires.

GrandJC78 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-30-2008, 05:50 AM
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Posts: 19,793
did you put the plug wires on correctly, check to be sure. did this start after the plugs and wires?

the tires will effect acceleration, but not your motor's redline.

the code could be a stored code from the bad sensor that didn't clear, did you disconnect the battery to clear the old codes?

'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline  
post #3 of 3 Old 06-30-2008, 06:49 AM
Redbob
Registered User
2004 WJ 
 
Join Date: Jul 2006
Location: North Texas
Posts: 1,103
You could have done something with the crankshaft position sensor so the ignition timing is way off; but that fault code will also come up if your timing (cam) chain is stretched much too far, so the timing is way off, or it may even have jumped a tooth, which will also give you the symptoms you've described.
Check out the timing chain before you go a lot farther.
Redbob is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Jeep hops when turning slow..parking ironmammoth ZJ Grand Cherokee Forum 20 08-04-2008 11:07 PM
my jeep is slow! GrandJC78 ZJ Grand Cherokee Forum 3 06-27-2008 07:17 PM
will 31s slow down my jeep? froadin orvis ZJ Grand Cherokee Forum 17 06-16-2008 02:29 PM
Has anybody put a 2" BB on 235s? 01grander ZJ Grand Cherokee Forum 6 02-04-2005 09:39 PM
235s on my Jeep unreal33 ZJ Grand Cherokee Forum 3 08-23-2002 10:32 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome