2004 Grand Cherokee 4.0 will crank but won't start... - JeepForum.com

 
LinkBack Thread Tools
post #1 of 12 Old 11-03-2009, 12:40 PM Thread Starter
rspi
Registered User
1998 ZJ 
 
Join Date: Aug 2009
Location: Albuquerque
Posts: 36
2004 Grand Cherokee 4.0 will crank but won't start...

Long story or short. Well, I'm at work so here is the short...

I have a 2004 Grand Cherokee Laredo with 93,880 miles on it that will not start. I parked it at the office, went to leave 4 hours later and it will not start. It cranks well, but won't turn over. I can not hear the fuel pump.

I hooked up my cheep OBD-II code reader and I get an error message that it will not link to the computer. So I ordered a "programmed computer" and it still does not start. Just cranks and cranks and cranks...

What should I try next???

rspi is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 11-03-2009, 01:19 PM
mhems001
Registered User
2015 JK Wrangler 
 
Join Date: Apr 2009
Location: Chesapeake, VA
Posts: 37
have you check your vitals, fuel air and spark, to see what in general is keeping it from running
mhems001 is offline  
post #3 of 12 Old 11-03-2009, 01:48 PM Thread Starter
rspi
Registered User
1998 ZJ 
 
Join Date: Aug 2009
Location: Albuquerque
Posts: 36
Well, I thought hooking it up to a OBD-II was checking vitals. I hear no fuel pump...
rspi is offline  
post #4 of 12 Old 11-03-2009, 04:08 PM
jeep210
Registered User
1997 ZJ 
 
Join Date: Oct 2009
Location: East Texas
Posts: 198
When you first turn your key on you should hear the fuel pump run, in the fuel tank, for a few seconds. If you don't hear it, check your ASD relay and the Fuel Pump relay. You can swap them out with similar. Or test them for normal operation. That is the first step.
jeep210 is offline  
post #5 of 12 Old 11-04-2009, 10:08 AM Thread Starter
rspi
Registered User
1998 ZJ 
 
Join Date: Aug 2009
Location: Albuquerque
Posts: 36
Oh, forgot to mention, I did replace the fuel pump relay. Actually, I have replaced it twice in the past 6 months because I have a problem with the battery terminals having corrosion build up (that was NOT visable). So I figured it out when I replaced the battery.

I'll try replacing the ASD relay (which ever one that is). If that does not work, I will replace the crank shaft sensor (just picked one up from NAPA).
rspi is offline  
post #6 of 12 Old 11-04-2009, 10:13 AM
mhems001
Registered User
2015 JK Wrangler 
 
Join Date: Apr 2009
Location: Chesapeake, VA
Posts: 37
before you go throwing more guess parts at it
-See if you have spark at the spark plugs
-See if you have fuel at the fuel rail
mhems001 is offline  
post #7 of 12 Old 11-04-2009, 01:04 PM Thread Starter
rspi
Registered User
1998 ZJ 
 
Join Date: Aug 2009
Location: Albuquerque
Posts: 36
Ok, I swapped the relays out, still no start. So I want to install this Crank Shaft Possition sensor... Where is it? I hope it's not between the motor and the fire wall. If so, how in the heck do you replace it???
rspi is offline  
post #8 of 12 Old 11-04-2009, 02:22 PM
JesseOR
Registered User
1993 ZJ 
 
Join Date: Oct 2009
Location: Eugene
Posts: 1,621
Go down to an autoparts store and pick up a Haynes manual. It will tell you where and how to test everything is located. It also has a TROUBLE SHOOTING section. DO IT BEFORE you just start dumping money into repairs that may not be the root of your problem

-Jesse-
GO DUCKS!

www.facebook.com/jesse.whitehargrove
JesseOR is offline  
post #9 of 12 Old 11-04-2009, 02:30 PM
mhems001
Registered User
2015 JK Wrangler 
 
Join Date: Apr 2009
Location: Chesapeake, VA
Posts: 37
I second that
mhems001 is offline  
post #10 of 12 Old 11-04-2009, 04:34 PM
jeep210
Registered User
1997 ZJ 
 
Join Date: Oct 2009
Location: East Texas
Posts: 198
I'm with the other members here. Do not throw parts at this trying to fix it. It gets expensive and you may not fix a thing. A Haynes manual will help.

No start problems are related to a fuel or ignition problem. Try cranking it over and check for a spark at the plugs or coil. If you have a spark, the CPS is not the problem. When you turn the key to on, you should hear the fuel pump run for a couple of seconds. Try turning you key on and off but do not try to start. Do this a couple of times then try to start. It could be a fuel issue.

The CPS is a pain to change. On a 4.0 it is on the drivers side bell housing on the transmission. On the V-8's it is on the passenger side.

Ok, I just saw that you have a 2004 and you may have a distributorless ignition. I think you have coil packs for each plug. I could be wrong. Not sure how to check for spark with that ignition. Maybe someone can comment on it. I am not sure.
jeep210 is offline  
post #11 of 12 Old 11-05-2009, 06:20 AM Thread Starter
rspi
Registered User
1998 ZJ 
 
Join Date: Aug 2009
Location: Albuquerque
Posts: 36
And the winner is (drum roll please), Crank Shaft Position Sensor.

Again, the symptoms:

1. Will not start.
2. Can not hear the fuel pump when you try to start.
3. Can not read the computer with the OBD-II code reader. Will not connect or communicate.
4. (Not sure about spark or fuel - my guess is have spark / no fuel).

Not a DIY job, just not enough space for me to reach the part to replace it. A local Jeep mechanic was kind enough to use my NAPA part and did the job for $113.
rspi is offline  
post #12 of 12 Old 11-05-2009, 07:50 AM
xJoshxx
Web Wheeler
 
xJoshxx's Avatar
2012 WK 
 
Join Date: Sep 2008
Location: Burlington, Kentucky
Posts: 5,533
Quote:
Originally Posted by rspi View Post
And the winner is (drum roll please), Crank Shaft Position Sensor.

Again, the symptoms:

1. Will not start.
2. Can not hear the fuel pump when you try to start.
3. Can not read the computer with the OBD-II code reader. Will not connect or communicate.
4. (Not sure about spark or fuel - my guess is have spark / no fuel).

Not a DIY job, just not enough space for me to reach the part to replace it. A local Jeep mechanic was kind enough to use my NAPA part and did the job for $113.
No Ob2 thats bad.

Sold4" Hybrid lift TeraFlex coils IRO Adjustable LA's Jks tracbar 1.25spidertrax spacers 265/75/16 Dura-tracs
Quote:
Originally Posted by moPowered View Post
The SRt-8's are a liberty design.
2011 WK2 ORA2 sold
2012 WK2 SRT8 - Current
99 WJ Limited Lifted.
2001 WJ stock 4.0 304k miles
xJoshxx is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
1994 grand cherokee wont crank or start ekelley1985 ZJ Grand Cherokee Forum 15 07-12-2012 09:15 PM
My 2004 grand cherokee wont start! bringnthenoise ZJ Grand Cherokee Forum 8 11-03-2009 12:28 PM
97 grand cherokee will crank but not start and im at my wits end pla4kps ZJ Grand Cherokee Forum 7 11-15-2008 01:57 AM
2004 Grand Cherokee I-6 wont crank... 98zjdave ZJ Grand Cherokee Forum 1 10-22-2008 05:45 PM
96 grand cherokee crank, no start, wiring??? JE55E ZJ Grand Cherokee Forum 2 10-31-2005 06:50 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome