2002 Grand Cherokee V8 Ltd. Start Up Prob. w/ Misfiring! - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 06-02-2004, 07:07 PM Thread Starter
arcarc
Registered User
 
Join Date: Jun 2004
Posts: 3
2002 Grand Cherokee V8 Ltd. Start Up Prob. w/ Misfiring!

Hi Guys,

I'm a Newbie here, and I desperately need some advice and help here, hope you can bare with me with the long post here.

I have a 2002 Grand Cherokee Ltd. V8 w/ only 39000 miles!

About 2 weeks ago one morning, I started my car first thing in the morning while the engine's completely cold in my garage (I'm in CA), the car idles so rough my steering wheel was totally shaking, then soon after the Check Engine light came on. I could hardly drive the sucker, it was reving so rough and low, only until the engine warmed up a bit (about 5 minutes) then it seemed to run ok.

I then immediately took it to the dealer nearby (Simi Valley Jeep), it took them 3 days to find what the problem was, they found some of the cylinders were Misfiring and they ended up replacing a Fuel Pump, and it ran really good and smooth.

4 days later (yesterday!), all things back to square one again, I immediately drove it back to the dealer's service dept. They called me back about 3 hours later, and told me that their mechanic had reconnected the connectors to the fuel injector and it seems to run fine. all the cylinders were in sync (all they did was disconnected some wires then reconnected them!)

I drove it home, waited for couple of hours, then I started the car, the engine didn't cooled down completely, about 1/4 way up on the gauge, then it all happend again, idling really rough, the check engine light came on again.. the same old thing's happening again.

I drove it back again, and now it's in the shop, and I'm clueless and it seems to me that they're clueless as well.

It seems to me the Simi Valley Jeep dealer's Service dept aren't really all that detail oriented, they made some stupid assumption and thought it would work and didn't bother to test the vehicle, didn't bother to let the engine to cool down completely to do the tests afterwards.

Anyone could give me a helping hand here on what might be the culprit, I'd really appreciate it.

I've only had this car for less then 3 years....

Thank You!

JT

arcarc is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 06-02-2004, 07:19 PM
driabyor
Registered User
 
driabyor's Avatar
1994 ZJ 
 
Join Date: Apr 2004
Location: chilton-haynes<$20
Posts: 2,450
plugs or wires ?

Next time you take it to the dealer tell them you want the mechanic not the parts changer
driabyor is offline  
post #3 of 5 Old 06-02-2004, 09:23 PM
Meerkat
Registered User
1996 ZJ 
 
Join Date: Apr 2003
Location: Belle, WV
Posts: 4,930
You didn't mention what error codes are being recorded. That could help a lot....

At this point, without more information, I would have to start at the CPS.

Warren
Black 1996 5.2L ZJ Limited
Meerkat is offline  
post #4 of 5 Old 06-02-2004, 10:04 PM Thread Starter
arcarc
Registered User
 
Join Date: Jun 2004
Posts: 3
Quote:
Originally Posted by wvd
You didn't mention what error codes are being recorded. That could help a lot....

At this point, without more information, I would have to start at the CPS.
Thanks for the pointer! my dealer called me today to tell me they still have no clue on what the culprit is, I'll have to wait until tomorrow.

As far as the error codes, I didn't ask for the error codes, my assumption is that they are the Jeep "dealer" guys, they should know better than anyone else.. but it's not the case.

I think it would be very helpful if I can come up w/ a list of possible causes and hoping they can get some info on some knowledge which they're lack of.

This is my second Grand Cherokee, I had a '99 limitd w/ the V6 then traded in for this crap....

The sad news is that I'm going away to Europe for a week this weekend, so the car might just sit in their garage and keep their minds busy. for 7 days! I'm so frustrated w/ this ordeal.

JT
arcarc is offline  
post #5 of 5 Old 06-02-2004, 10:11 PM Thread Starter
arcarc
Registered User
 
Join Date: Jun 2004
Posts: 3
Quote:
Originally Posted by driabyor
plugs or wires ?

Next time you take it to the dealer tell them you want the mechanic not the parts changer
Trust me I've yelled at them when the problem first happened about a week ago, they couldn't tell me anything, the interesting thing about it is, after they've replace the fuel pump, it ran fine for 4 days, so does it sounds like the fuel pump went out again? Tired of these so call trained certified mechanic w/ no brains.

Let's say if it's the pump, what might cause it to go out other than a factory defect pump? hmmmm....
arcarc is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
2002 grand cherokee hard to start lepr13665 ZJ Grand Cherokee Forum 0 10-12-2008 05:22 PM
Grand Cherokee Misfiring in the UK award ZJ Grand Cherokee Forum 3 04-16-2007 01:31 PM
2002 Grand Cherokee 4.7 hard start. trouser chili ZJ Grand Cherokee Forum 16 01-05-2007 07:59 PM
95 grand cherokee tranny prob.. stffrs2005 ZJ Grand Cherokee Forum 1 03-15-2006 09:09 AM
Grand Cherokee oil pressure prob geokam ZJ Grand Cherokee Forum 8 07-20-2004 06:28 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome