2002 2.7td Grand Cherokee(uk) - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 2002 2.7td Grand Cherokee(uk)

Savvy Aluminum BumpersIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed LineThe RuffStuff "I can't go to EJS" Sale!

Reply
Unread 07-11-2008, 03:13 PM   #1
bazzer12
Registered User
 
Join Date: Jul 2008
Location: glos
Posts: 15
2002 2.7td Grand Cherokee(uk)

Auto Trans 2+rev, thats all!? My jeep seems to have transmission trouble. feels like its in 2nd forward and wont change up on acceleration, reverse works??

bazzer12 is offline   Reply With Quote
Unread 07-11-2008, 03:20 PM   #2
bazzer12
Registered User
 
Join Date: Jul 2008
Location: glos
Posts: 15
Havin a problem with my jeep's auto trans. On selecting drive, its seems like its in 2nd not 1st and doesn't change up on acceleration. Reverse seems ok. Any thoughts anyone??
bazzer12 is offline   Reply With Quote
Unread 07-11-2008, 03:30 PM   #3
Dillonzj
Registered User
1998 ZJ 
 
Join Date: Sep 2007
Location: Indiana
Posts: 2,166
limp mode? try disconection your battery for a short wile
__________________
98' JEEP GRAND CHEROKEE LIMITED 5.9
149k 5.9L v8 White

Crane Cam shaft and Crane, Roller Rockers, bored .030 over, edelbrock performer heads, M1 Intake manifold, Fasstman throttle body, magnacore wires, platinum plugs, K&N FIPK, dough thorley headers,3" high flow cat, 3" magnaflow mandrel bent exhaust, SCT tuned

***future mods -5.5 IRO LA - KOR sliders -KOR roof rack -

SOLD-
95' JEEP GRAND CHEROKEE LIMITED
188k 5.2L v8 White 98 ZJ rims

Quote:
Originally Posted by nashmd454 View Post
...we all know they empty our pockets...yet they fill our hearts...


MY BUILD THREAD
Dillonzj is offline   Reply With Quote
Unread 07-11-2008, 03:58 PM   #4
bazzer12
Registered User
 
Join Date: Jul 2008
Location: glos
Posts: 15
Thanks for the reply, have just disconnected. Worth a try.
bazzer12 is offline   Reply With Quote
Unread 07-11-2008, 04:03 PM   #5
BucYouUp68
Registered User
2013 JK Wrangler 
 
Join Date: Aug 2007
Location: St Petersburg, Florida
Posts: 1,999
Speed Sensor
__________________
Why is there a fish finder in your Jeep?

Not hard, if you have a socket wrench and the mental capacity of a ham sandwich.
BucYouUp68 is offline   Reply With Quote
Unread 07-11-2008, 04:05 PM   #6
merlinTec
Registered User
 
Join Date: Jul 2007
Location: England
Posts: 2,944
Hi
Defiantly sounds like it’s in limp mode, Need to get the codes out of the TCM. When did it start doing this? Was it parked up for long? Was the battery slightly low? I ask as the box in the 2.7 is a very good box and don’t give much problems with them, the most common fault it transmission supply voltage fault codes and this is down to low battery voltage when cranking. If it drops below about 10.5 it flags this codes and gives the fault you have. Here is the TSB for this and the flash to fix it. http://www.wjjeeps.com/tsb/tsb_wg_2100908.pdf
Regards,
Merlin
__________________
UK Chrysler Jeep Master Tec.
merlinTec is offline   Reply With Quote
Unread 07-11-2008, 04:14 PM   #7
bazzer12
Registered User
 
Join Date: Jul 2008
Location: glos
Posts: 15
Hey Merlin thanks for your reply. All sound very technical mate. This is a dealer workshop job with a computer then yeah?? regards jim.
bazzer12 is offline   Reply With Quote
Unread 07-11-2008, 04:29 PM   #8
merlinTec
Registered User
 
Join Date: Jul 2007
Location: England
Posts: 2,944
Hi Jim
Yes dealer job, print the TSB I posted above before you go in as this is a new TSB so some dealer may not know about it yet and point out the 0.4 labour time unless it’s my dealership need to make my bonus lol. (That’s a joke.) If you need any more help give me a nudge.
Best of luck,
Regards,
Merlin
__________________
UK Chrysler Jeep Master Tec.
merlinTec is offline   Reply With Quote
Unread 07-11-2008, 04:39 PM   #9
BucYouUp68
Registered User
2013 JK Wrangler 
 
Join Date: Aug 2007
Location: St Petersburg, Florida
Posts: 1,999
Ummmm..............Speed Sensor
__________________
Why is there a fish finder in your Jeep?

Not hard, if you have a socket wrench and the mental capacity of a ham sandwich.
BucYouUp68 is offline   Reply With Quote
Unread 07-11-2008, 04:51 PM   #10
bazzer12
Registered User
 
Join Date: Jul 2008
Location: glos
Posts: 15
Merlin you're a star. Thanks for your advice mate, cheers again. I'll let you all know how i get on. Jim.
bazzer12 is offline   Reply With Quote
Unread 07-11-2008, 04:55 PM   #11
bazzer12
Registered User
 
Join Date: Jul 2008
Location: glos
Posts: 15
Thanks BucYouUp68 for your reply too mate, the more help, the better! Cheers, jim.
bazzer12 is offline   Reply With Quote
Unread 07-11-2008, 04:55 PM   #12
merlinTec
Registered User
 
Join Date: Jul 2007
Location: England
Posts: 2,944
Hi
This is a NAG 1 Mercedes box in the 2.7 and don’t suffer from speed sensors but get the fault codes and we will know and then can help more.
Regards,
Merlin
__________________
UK Chrysler Jeep Master Tec.
merlinTec is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.