1998 Grand Cherokee Laredo v6 - NO HEAT - JeepForum.com
 
LinkBack Thread Tools
post #1 of 7 Old 01-18-2009, 02:12 PM Thread Starter
golfcaddie99
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: Greenville
Posts: 7
1998 Grand Cherokee Laredo v6 - NO HEAT

Anybody with this model performed the heater treater fix? If so, how hard was it to perform?

And how did you get to motor and blend doors to put repair in?

Thanks in advance.

Golfcaddie99

golfcaddie99 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 01-18-2009, 03:03 PM
waarp8nt
Registered User
1995 ZJ 
 
Join Date: Sep 2008
Location: F-N-Ham, IL
Posts: 105
V6?

The do you have ATC (automatic temp control)?
waarp8nt is offline  
post #3 of 7 Old 01-18-2009, 03:40 PM
trail-rated
Registered User
2001 WJ 
 
Join Date: Dec 2008
Location: Plant City, FL
Posts: 47
First off, you have an I6 and NOT a V6. Your problem is probably a clogged heater core.

What temp does the engine run? Any leaks? What is the coolant level (check both the radiator and overflow)?

[ ]IIIIIII[ ] |2001 WJ|4.0L|42re|Quadra-trac II| Too many mods to list|


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
trail-rated is offline  
 
post #4 of 7 Old 01-18-2009, 04:10 PM
compcrasher86
Registered User
1998 XJ Cherokee 
 
Join Date: Nov 2008
Location: Marblehead, MA
Posts: 6,276
whoah, yeah the v6 totally threw me off, I was like, huh? i6 man, i6

98 XJ Sport | i6 | AW4 | 231 | Stone White | Agate Leather

SOLD 01 WJ Ltd | i6 | QT2 | Moog HD steering | Tow Package | Boston Acoustics Audio | RB1 | Lou's Catback | Stone White |

Matt
compcrasher86 is offline  
post #5 of 7 Old 01-18-2009, 04:33 PM Thread Starter
golfcaddie99
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: Greenville
Posts: 7
Sorry about the error

yes I6 and no I don't have auto temp control.

Have had certified tech flush system 4 times now, replace hoses and thermostat - yet doesn't fix the heat issue. Blower is fine and system Just wondering if the actual issue is the heater core or whether or not this is the blend door issue reported on other forum posts (hence the reference for heatertreater.net).

If only option is to replace heater core, I'll junk this pos. Given me nothing but trouble for 10 years. Transmission, engine, brakes - you name it.

That's why I'm looking for cheapest way to resolve.

Thanks
golfcaddie99 is offline  
post #6 of 7 Old 04-21-2011, 12:47 PM Thread Starter
golfcaddie99
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: Greenville
Posts: 7
problem resolved

Turned out to be the water pump. Had the pump replaced and coolant system flushed. All worked out well.
golfcaddie99 is offline  
post #7 of 7 Old 01-06-2014, 10:50 AM
2tall2slow
Registered User
1998 XJ Cherokee 
 
Join Date: Jul 2013
Location: Coleridge
Posts: 133
frigid cold and no heat, help!

I too have been experiencing no heat. Inline 6, 98 Laredo. I am not mechanically inclined, however I choose to do my own labor so I can learn and save. anyway, blowers work good. checked heater hoses and they are both hot so thermostat must be working good. rod that connects to heater switch is connected.. So am I looking at the heater core next? I would like to think its clogged and can easily be fixed. I need to know stp by step how to flush the heater core, that is before I am told to pull the whole thing out and examine the 2 doors on it/ or replace the thing. Family man, got kids. tommorrows low is 6degrees. Please help!
2tall2slow is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
1998 Jeep Grand Cherokee Laredo Pint ZJ Grand Cherokee Forum 9 10-12-2009 03:00 PM
1998 grand cherokee laredo slipping problem Azazel ZJ Grand Cherokee Forum 4 02-26-2009 11:51 AM
Just bought a 1998 Grand Cherokee Laredo elmer91 ZJ Grand Cherokee Forum 6 08-04-2008 11:00 PM
1998 Grand Cherokee Laredo overheating after 5 mins. BlessingD ZJ Grand Cherokee Forum 9 07-20-2008 02:52 PM
Wrangler Wheels on a 1998 Grand Cherokee Laredo Steven566 ZJ Grand Cherokee Forum 4 11-13-2006 02:21 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome