1997 Grand Cherokee Laradeo, stalls after cold starts. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 1997 Grand Cherokee Laradeo, stalls after cold starts.

6th Annual, Beat Your Wife to the Credit Card Sale!Flush Mount LED Bumper Lights, CREERuffstuff Axle Simple Swap Kit!

Reply
Unread 09-05-2007, 10:59 AM   #1
MRCLIVE
Registered User
1989 MJ Comanche 
 
Join Date: Jul 2007
Location: Virginia
Posts: 28
1997 Grand Cherokee Laradeo, stalls after cold starts.

Hello everyone,

I am new to Jeep Forum. I have the following problem, my 1997 Grand Cherokee Laradeo ZJ inline 6 4.0L stalls out after a cold start. If i warm it up for about 20 minutes it seem to work just fine. However, lately as the temperatures have been in the low 60s and 50s at night and in early mornings the problem has gotten worst. It seems to work fine when temperatures above 70 degrees. After searching the forum and following all the good advice the problem persists.

Here is a list of my action to date. I have replaced the wires, plugs, distributor w/cam sensor, cap & rotor. Ignition coil, TPS, Idle Air Control valve. I have a new catalyst converter. Repaired an exhaust manifold leak (new manifold). Inspected the battery cables (ok), applied dielectric grease to most electrical connection with exception to connections on throttle body.

Once again, after getting hot it runs fine. It only after cold starts when temp is below 70 degrees I have problems. In fact just this morning temp was about 62, started it up, warmed up, and drove about 1 or miles it stalled. I was able to restart and continue. Now that its hotter it will start up and go without issue.

Any thoughts on what else my problem could be. Thanks in Advance.

MRCLIVE is offline   Reply With Quote Quick reply to this message
Unread 09-05-2007, 12:55 PM   #2
impuresoul2k3
Registered User
1993 ZJ 
 
Join Date: Mar 2007
Location: Nebraska
Posts: 565
Sounds like it's running lean. Test out the coolant temp sensor. I have mine rigged up so mine thinks the jeep is 247* (to help lean it out and get better gas mileage) and I have to turn the switch off to get it to start and if I turn the switch back on it will hesitate or stall out depending on the load, next time you start it try tapping the peddle until you get the rpms around 1500 then you can drive it like normal. You may have to drive like that for a few minutes until it warms up.
__________________
1993 Grand Cherokee Limited, 5.2L
Modified/Slightly Ported Kegger
Air hat spacer
Modified Throttle body
Flowmaster muffler
impuresoul2k3 is offline   Reply With Quote Quick reply to this message
Unread 09-06-2007, 10:51 AM   #3
MRCLIVE
Registered User
1989 MJ Comanche 
 
Join Date: Jul 2007
Location: Virginia
Posts: 28
1997 Grand Cherokee Laradeo, stalls after cold starts.

Thanks for tip.

I tested the coolant temperature sensor. it appears to working fine. I unplugged it and started the engine, it immediately stalled and check engine light came on. Reconnected, started it and it stalled several minute later, but without check engine light coming on. After another restart it ran
after reaching operating temp of 210*. Still searching for a fix.


Thanks again.
MRCLIVE is offline   Reply With Quote Quick reply to this message
Unread 09-06-2007, 12:12 PM   #4
rm2001wj
Web Wheeler
 
rm2001wj's Avatar
2001 WJ 
 
Join Date: Aug 2005
Location: Memphis, TN
Posts: 3,118
Check to see if there are any trouble codes, not all codes turn on the CEL.

Use the DIY method in this link: http://www.zjilla.com/tech_codes.htm.

Or, go to someplace like AutoZone and get them to connect a code reader. They do it for free.

Let us know what the result is.
__________________
2001 WJ Limited with Quadra-Drive, Kenne Bell Supercharger, 3-inch Kolak exhaust, Stillen rotors (F/R) and MM pads, Addco sway bars (F/R).
rm2001wj is offline   Reply With Quote Quick reply to this message
Unread 04-21-2009, 05:01 PM   #5
MRCLIVE
Registered User
1989 MJ Comanche 
 
Join Date: Jul 2007
Location: Virginia
Posts: 28
Update to stalling issues. Finally found the cause of the intermitten stalling. After selling the Vehicle. It turn out that the three connectors that plug into the PCM were broken. By being broken they were not staying in place. So once the ZJ went over a bump they dislodged. Apparent on the restart the current draw pulled them back in. So after buying repair kits for the plugs. The Jeep is running fine.
MRCLIVE is offline   Reply With Quote Quick reply to this message
Unread 04-25-2010, 12:36 PM   #6
MRCLIVE
Registered User
1989 MJ Comanche 
 
Join Date: Jul 2007
Location: Virginia
Posts: 28
1997 Grand Cherokee Laradeo, stalls after cold starts.

Turns out the last post was not correct. The vehicle has been returned. The fixed was the ignition coil replacement. '97 Grand currently on the road and running good.

Just might be the problem for others as well. Oh and by the way its been running without issue for at least five months.
MRCLIVE is offline   Reply With Quote Quick reply to this message
Unread 08-08-2010, 08:28 PM   #7
MRCLIVE
Registered User
1989 MJ Comanche 
 
Join Date: Jul 2007
Location: Virginia
Posts: 28
1997 Grand Cherokee Laradeo, stalls after cold starts.

'97 Grand Cherokee Laradeo still running after ignition coil replacements. In fact just put on four new tires. See earlier post, if you are experiencing similar issues give it a try and post your results.
MRCLIVE is offline   Reply With Quote Quick reply to this message
Unread 11-12-2013, 06:04 PM   #8
NissanGuy23
Registered User
1996 ZJ 
 
Join Date: Jul 2013
Location: West Chester, PA
Posts: 35
Im having issues with stalling only in cold weather, 10-20 min after startup. So, if its 50 DEG plus outside, it has never stalled. If its freezing cold, but the Jeep has been given 20+ min to warm up, it has never stalled. It only stalls in a situation where the Jeep has been sitting for 9+ hours, and its 34 DEG outside, when you fire it up, it will stall and die multiple times until about 20 min in it starts to run normally.

Things replaced to far (not necessarily to stalling but for other reasons): CPS, Harmonic Balancer, Alternator, Serp Belt, Cleaned the IAC, new cat-back exhaust.
The car is a 1996 Jeep GC Laredo 4.0 Auto with 227,000 miles.

So do you think its the ignition coil? The next thing i was going to try was cleaning the throttle body. Any help very appreciated, tired of stalling on the way to work
NissanGuy23 is offline   Reply With Quote Quick reply to this message
Unread 11-13-2013, 07:06 AM   #9
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,727
wiggle pcm connectors while cold. see link in my sig
ZeeJay1997 is offline   Reply With Quote Quick reply to this message
Unread 11-13-2013, 10:53 AM   #10
NissanGuy23
Registered User
1996 ZJ 
 
Join Date: Jul 2013
Location: West Chester, PA
Posts: 35
Quote:
Originally Posted by ZeeJay1997 View Post
wiggle pcm connectors while cold. see link in my sig
My PCM came zip-tied from the previous owner. If the PCM stall issues can be linked to cold weather, pre warm up, than ill target the PCM as a possible cause and try to clean, ect. People keep giving different recommendations, not sure which to look at.
NissanGuy23 is offline   Reply With Quote Quick reply to this message
Unread 11-13-2013, 12:31 PM   #11
Oldfrog
Web Wheeler
1997 ZJ 
 
Join Date: Feb 2008
Location: Louisiana/Texas
Posts: 4,135
Quote:
Originally Posted by NissanGuy23 View Post
My PCM came zip-tied from the previous owner. If the PCM stall issues can be linked to cold weather, pre warm up, than ill target the PCM as a possible cause and try to clean, ect. People keep giving different recommendations, not sure which to look at.
That's usually a dead giveaway that the PCM is bad. Not always...but most of the time.
__________________
Cajun Recipes and Fishing tips

Words of wisdom, Posted by Zeejay:
"..it's not air, it is the opposite of air... suckage so to speak."

Stalling? Work through Zeejay's list
Oldfrog is offline   Reply With Quote Quick reply to this message
Unread 11-13-2013, 05:46 PM   #12
NissanGuy23
Registered User
1996 ZJ 
 
Join Date: Jul 2013
Location: West Chester, PA
Posts: 35
Check out this video i took, car has been sitting in pretty cold weather for 24 hrs. Did its usual hard to start up / stall. Died when i put pressure on the third connector, so i guess ill get learning how to reflow a PCM pretty soon.

NissanGuy23 is offline   Reply With Quote Quick reply to this message
Unread 11-13-2013, 10:16 PM   #13
JS97ZJ
Registered User
1997 ZJ 
 
Join Date: Dec 2009
Location: Dingmans Ferry, PA
Posts: 2,039
My Jeep was doing the same as in the video. (touch the PCM plugs and loose power)
After spending much time on that problem with others on this forum, I came up with the solution for the loose connections that worked on mine.

http://www.jeepforum.com/forum/f13/9...tures-1303589/

It solved my situation and care must be taken when doing it. But you should first go through ZeeJay's 12 things list (the link in his signature in his post above) before you tear the PCM apart.
Another member found it was the pins that were making intermittent connections due to sloppy openings in the harness connectors.
JS97ZJ is offline   Reply With Quote Quick reply to this message
Unread 12-16-2013, 08:04 AM   #14
rpm0627
Registered User
 
Join Date: Dec 2013
Posts: 1
what is a pcm I am having the same issues with my jeep in the morning its stalling when I make a complete stop or ak idiling for a while
rpm0627 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.