1997 grand cherokee - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 1997 grand cherokee

1984-2001 Jeep Cherokee Front Upper & Lower Control ArSwag Off Road BIG-HIT TJ-YJ Rear BumperFS: Wrangler RGB Multicolor Fog Light LEDs: Awesome Effect

Reply
Unread 09-01-2009, 08:17 PM   #1
jboidock
Registered User
 
Join Date: Sep 2009
Location: the fort
Posts: 2
1997 grand cherokee

I am having an issue with my jeep it idles rough and shifts hard and sometimes stalls when it is at idle speedi think it is probably the iac but i dont want to replace it if i am not sure is there any way to test it and does anybody have any ideas for me

jboidock is offline   Reply With Quote
Unread 09-01-2009, 08:39 PM   #2
wickerham
Registered User
1993 ZJ 
 
Join Date: Jul 2009
Location: PA
Posts: 810
clean it with throttle body cleaner.
search, there's a write-up on it here.
wickerham is offline   Reply With Quote
Unread 09-02-2009, 06:23 PM   #3
jboidock
Registered User
 
Join Date: Sep 2009
Location: the fort
Posts: 2
no write up that i could find. i unplugged the connector whileit was running and it stayed running. i have heard that if you unplug it while it is running it should die. so i checked for vaccum leaks none. so is that a pretty sure sign that it is a bad iac and i also cleaned it planning on driving it for a couple see if it change anything by cleaning it.
jboidock is offline   Reply With Quote
Unread 09-02-2009, 09:02 PM   #4
wickerham
Registered User
1993 ZJ 
 
Join Date: Jul 2009
Location: PA
Posts: 810
no write up? it was first link after I searched "clean IAC"
anyway here: IAC_linky
wickerham is offline   Reply With Quote
Unread 09-02-2009, 09:10 PM   #5
ben98zj
Registered User
1998 ZJ 
 
Join Date: Mar 2009
Location: Travelers Rest, SC
Posts: 30
I have had an issue like this for a while on my jeep. cleaned the iac , tps squeaky clean. I think I have narrowed it down to somthing in the trans. the govenor pressure selinoid maybe. don't know. when I adjusted the band to the right tourque the stlling got worse. I have yet to open the trans back up but that could be your prob. clean the iac first though. hope this helps
ben98zj is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.