1996 ZJ No shift - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 1996 ZJ No shift

FS: Jeep Fog Light LED Bulbs! Several Brightness Options! Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineOld Man Emu WK Lift - Black Friday Special!!

Reply
Unread 03-12-2011, 02:08 PM   #1
lilkinz17
Registered User
1996 ZJ 
 
Join Date: Mar 2011
Location: Des Moines, IOWA
Posts: 4
1996 ZJ No shift

Hey, I'm new here and need some help. Have the 96 ZJ grand with 4.0L I6 and 42RE. Had problems with shifting. in Drive its in 3rd all the time, can shift down to 2nd manually and shift back up manually but won't shift into 1st or OD. pulled code p0748 which was the Governor Pressure Solenoide, so i put in a new solenoid and sensor. Nothing changed. Need ideas. Please help me out.


LilKinz17

lilkinz17 is offline   Reply With Quote Quick reply to this message
Unread 03-12-2011, 03:32 PM   #2
larudy
Registered User
1996 ZJ 
 
Join Date: Feb 2011
Location: chicago, illinois
Posts: 77
check the transmission fluid levels or o2 sensor i had an issue like youts ended up being o2 sensor
__________________
i love my piece of crap jeep :)
larudy is offline   Reply With Quote Quick reply to this message
Unread 03-12-2011, 03:36 PM   #3
larudy
Registered User
1996 ZJ 
 
Join Date: Feb 2011
Location: chicago, illinois
Posts: 77
oh and btw i was getting a check engine light too for governor sensor when i had just put on a new trans so i found out when the o2 sensor is bad it can give a funky reading but it does really cause loss of rpms hence the transmission having issues shifting when it should. oh and btw did you change the tranny fluid because thats what cause my first tranny to blow..long story short hose collapsed 2am on the highway and all tranny fluid leaked out then my mechanic put new fluid blew the trans then bought new one then had shifting issues due to o2 sensor
__________________
i love my piece of crap jeep :)
larudy is offline   Reply With Quote Quick reply to this message
Unread 03-12-2011, 05:08 PM   #4
neonhomer
Registered User
1996 ZJ 
 
Join Date: Sep 2010
Location: Edgewater, FL, Florida
Posts: 456
Make sure you cleared the codes after replacing the solenoid. Also replace the pressure sensor at the same time.

When you tranny starts out in 3rd gear it means it is in Limp Home mode.

Weird about the O2 sensor....
neonhomer is offline   Reply With Quote Quick reply to this message
Unread 03-13-2011, 04:29 PM   #5
lilkinz17
Registered User
1996 ZJ 
 
Join Date: Mar 2011
Location: Des Moines, IOWA
Posts: 4
had a tranny put in so the fluid and filter is brand new. im starting to think theres a wire problem between the pcm and tranny so thats where im goint to look
lilkinz17 is offline   Reply With Quote Quick reply to this message
Unread 03-13-2011, 05:40 PM   #6
ZombieJeep93
Registered User
1993 ZJ 
 
Join Date: Sep 2010
Location: westminster, co
Posts: 125
is this a new trans or a reman? has it been doing this since trans install? is there still any warranty on trans?

could be bad wirng pcm to trans or in trans from connector to gov sol and sensor. could also be valve body problem.

just a few things to consider.
__________________
93 Grand Wagoneer (de-wooded) 5.2 Mag, 2"BB, Magnaflo Cat, Gibson ex, K&N CAI, Mopar pcm, 32" BFG AT, Accel truck ignition
ZombieJeep93 is offline   Reply With Quote Quick reply to this message
Unread 03-14-2011, 08:27 PM   #7
lilkinz17
Registered User
1996 ZJ 
 
Join Date: Mar 2011
Location: Des Moines, IOWA
Posts: 4
reman tranny. starting acting up with the old one so i had the reman one installed. still nothing so i installed a sensor and solenoid and inspected the valve body as well. all is good so i turn to electrical. im thinking a bad wire from pcm to tranny connector. i need to get ahold of a multimeter and run an ohm test to make sure
lilkinz17 is offline   Reply With Quote Quick reply to this message
Unread 03-14-2011, 09:58 PM   #8
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Location: , Pennsylvania
Posts: 19,794
Codes?
__________________
'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline   Reply With Quote Quick reply to this message
Unread 03-17-2011, 10:29 AM   #9
lilkinz17
Registered User
1996 ZJ 
 
Join Date: Mar 2011
Location: Des Moines, IOWA
Posts: 4
only code i get is p0748 which is the pressure solenoid circuit.
lilkinz17 is offline   Reply With Quote Quick reply to this message
Unread 11-05-2013, 04:31 PM   #10
Procide
Registered User
1998 ZJ 
 
Join Date: Nov 2012
Location: Milford, Connecticut
Posts: 5
Did you ever figure this out? I'm in the EXACT same situation. I replaced my transmission and govenor pressure solenoid as well. I tested my wiring and everything checked out. The solenoid to PCM was putting out voltage under load as well so the only thing left seems to be a bad PCM.. Let me know!
__________________
1998 Grand Cherokee~Current
2008 BMW 335xi~Current
1996 Grand Cherokee~6" on 33's~SOLD
Procide is offline   Reply With Quote Quick reply to this message
Reply

Tags
cherokee , grand , shifting problem , transmission , zj

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.