1996 Jeep Grand Cherokee Won't Start rigth away. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 1996 Jeep Grand Cherokee Won't Start rigth away.

Dan's Old as Dirt Birthday Sale!Ruffstuff Axle Simple Swap Kit!Ruffstuff XJ Unirail Channel Reinforcement....

Reply
Unread 12-05-2011, 12:08 PM   #1
jskenyon
Registered User
1996  
 
Join Date: Dec 2011
Location: stamford, ct
Posts: 2
1996 Jeep Grand Cherokee Won't Start rigth away.

Dear All,

my 1996 Jeep Grand Cherokee isn't starting up right away. Battery turns on, and you can hear the fuel pump turn on. However, the engine doesn't start, just tries for a long time. sometimes the engine will turn over easier and other times it can take up to 10-15 minutes. Sounds a lot like this video http://www.youtube.com/all_comments?v=5NfqrTcnczM. Once the engine finally turns over, it runs well and doesn't stall.

Any suggestions?

Thanks.

jskenyon is offline   Reply With Quote
Unread 12-05-2011, 12:11 PM   #2
jskenyon
Registered User
1996  
 
Join Date: Dec 2011
Location: stamford, ct
Posts: 2
Should note that the starter & spark pug were replaced less than four years ago.
jskenyon is offline   Reply With Quote
Unread 12-07-2011, 09:40 AM   #3
zvanit03ru
Registered User
1997 ZJ 
 
Join Date: Jan 2006
Posts: 48
I think you're misusing the phrase "turns over", which means that the engine is spinning, but not starting to run. Failure to "turn over" means that you get nothing but a click or bump, such as with a totally dead battery, or no sound at all, such as with a disconnected battery.
Assuming that your engine is indeed "turning over" when it fails to start, I would suspect one of two things first: a faulty automatic shutdown (ASD) relay, or a faulty crankshaft position sensor (CKP.)
To test the ASD relay, located in the electrical box under the hood, swap it with the horn or AC relay (whichever one is identical; both are on mine.)
I did not view the attached YouTube video because I'm at work and cannot do it on the terminal here.
zvanit03ru is offline   Reply With Quote
Unread 12-09-2011, 10:24 PM   #4
kevins79j10
Registered User
1979 J-Series Truck 
 
Join Date: Dec 2011
Location: Sedalia, MO
Posts: 7
for what it's worth, i just took my 96 to the dealer for some PCM updates, and i think one of them was related to an issue similar to yours. might wanna take it there to have a look-see
kevins79j10 is offline   Reply With Quote
Unread 12-09-2011, 11:30 PM   #5
IdabJeepin
Registered User
1993 ZJ 
 
Join Date: Jan 2011
Location: Rigby, Idaho
Posts: 73
When you first role your key on before it starts the starter cranking, does your "CHECK ENGINE" light come on with all of your other check lights on your dash??? This thread is also for 4.0 IL6 motors also. Mine did the same thing you are talking about and I followed this thread and now I am running fine.
http://www.jeepforum.com/forum/f12/c...rs-ecu-492597/
__________________
[B][SIZE="1"][FONT="Book Antiqua"][COLOR="DarkSlateGray"][SIZE="3"]93 ZJ 4.0 IL6[/SIZE]
[SIZE="4"]235/85/16 (32s)[/SIZE]
[SIZE="3"]2 inch BB[/SIZE]
[SIZE="4"]Aussie Locker up front[/SIZE][COLOR="DarkRed"][FONT="Comic Sans MS"][B][SIZE="4"] Now I have a genuine 3-wheel drive 4x4![/SIZE][/B][/FONT][/COLOR]
[SIZE="3"]Ramsay Winch on receiver so it can be used on front [B][U]OR[/U][/B] back of Jeep [B][U]OR[/U][/B] on my 4-wheeler [B][U]OR[/U][/B] to hang another bull elk up in a tree [B][U]OR[/U][/B] ???
[/SIZE][/COLOR][/FONT][/SIZE][/B]
[SIZE="4"][B][COLOR="Lime"]Why do they call it common sense when it is so uncommon ?[/COLOR][/B][/SIZE]
[FONT="Comic Sans MS"][SIZE="4"][COLOR="Cyan"]Jeep Mods Are Like Eating Potato Chips.
Ya Can't Stop Having Just One.[/COLOR][/SIZE][/FONT]
IdabJeepin is offline   Reply With Quote
Unread 12-10-2011, 08:25 AM   #6
JS97ZJ
Registered User
1997 ZJ 
 
Join Date: Dec 2009
Location: Dingmans Ferry, PA
Posts: 2,015
Quote:
Originally Posted by jskenyon View Post
Dear All,

my 1996 Jeep Grand Cherokee isn't starting up right away. Battery turns on, and you can hear the fuel pump turn on. However, the engine doesn't start, just tries for a long time. sometimes the engine will turn over easier and other times it can take up to 10-15 minutes. Sounds a lot like this video http://www.youtube.com/all_comments?v=5NfqrTcnczM. Once the engine finally turns over, it runs well and doesn't stall.

Any suggestions?

Thanks.
Have you tried using the zip ty fix to solve the problem?

Quote:
Originally Posted by IdabJeepin View Post
When you first role your key on before it starts the starter cranking, does your "CHECK ENGINE" light come on with all of your other check lights on your dash??? This thread is also for 4.0 IL6 motors also. Mine did the same thing you are talking about and I followed this thread and now I am running fine.
http://www.jeepforum.com/forum/f12/c...rs-ecu-492597/
This is for rhe 93-95 Jeeps.
JS97ZJ is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.