post #1 of Old 07-21-2013, 09:43 PM Thread Starter
Trosar
Registered User
 
Join Date: Jul 2013
Location: PA
Posts: 1
1995 jeep zj tranny problems?

Hi i am new here and having a problem with my jeep, it has done it since i got it and finally got some money to fix it. The problem is when i reach 50mph and am at half throttle it loses power i can put it 3/4 the way down and it will go but its very slow and underpowered then at a certain point near 3/4 throttle it will catch and take off real fast. I had changed the catalyctic converter and didnt change anything. Tranny? what do you guys think? Thanks

Trosar is offline  
post #2 of Old 07-21-2013, 10:14 PM
mig1289
Registered User
1998 ZJ 
 
Join Date: May 2008
Location: philadelphia
Posts: 421
have you adjusted the tv cable right by the throttle body? i had an issue similar to what you are describing and i thought my tranny was about to lose it. ended up just being a cable that needed to be adjusted.

video of how to do it [ame]http://www.youtube.com/watch?v=TH4UV2HrD1w[/ame]

2wd zj...
mig1289 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome