1995 Grand Cherokee - Missfire problem - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 1995 Grand Cherokee - Missfire problem

The Original 3/8" Ruffstuff Diff Cover!The Ruffstuff NOT Universal 4 Link Kit!Flush Mount LED Bumper Lights, CREE

Reply
Unread 08-02-2011, 10:14 PM   #1
Orvisjeep
Registered User
1995 ZJ 
 
Join Date: Jul 2011
Location: Stanwood, WA
Posts: 5
1995 Grand Cherokee - Missfire problem

First off i want to say i have searched and searched the forums and cannot find a answer.

So i have a 1995 grand cherokee that has a major missfire issue. I just bought it with a new motor installed. 5.2L V8. The motor was installed 3 weeks ago, and ran fine at first. It has developed a missfire issue that i cannot figure out.

Things i have done are:

Ignition timing
new plugs
new wires
new ignition coil
new cap
new rotor
reset computer

Nothing has worked, and I am completly out of ideas. Does anyone have any more places to check?

Thanks.

Orvisjeep is offline   Reply With Quote
Unread 08-02-2011, 11:55 PM   #2
JS97ZJ
Registered User
1997 ZJ 
 
Join Date: Dec 2009
Location: Dingmans Ferry, PA
Posts: 2,015
Possibly some junk got loose in the fuel lines and is restricting the injectors? Is the miss a steady miss or random? Run some injector cleaner. (?)
JS97ZJ is offline   Reply With Quote
Unread 08-03-2011, 12:10 AM   #3
Orvisjeep
Registered User
1995 ZJ 
 
Join Date: Jul 2011
Location: Stanwood, WA
Posts: 5
It is steady at 1500rpm, and shakes the whole jeep at 2000rpms. Below and above those it runs fine.
Orvisjeep is offline   Reply With Quote
Unread 01-31-2013, 04:23 AM   #4
Muaymendez
Registered User
1993 ZJ 
 
Join Date: Dec 2008
Location: rahway NJ
Posts: 80
IM havng the same issue did you figure this out yet. This weekend will be tune up weekend, Caps rotor, pcm and IAC cleaning but I would hate to burn that cash and it nt solve the problem. And not to mentrion . I HATE DEAD END threads.
Muaymendez is offline   Reply With Quote
Unread 01-31-2013, 10:28 AM   #5
Snowfan2
Registered User
1998 ZJ 
 
Join Date: Jan 2012
Location: North of Amarillo, Tx
Posts: 506
Be sure your plug wires are run correctly. There is a TSB regarding routing.

http://dodgeram.info/tsb/1998/18-48-98/18-48-98-v8.htm
Snowfan2 is offline   Reply With Quote
Unread 02-19-2013, 01:05 AM   #6
Muaymendez
Registered User
1993 ZJ 
 
Join Date: Dec 2008
Location: rahway NJ
Posts: 80
Just wanted to close this thread and let readers know my plugs and cap n rotor were toast. TB also needed a good cleaning.Everything good now
Muaymendez is offline   Reply With Quote
Unread 03-14-2014, 08:46 PM   #7
bobinAZ
Registered User
1993 ZJ 
 
Join Date: Feb 2014
Location: bullhead city, AZ
Posts: 192
Quote:
Originally Posted by Snowfan2 View Post
Be sure your plug wires are run correctly. There is a TSB regarding routing.

http://dodgeram.info/tsb/1998/18-48-98/18-48-98-v8.htm
hate to revive an old thread but, I was looking everywhere for that info.. the search function really does work!!! thanks
bobinAZ is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.