1995 grand cherokee electrical problems - JeepForum.com

 
LinkBack Thread Tools
post #1 of 13 Old 06-23-2008, 04:25 PM Thread Starter
mvharb
Registered User
1995 FSJ Cherokee 
 
Join Date: Jun 2008
Location: Clinton
Posts: 1
1995 grand cherokee electrical problems

Im having all sorts of electrical problems that all seem to be related. There is a relay that constantly clicks when the ign. is turned off. It is the relay that controls radio memory, power locks, interior lights and several other things that require power after the ign. is off. Also the radio, which by the way will play only on AM, goes off when either front door is opened. I have replaced the relay (the new one clicks too). I disconnected the wiring to overhead console and the clicking stops. Also the chime module doesn't work. Someone told me that the door wiring harnesses need to be replaced. If so, how do I do that. Whew what a mess!!!! Somebody please help me

Mike

mvharb is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 06-23-2008, 04:31 PM
Virmagicus
Moderator
 
Virmagicus's Avatar
1998 ZJ 
 
Join Date: Feb 2006
Location: Northern Indiana
Posts: 6,440
Clean the battery terminals really good & check the ground wire. Make sure the battery is up to par.

Last edited by Virmagicus; 06-23-2008 at 04:45 PM.
Virmagicus is offline  
post #3 of 13 Old 06-23-2008, 05:29 PM
jwarfield
Registered User
1995 ZJ 
 
Join Date: Feb 2007
Location: Frederick, MD
Posts: 129
Mine did the exact same thing. Check the condition of ALL of the fuses on the passenger side fuse panel. I cant remember which one it was but I bet you'll find that one is blown.

Never trust a man in shiny shoes or a clean hard hat.

92 XJ-Toy
95 ZJ-Daily Driver (bad on gas)
09 Genuine Roughhouse 50 scooter-Daily Driver (good on gas)
jwarfield is offline  
post #4 of 13 Old 06-23-2008, 08:12 PM
Vestjam
Registered User
2008 JK Wrangler 
 
Join Date: Feb 2006
Location: Illinois
Posts: 763
It may simply be the chime module has gone bad, but check fuses 8 and 9....

That thing does more than just remind you the key is in the ignition.

The first step in trouble shooting the chime module it is to replace it. If it solves all the problems, great. If it doesn't, then let us know. There is a sequence to trouble shooting the problem.

2008 Jeep Wrangler X (Hard Top)
Incubus Off Road 511's with BFG 285/70-17

1998 Jeep Cherokee Sport
4.0L/AW4, Yakima Roof Rack
Vestjam is offline  
post #5 of 13 Old 06-30-2008, 01:41 PM
95ZJL
Registered User
 
95ZJL's Avatar
1995 ZJ 
 
Join Date: Apr 2007
Location: Marlborough, MA
Posts: 110
hey all same exact problems for me here, i replaced the fuse already and everything worked great for like 2 days and the problem came back again no chime no nothing, but all the fuses are intact and none of them blew

The line isn't about the motive, it's merely the result.
1995 ZJ Limited Black/Gold
5.2 V8 NEW 249
2" Doestch 3000 Shocks
31x10.5 BFG All-Terrain's
KOR Radiator Support
95ZJL is offline  
post #6 of 13 Old 06-30-2008, 02:12 PM
sjhill81
Registered User
1993 ZJ 
 
Join Date: Mar 2007
Location: Springfield, MO
Posts: 20
Quote:
Originally Posted by mvharb View Post
Also the radio, which by the way will play only on AM, goes off when either front door is opened.
perhaps unrelated problems? only playing AM sounds like your antena is either unplugged or your deck is shot. as far as it turning off... i had a short in one of my speaker wires that ran into my pasenger side front door. opening or closing the door, sometimes even rolling the window down would shut off my whole stereo. i had to remove the door panel and run a new wire, problem solved.

If A is success in life, then A equals x plus y plus z. Work is x; y is play; and z is keeping your mouth shut. - Albert Einstein
sjhill81 is offline  
post #7 of 13 Old 05-24-2011, 08:22 AM
mark512
Registered User
 
Join Date: May 2011
Location: Blacksburg
Posts: 2
As others have said, check your fuses! #8 (15amp) was the one that fixed it for me! I had trouble believing that a blown fuse would cause such varied problems, but replacing the fuse worked.

I have a 95 Grand Cherokee. The trouble all started at once after turning off one of the overhead lights. The Jeep still started, ran and drove fine. The problems were all related to peripheral electrical stuff. The door chime stopped working, a relay near the passenger's feet clicked rapidly when a door was open, the display in front of the gearshift stopped working, the stereo was a bit erratic, interior lights went crazy, etc.

Good luck!
mark512 is offline  
post #8 of 13 Old 06-03-2011, 07:51 PM
mattcampbell12
Registered User
 
Join Date: Jun 2011
Location: elkhart
Posts: 1
Confussed

I have the same issue, but replacing the fuse didn't work. It just keeps popping. Anyone know why?
mattcampbell12 is offline  
post #9 of 13 Old 11-27-2011, 09:42 AM
spydirman70
Registered User
 
Join Date: Nov 2011
Location: fitchburg
Posts: 1
my 95 jeep does the same. Door opens radio goes off, relay clicking, overhead lights don't work correctly. all fuses are good, strange stuff , any help?
By the way everything worked fine except the door locks until a friend played with the fuses to get them to work now the locks work but not correctly and the other problems started.

Last edited by spydirman70; 11-27-2011 at 09:45 AM. Reason: info
spydirman70 is offline  
post #10 of 13 Old 11-27-2011, 01:19 PM
merlot2twisty
Registered User
1997 ZJ 
 
Join Date: Nov 2008
Location: MiddleOfNowhere
Posts: 156
Have you been messing with any electrical components? Is the radio stock or aftermarket?
sounds like a shorft circuit that is allowing electrical backflow.

I once had a car that had a blown main fuse, but because of a crappy stereo install, there was a backflow of power that allowed the car to run, but all the gauges were screwy, etc. Once I fixed the wiring and replaced the main fuse, car was great.

So, if anything electrical is non-stock, or has been modified, start looking there.
merlot2twisty is offline  
post #11 of 13 Old 03-08-2012, 04:58 PM
SMGORDON1259
Registered User
1995 ZJ 
 
Join Date: Feb 2011
Posts: 39
Ok last night my daughter pressed the overhead light in the rear of the console , after this happened a constant clicking of What I assume is the s.a.m. (system alarm module) relay. the radio does not work the interior lights flash the System information does not work.

I get up this morning to tackle the problem I started first with the Overhead console and removed it. The Light Assembly's were loose because a couple mountings were broken ( fixed with super glue and a small piece of jb weld, yep Jb weld works on plastic great), The backs of the light housing has wires on it that are exposed at the connectors and when the light was pressed it shorted out on the roof metal ( Used CardBoard and tape to cover the connections before replacing).

I found that the #8 fuse was blown (15A mini blade fuse) Replaced it with another 15a and the problem is fixed.

Hope this helps everyone who has this problem

1995 Jeep Grand Cherokee Laredo 5.2 v8 magnum, Dana30/35, TC NP-249, Trans 46rh 170,000miles
SMGORDON1259 is offline  
post #12 of 13 Old 09-23-2013, 07:36 AM
Firefighter29
Registered User
1995 ZJ 
 
Join Date: Jul 2013
Location: Jacksonville
Posts: 18
I have a 95 ZJ 5.2L and I'm having different problems, first it started with my dash lights going out, But would come back on whenever and go back out, I bought a new dimmer switch and just as I was going to replace it the problem stopped. A few days later the vehicle info center above the shifter would reset the clock on it, so I would set the clock, 5 hours later it reset, I got tired of fighting it so I just held the "set" button so I wouldn't blink at me but it never reset that. So I set the correct time and it was fine, next was the horn, it sounds like Homer Simpson strangling Bart. Still works but not loud and just sounds like its dying. Next was the door chime. Instead of not working it did the exact opposite, it would ding like normal until the final ding and then it was a constant one tone ding that wouldn't stop until I shut off the ignition. I solved it by removing the chime module. Next I had a fm radio transmitter that you plug your phone/mp3 player to, I've had it for about a year and it's never been taken out of the power point until Friday when it decided to smoke and I pulled it out and it was melted, I had to throw it out the window cause it was so hot. I have not put anything in there since. Now the info center is back to resetting itself. Every time I go to trouble shoot one problem, it stops. I really need help this is a little outta my league and I do not want to spend $150 just so the the dealer can tell me what's wrong.
Firefighter29 is offline  
post #13 of 13 Old 09-23-2013, 07:46 AM
Firefighter29
Registered User
1995 ZJ 
 
Join Date: Jul 2013
Location: Jacksonville
Posts: 18
Oh and the alarm would go off randomly whenever I activated it, so I just would never lock the doors with the switch and locked them by hand. Now the lock switch doesn't work but unlock does.
Firefighter29 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Electrical problems in 1999 Jeep Grand Cherokee BDASigEp WJ Grand Cherokee Forum 3 06-02-2010 10:14 PM
2007 Grand Cherokee Electrical Problems mellentine WK Grand Cherokee & XK Commander Forum 6 10-18-2009 06:28 PM
1995 Grand Cherokee zj 5.2L Strating problems - Please Help yuvalb ZJ Grand Cherokee Forum 15 10-09-2007 04:31 PM
1995 Grand Cherokee 95PAGCLO ZJ Grand Cherokee Forum 15 06-13-2006 01:47 PM
1995 Ltd Grand Cherokee krypt68 ZJ Grand Cherokee Forum 12 12-16-2005 08:31 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome