1994 ZJ Larado won't start - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 1994 ZJ Larado won't start

Offset Tie Rod Kit From RuffStuff!The Ruffstuff NOT Universal 4 Link Kit!Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 06-26-2013, 03:15 PM   #1
rtrainer
Registered User
 
Join Date: Jun 2013
Location: Ellicott City, MD
Posts: 4
1994 ZJ Larado won't start

When I turn the key over, the dash lights light up but the starter does not crank the engine. Nothing. Interior lights, radio, locks all work.

Here are the things I tried:

1. Locked and unlocked using the key in all 3 doors.
2. Tried to start it in neutral.
3. Tried starting it while putting pressure on the transmission lever while it was in Park.
4. Disconnected the battery cables and cleaned the connectors and the battery posts. When I did this and tried to start it, the lights flashed like they should due to the immobilizer. Used the key in the tailgate and successfully turned off the immobilizer.
5. Removed and ohmed out the ignition switch.

So it sounds like it is down to the NSS or the starter solenoid.

I looked into the NSS and when I search at Advanced Auto Parts for a replacement, I get a small unit that has 3 terminals and looks more like a plug that what I see here, http://www.bc4x4.com/tech/2010/jeep-...ty-switch-nss/

Here is what I found at Advanced, http://shop.advanceautoparts.com/web...+safety+switch

I have not tried to connect a wire from the battery directly to the start solenoid to see it it turns over, but I believe it will as my daughter had been driving on and off all day.

Any ideas?

Thanks...rob

rtrainer is offline   Reply With Quote Quick reply to this message
Unread 06-26-2013, 03:50 PM   #2
Rook87
Registered User
1997 ZJ 
 
Join Date: Jul 2012
Location: Kankakee, Illinois
Posts: 96
Twice this week I came out to my jeep and it was doing the exact thing yours is doing. Lights, radio, everything was fine but just wouldn't even try to turn over. A quick jump start and it would fire right up. It's been taking what seems like a little longer then normal to crank over so I went ahead and replaced the Starter for now.
Rook87 is offline   Reply With Quote Quick reply to this message
Unread 06-26-2013, 03:56 PM   #3
WhiteOut
Web Wheeler
 
WhiteOut's Avatar
1998 ZJ 
 
Join Date: Dec 2007
Posts: 8,175
Put it in neutral and try to start it. If it doesn't then replace the starter.
WhiteOut is online now   Reply With Quote Quick reply to this message
Unread 06-26-2013, 04:23 PM   #4
rtrainer
Registered User
 
Join Date: Jun 2013
Location: Ellicott City, MD
Posts: 4
Quote:
Originally Posted by Rook87 View Post
Twice this week I came out to my jeep and it was doing the exact thing yours is doing. Lights, radio, everything was fine but just wouldn't even try to turn over. A quick jump start and it would fire right up. It's been taking what seems like a little longer then normal to crank over so I went ahead and replaced the Starter for now.
Tried jumping it..did not work.
rtrainer is offline   Reply With Quote Quick reply to this message
Unread 06-26-2013, 06:06 PM   #5
Rook87
Registered User
1997 ZJ 
 
Join Date: Jul 2012
Location: Kankakee, Illinois
Posts: 96
Quote:
Originally Posted by WhiteOut View Post
Put it in neutral and try to start it. If it doesn't then replace the starter.
I tried this aswell with no luck so thanks for making me feel better about replacing the starter first.
But ya, replace your starter. My girls jetta also with same symptoms but couldn't be jumped like yours was still the starter too.. Good luck man
Rook87 is offline   Reply With Quote Quick reply to this message
Unread 06-26-2013, 08:11 PM   #6
rtrainer
Registered User
 
Join Date: Jun 2013
Location: Ellicott City, MD
Posts: 4
After some testing tonight I think it is the NSS switch. I have come to this conclusion because I get 12v on contact #86 when the ignition switch is in the Start position, but I do not get continuity to ground when the shifter is in Park or Neutral. my problem now is that I cannot figure out where the NSS is on the transmission. I have a 42RE which has the one that looks like a plug with 3 contacts.
rtrainer is offline   Reply With Quote Quick reply to this message
Unread 06-26-2013, 08:20 PM   #7
xcaliber81
Registered User
1994 ZJ 
 
Join Date: Jul 2012
Location: Prince George, B.C
Posts: 3,016
try jumping the starter if it starts then the starter is gone.
xcaliber81 is offline   Reply With Quote Quick reply to this message
Unread 06-26-2013, 08:21 PM   #8
xcaliber81
Registered User
1994 ZJ 
 
Join Date: Jul 2012
Location: Prince George, B.C
Posts: 3,016
had the same problem a few months back ended up replacing the starter and battery, but my problem only existed in cold weather
xcaliber81 is offline   Reply With Quote Quick reply to this message
Unread 06-26-2013, 11:19 PM   #9
Oldfrog
Web Wheeler
1997 ZJ 
 
Join Date: Feb 2008
Location: Louisiana/Texas
Posts: 4,113
Quote:
Originally Posted by xcaliber81 View Post
try jumping the starter if it starts then the starter is gone.
^^ This.. ( or hit the starter with a hammer) ....and of course, the obvious question of :

How old is the battery? Jeeps HATE weak batteries.
__________________
Cajun Recipes and Fishing tips

Words of wisdom, Posted by Zeejay:
"..it's not air, it is the opposite of air... suckage so to speak."

Stalling? Work through Zeejay's list
Oldfrog is offline   Reply With Quote Quick reply to this message
Unread 06-28-2013, 07:16 AM   #10
Rook87
Registered User
1997 ZJ 
 
Join Date: Jul 2012
Location: Kankakee, Illinois
Posts: 96
He's not coming back to say if it's fixed or not huh..
Rook87 is offline   Reply With Quote Quick reply to this message
Unread 06-29-2013, 10:30 AM   #11
rtrainer
Registered User
 
Join Date: Jun 2013
Location: Ellicott City, MD
Posts: 4
Well I have and have not fixed it. Went and bought a new NSS but did some more testing on the existing one and found that it was working. Wasn't keen on trying to jump the starter so I hit it with a hammer. Boom, engine starts. So I will replace the starter in the next couple of days.
rtrainer is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.