1994 Grand cherokee fuel pump problem - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 1994 Grand cherokee fuel pump problem

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineFS: Jeep Fog Light LED Bulbs! Several Brightness Options! Clayton Off Road JK Short Arm Suspension Kits

Reply
Unread 02-18-2005, 07:58 PM   #1
mikemedic
Registered User
 
Join Date: Nov 2004
Posts: 12
1994 Grand cherokee fuel pump problem

I have a 1994 grand cherokee laredo. Sometime when you o to start the car it turns but doesnt kick over. I can not hear the fuel pump humming. So I go underneath and find the wiring harness for the fuel pump and wiggle it around, then it fstarts ok. I hear the hum. It never stalls once it starts and the fuel pump was replacd about a year ago. I also notice one time the fuel gauge read empty and there was several gallons of gas. Took it to my mechanic and he siad he tightened some wires? I am assuming it was this connection form the fuel pump assy to the wiring harness. I think I have a loose connection in that male/female connection? Ok so i can identify the culprit wire. i sprayed some contact cleaner on the pins to make a better cleaner connection tonight, so far so good but i bet it will cut out again. Can anybody tell me what the five wires supple and the colors from that connection( fuel pump harness to wire assy?) If I could find te culprit wire i may be able to fix. Does anyone have any other ideas , again once it starts it will run fine. An diagram explaining those wires would be great. I have the hayes manual but cant seem to track that 5 pin connection down


Thanks---Mike

mikemedic is offline   Reply With Quote
Unread 02-19-2005, 07:43 AM   #2
driabyor
Registered User
1994 ZJ 
 
Join Date: Apr 2004
Location: chilton-haynes<$20
Posts: 2,450
it could be a broken wire at the connector.. your wiggling is causing it to make contact again.... you may have to replace the plugs.. or just hard wire it...

another option is to get some contact cleaner ,spray on both plugs . then put some dielectric grease on them
__________________
94 Grand Cherokee ... 332,000 miles
5.2 liter 242 :)
Rancho 5000 steering stabilizer
driabyor is offline   Reply With Quote
Unread 02-19-2005, 07:49 AM   #3
mikemedic
Registered User
 
Join Date: Nov 2004
Posts: 12
yeah, thats what i thought..I did spray some contact cleaner on the plugs..drenched them. then reassembled... where do you buy dielectric grease? auto store?

Does anybody have the wiring diagram for that particular connection?
mikemedic is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.