12 Things You Can Do When Your ZJ Stalls - Page 6 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 12 Things You Can Do When Your ZJ Stalls

TeraFlex Now at Rockridge 4WD! BEST DEALS around!Alloy usa heavy duty ball joint kitsENGO QUADLUX 6" to 54" LED AMBER AND WHITE MULTI

Reply
Unread 06-21-2013, 03:05 PM   #76
DickDickle
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Dracut, Ma
Posts: 543
When my jeep stalls I have to pull the 20 amp fuse from the junction block for the pcm/asd for a few seconds put it back in and it fires right up some days it will stall four times in one trip some days it never acts up

DickDickle is offline   Reply With Quote Quick reply to this message
Unread 06-21-2013, 05:33 PM   #77
coralman
new wrangler prototype
 
coralman's Avatar
1998 ZJ 
 
Join Date: Jul 2010
Location: florida
Posts: 4,533
I'll start a vote to get this is the stickies, right after i get my free trailer hitch Zee always does good diligent work.
__________________
deep from the bowels of mopar design

Links to axle rebuilds, mount replace,a/c box rebuild,ect in history section of my profile page
coralman is online now   Reply With Quote Quick reply to this message
Unread 06-21-2013, 05:40 PM   #78
JS97ZJ
Registered User
1997 ZJ 
 
Join Date: Dec 2009
Location: Dingmans Ferry, PA
Posts: 2,035
You know you'll get my vote.
JS97ZJ is offline   Reply With Quote Quick reply to this message
Unread 06-21-2013, 07:09 PM   #79
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,590
Quote:
Originally Posted by mcp2009 View Post
if anyone has any guesses or assumptions please let me know
You are a prime candidate for #4, then 3.
ZeeJay1997 is offline   Reply With Quote Quick reply to this message
Unread 06-21-2013, 07:12 PM   #80
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,590
Quote:
Originally Posted by DickDickle View Post
When my jeep stalls I have to pull the 20 amp fuse from the junction block for the pcm/asd for a few seconds put it back in and it fires right up some days it will stall four times in one trip some days it never acts up
The PCM is suspect, but could be something reverse biasing one of the circuits or possibly a bad ground on the engine block.

Also try swapping ASD relay with horn relay.
ZeeJay1997 is offline   Reply With Quote Quick reply to this message
Unread 06-21-2013, 07:14 PM   #81
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,590
Quote:
Originally Posted by coralman View Post
I Zee always does good diligent work.
Dont tell anyone, you'll ruin my reputation
ZeeJay1997 is offline   Reply With Quote Quick reply to this message
Unread 06-21-2013, 07:19 PM   #82
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,590
Quote:
Originally Posted by coralman View Post
I'll start a vote to get this is the stickies, right after i get my free trailer hitch
Quote:
Originally Posted by JS97ZJ View Post
You know you'll get my vote.
It already has more hits than the rules and guidelines.
ZeeJay1997 is offline   Reply With Quote Quick reply to this message
Unread 06-23-2013, 06:27 AM   #83
Texas ZJ1
Jeep Jedi Master
 
Texas ZJ1's Avatar
1994 ZJ 
 
Join Date: Mar 2003
Location: Omaha, NE
Posts: 20,133
This thread was just added to the faqs page. Thanks ZeeJay for the hard work.


Hunter
__________________
00 4.7 Laredo...stock

94 5.9 Laredo 6.5 RE lift with 35 Maxxis Bighorns
and 33 Bridgestone Duelers
Detroit and true trac
Red Jeep Club Member
REDNECK JCM
Texas Jeep Owner #6
USN Jeep Club #4
http://www.kevinsoffroad.com/
602.841.3355

For your performance needs:

kolak@kolakperformance.com
480.998.3661
Texas ZJ1 is offline   Reply With Quote Quick reply to this message
Unread 06-26-2013, 07:07 AM   #84
DickDickle
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Dracut, Ma
Posts: 543
So I ended up swapping my asd relay with the horn relay and noticed no change, I also tried a brand new relay with no change. I had a few computers in stock so I changed the computer out but before doing so I scanned the jeep for codes and the only code that came up was number 42 for high fuel volts. I disconnected the battery and swapped computers, I have not experienced any stalling yet but I did notice that on my way to work this morning my fuel Guage was at about half a tank and while sitting at a red light it dropped to e and never came back where as with the old computer if the fuel level would drop to e and a few seconds later it would return to normal. Wouldn't that be a sending unit problem or could the computer have something to do with that too? I have one more spare computer I could try and I just want to mention that all three computers I have do have the exact same part numbers on them
DickDickle is offline   Reply With Quote Quick reply to this message
Unread 06-26-2013, 10:01 AM   #85
DickDickle
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Dracut, Ma
Posts: 543
I know that the dtc code 42 can also be for low fuel voltage or for the asd I don't know if this code has to do with errartic fuel level display or not
DickDickle is offline   Reply With Quote Quick reply to this message
Unread 06-26-2013, 11:15 AM   #86
DickDickle
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Dracut, Ma
Posts: 543
Just went to swap in computer number 3 and before I did I scanned it again and got dtc code 11 disconnected the battery put the 3rd computer in went to pick up lunch drove about 5 miles and the jeep died going down the road right in front of the shop luckily, I opened the central junction box pulled out the 20 amp mini fuse put it back in and the jeep restarted normally could this be the start of a bad cps? I scanned it after the stall and my scan tool is showing no codes.....
DickDickle is offline   Reply With Quote Quick reply to this message
Unread 06-26-2013, 07:31 PM   #87
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,590
yes it sounds like either the CPS or O2 sensor is shorting the 5v sensor supply. try disconnecting o2 sensors. you'll get a code, but if it quits stalling, you'll know what the problem is.

If that doesnt work, you are probably looking at a failing CPS.

The fuel gauge problem you described on the other PCM could be caused by the PCM, guage or fauly connection at the fuel tank.

I'm assuming since you posted on this thread that you have gone through all of the troubleshooting?
ZeeJay1997 is offline   Reply With Quote Quick reply to this message
Unread 06-26-2013, 08:41 PM   #88
DickDickle
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Dracut, Ma
Posts: 543
I have gone through all of the trouble shooting I'm now curious of the cam position sensor because I'm getting 5v at the plug but only getting a little over 3v on the sensor side. I'm gong to put it on the scope tomorrow to get a better idea of what is going on I will take some pictures of the readings I tried switching the crank position sensor with no change it stalled 5 times on a 16 miles ride this evening
DickDickle is offline   Reply With Quote Quick reply to this message
Unread 06-27-2013, 04:13 AM   #89
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,590
Quote:
Originally Posted by DickDickle View Post
I'm getting 5v at the plug but only getting a little over 3v on the sensor side.
You're rotating the crank I presume? On mine the engine usually stops with the field collapsed. When I go to the output wire with the key on, I get 5V.
ZeeJay1997 is offline   Reply With Quote Quick reply to this message
Unread 06-27-2013, 05:43 AM   #90
DickDickle
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Dracut, Ma
Posts: 543
I tested it running I have test leads the thickness of safety pins so I can tap right into the wires
DickDickle is offline   Reply With Quote Quick reply to this message
Reply

Tags
bucking , check engine light , hesitation , no start , stall issue

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.