12 Things You Can Do When Your ZJ Stalls - Page 6 - JeepForum.com

 6Likes
Reply
 
LinkBack Thread Tools
post #76 of 435 Old 06-21-2013, 04:05 PM
DickDickle
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Dracut
Posts: 545
When my jeep stalls I have to pull the 20 amp fuse from the junction block for the pcm/asd for a few seconds put it back in and it fires right up some days it will stall four times in one trip some days it never acts up

DickDickle is offline  
Sponsored Links
Advertisement
 
post #77 of 435 Old 06-21-2013, 06:33 PM
coralman
USER OF PARTS CATALOGS
 
coralman's Avatar
1998 ZJ 
 
Join Date: Jul 2010
Location: florida
Posts: 7,597
I'll start a vote to get this is the stickies, right after i get my free trailer hitch Zee always does good diligent work.

Info on projects and repairs categorized by system

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Originally Posted by HighLonesome
lol...if life is as a simple as a 5.9 making you happy, I'd say go ahead and buy it on impulse. ZJs are the way of Zen. Wax on, wax off
coralman is offline  
post #78 of 435 Old 06-21-2013, 06:40 PM
JS97ZJ
Registered User
2004 WJ 
 
Join Date: Dec 2009
Location: Dingmans Ferry
Posts: 2,286
You know you'll get my vote.
JS97ZJ is offline  
post #79 of 435 Old 06-21-2013, 08:09 PM Thread Starter
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 8,842
Quote:
Originally Posted by mcp2009 View Post
if anyone has any guesses or assumptions please let me know
You are a prime candidate for #4, then 3.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ZeeJay1997 is online now  
post #80 of 435 Old 06-21-2013, 08:12 PM Thread Starter
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 8,842
Quote:
Originally Posted by DickDickle View Post
When my jeep stalls I have to pull the 20 amp fuse from the junction block for the pcm/asd for a few seconds put it back in and it fires right up some days it will stall four times in one trip some days it never acts up
The PCM is suspect, but could be something reverse biasing one of the circuits or possibly a bad ground on the engine block.

Also try swapping ASD relay with horn relay.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ZeeJay1997 is online now  
post #81 of 435 Old 06-21-2013, 08:14 PM Thread Starter
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 8,842
Quote:
Originally Posted by coralman View Post
I Zee always does good diligent work.
Dont tell anyone, you'll ruin my reputation


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ZeeJay1997 is online now  
post #82 of 435 Old 06-21-2013, 08:19 PM Thread Starter
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 8,842
Quote:
Originally Posted by coralman View Post
I'll start a vote to get this is the stickies, right after i get my free trailer hitch
Quote:
Originally Posted by JS97ZJ View Post
You know you'll get my vote.
It already has more hits than the rules and guidelines.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ZeeJay1997 is online now  
post #83 of 435 Old 06-23-2013, 07:27 AM
Texas ZJ1
Jeep Jedi Master
 
Texas ZJ1's Avatar
1994 ZJ 
 
Join Date: Mar 2003
Location: Omaha
Posts: 20,349
This thread was just added to the faqs page. Thanks ZeeJay for the hard work.


Hunter

04 4.7 HO, limited

08 Z71 Suburban, front leveling kit with rear spacers. 285/65 18s Nitto TerraGrappler G2s

94 5.9 Laredo 6.5 RE lift with 35 Maxxis Bighorns
and 33 Bridgestone Duelers
Detroit and true trac
Red Jeep Club Member
REDNECK JCM
Texas Jeep Owner #6
USN Jeep Club #4

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

602.841.3355

For your performance needs:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

480.998.366
Texas ZJ1 is offline  
post #84 of 435 Old 06-26-2013, 08:07 AM
DickDickle
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Dracut
Posts: 545
So I ended up swapping my asd relay with the horn relay and noticed no change, I also tried a brand new relay with no change. I had a few computers in stock so I changed the computer out but before doing so I scanned the jeep for codes and the only code that came up was number 42 for high fuel volts. I disconnected the battery and swapped computers, I have not experienced any stalling yet but I did notice that on my way to work this morning my fuel Guage was at about half a tank and while sitting at a red light it dropped to e and never came back where as with the old computer if the fuel level would drop to e and a few seconds later it would return to normal. Wouldn't that be a sending unit problem or could the computer have something to do with that too? I have one more spare computer I could try and I just want to mention that all three computers I have do have the exact same part numbers on them
DickDickle is offline  
post #85 of 435 Old 06-26-2013, 11:01 AM
DickDickle
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Dracut
Posts: 545
I know that the dtc code 42 can also be for low fuel voltage or for the asd I don't know if this code has to do with errartic fuel level display or not
DickDickle is offline  
post #86 of 435 Old 06-26-2013, 12:15 PM
DickDickle
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Dracut
Posts: 545
Just went to swap in computer number 3 and before I did I scanned it again and got dtc code 11 disconnected the battery put the 3rd computer in went to pick up lunch drove about 5 miles and the jeep died going down the road right in front of the shop luckily, I opened the central junction box pulled out the 20 amp mini fuse put it back in and the jeep restarted normally could this be the start of a bad cps? I scanned it after the stall and my scan tool is showing no codes.....
DickDickle is offline  
post #87 of 435 Old 06-26-2013, 08:31 PM Thread Starter
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 8,842
yes it sounds like either the CPS or O2 sensor is shorting the 5v sensor supply. try disconnecting o2 sensors. you'll get a code, but if it quits stalling, you'll know what the problem is.

If that doesnt work, you are probably looking at a failing CPS.

The fuel gauge problem you described on the other PCM could be caused by the PCM, guage or fauly connection at the fuel tank.

I'm assuming since you posted on this thread that you have gone through all of the troubleshooting?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ZeeJay1997 is online now  
post #88 of 435 Old 06-26-2013, 09:41 PM
DickDickle
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Dracut
Posts: 545
I have gone through all of the trouble shooting I'm now curious of the cam position sensor because I'm getting 5v at the plug but only getting a little over 3v on the sensor side. I'm gong to put it on the scope tomorrow to get a better idea of what is going on I will take some pictures of the readings I tried switching the crank position sensor with no change it stalled 5 times on a 16 miles ride this evening
DickDickle is offline  
post #89 of 435 Old 06-27-2013, 05:13 AM Thread Starter
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 8,842
Quote:
Originally Posted by DickDickle View Post
I'm getting 5v at the plug but only getting a little over 3v on the sensor side.
You're rotating the crank I presume? On mine the engine usually stops with the field collapsed. When I go to the output wire with the key on, I get 5V.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ZeeJay1997 is online now  
post #90 of 435 Old 06-27-2013, 06:43 AM
DickDickle
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Dracut
Posts: 545
I tested it running I have test leads the thickness of safety pins so I can tap right into the wires
DickDickle is offline  
Reply

Tags
grounds , hesitation , no start , stalling , wiring

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
95 ZJ stalls? longtravel1 ZJ Grand Cherokee Forum 2 09-06-2011 11:12 PM
Stalls when low on gas. sk8tgk ZJ Grand Cherokee Forum 3 10-08-2010 01:34 PM
stalls toolman401 ZJ Grand Cherokee Forum 1 02-18-2010 07:19 PM
95 4.0 stalls when off the gas liredneck ZJ Grand Cherokee Forum 8 04-20-2009 07:45 PM
Please HELP my 95 Zj stalls wrestlerobx ZJ Grand Cherokee Forum 43 05-18-2008 09:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome