12 Things You Can Do When Your ZJ Stalls - Page 5 - JeepForum.com
 1Likes
Reply
 
LinkBack Thread Tools
post #61 of 429 Old 03-21-2013, 06:44 AM
Vortexium
Registered User
1998 ZJ 
 
Join Date: Mar 2013
Location: Hazleton
Posts: 36
I got a 98 ZJ. 5.2 V8. It was doing this before and I replaced the cat and muffler, due to both being clogged, tune up, fixed the issue. Now it has a low idle in drive and reverse. Wants to stall, but won't. Starts up fine about half the time. I just replaced the distributor pick up as well, still doing it. Fuel pressure is at 50 PSI. Need some help!

Vortexium is offline  
Sponsored Links
Advertisement
 
post #62 of 429 Old 03-21-2013, 06:21 PM
phitmein
Web Wheeler
 
phitmein's Avatar
1995 ZJ 
 
Join Date: Feb 2009
Location: Columbia
Posts: 2,768
clean your throttle body maybe .

Did it start doing it all of a sudden or gradually .
phitmein is offline  
post #63 of 429 Old 03-21-2013, 06:40 PM Thread Starter
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 8,555
Quote:
Originally Posted by Vortexium View Post
I got a 98 ZJ. 5.2 V8. It was doing this before and I replaced the cat and muffler, due to both being clogged, tune up, fixed the issue. Now it has a low idle in drive and reverse. Wants to stall, but won't. Starts up fine about half the time. I just replaced the distributor pick up as well, still doing it. Fuel pressure is at 50 PSI. Need some help!
You've eliminated secondary ignition,restricted exhaust, and fuel pressure. Work your way down the list.

how is battery/charging system?
ZeeJay1997 is offline  
post #64 of 429 Old 03-22-2013, 01:40 AM
phitmein
Web Wheeler
 
phitmein's Avatar
1995 ZJ 
 
Join Date: Feb 2009
Location: Columbia
Posts: 2,768
ZeeJay, his post is still a bit vague to me ?

Vortex, does it run well at higher speeds ?
phitmein is offline  
post #65 of 429 Old 04-14-2013, 06:24 PM
joshyoung
Registered User
 
Join Date: Apr 2013
Posts: 1
New subscriber here, but just want to say thanks for taking the time. My 97 wasn't stalling, but idling really low and hard at stops. After reading your post, I replaced the IAC and TPS and cleaned the throttle body. I also checked and cleaned the fuses and relays. No more hard idle. Thanks again, I'm loving the forum. Just started changing my own oil a year ago, and it is awesome to be able to learn here and get the confidence to do more and more things.
joshyoung is offline  
post #66 of 429 Old 04-14-2013, 06:35 PM Thread Starter
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 8,555
Quote:
Originally Posted by joshyoung View Post
New subscriber here, but just want to say thanks for taking the time.
YW, Thanks for reading!
ZeeJay1997 is offline  
post #67 of 429 Old 04-14-2013, 06:50 PM
phitmein
Web Wheeler
 
phitmein's Avatar
1995 ZJ 
 
Join Date: Feb 2009
Location: Columbia
Posts: 2,768
Josh, fill in your profile when you get a chance and it will help here if you have question on your Jeep .

Nice work fixing your ride .
phitmein is offline  
post #68 of 429 Old 05-08-2013, 07:31 AM
Uniblurb
Web Wheeler
 
Uniblurb's Avatar
1996 ZJ 
 
Join Date: Jan 2012
Location: Central
Posts: 6,576
This thread is falling waay too far back and needs to be brought back up to the front. I still don't see it as a sticky or in the FAQ's where it should be!

ZeeJay, I installed a link to this thread in my sig since tired of searching for it and will try to point members to it when need be. I'll try to do this before my narrow mindset says it's a bad crank sensor after going through 4-5 of them.
Uniblurb is offline  
post #69 of 429 Old 05-10-2013, 06:18 AM Thread Starter
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 8,555
Thanks Uni

Or we could forget about this thread and buy some stock in auto parts.
ZeeJay1997 is offline  
post #70 of 429 Old 05-10-2013, 09:32 PM
phitmein
Web Wheeler
 
phitmein's Avatar
1995 ZJ 
 
Join Date: Feb 2009
Location: Columbia
Posts: 2,768
phitmein is offline  
post #71 of 429 Old 05-11-2013, 11:39 PM
hdrocknroll
Registered User
1995 ZJ 
 
Join Date: Dec 2011
Location: Flint
Posts: 2,274
HI tech approach, Wiggle wires to track it down

Always !! Keep A Firm Grip On Your Tool !!

Watch Out For The Air Hose Gone Wild!! Or Wear A Cup,: True Story


Quote:
Originally Posted by rooster51 View Post
Whats the worse that can happen? Your jeeps already broke.


hdrocknroll is offline  
post #72 of 429 Old 05-12-2013, 03:08 AM
KoreaZJ
Registered User
1994 ZJ 
 
Join Date: Aug 2011
Location: GANGNAM STYLE
Posts: 2,666
Quote:
Originally Posted by hdrocknroll View Post
HI tech approach, Wiggle wires to track it down
KoreaZJ is offline  
post #73 of 429 Old 06-01-2013, 09:33 AM Thread Starter
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 8,555
[QUOTE=KoreaZJ;15422316]
I wonder why Chrysler dropped the once a month maintenance from the later model ZJ owner's manual? Must have needed more shop visits...
ZeeJay1997 is offline  
post #74 of 429 Old 06-21-2013, 10:29 AM
mcp2009
Registered User
1996 ZJ 
 
Join Date: Mar 2011
Location: YORK
Posts: 29
My 96 Jeep Grand Cherokee Laredo was stalling when coming to stops or just braking. After it stalled I could usually start it right back up or I would have to try a couple times but I had to be careful because if I tried starting it too much the battery would die. Took it to my mechanic and he said the fuel pump was bad so I got it replaced. All seemed well and then a few days later after coming home from the gym right when I parked the car shut off. This time I had to hook up my charger for it too start. I made sure it started and then turned it off, the next day in the morning battery is dead so I charge it up again and drive around to a couple places and it doesn't stop at all. Then I decide to go to a buddy's house and sure enough the damn thing stops on the highway after sitting at a light for a few mins. This time I figured it'd be like before when I got the fuel pump replaced so I try to start it but the battery seems dead luckily a good Samaritan helps push it into a parking lot for me.

Since my buddy lives around the corner he drives over to jump my car and after a few mins we get it started but less than a minute after we unhook the cables my damn car shuts off. We jump it again and make it part way to advance auto but it shuts off at another light and we have to push it the rest. We get there and the guy was completely useless, just says the battery is bad and tries to sell me a new one (week prior they said batt was good). We get it jumped again and try to drive to my friends house and it shuts off about 4 times on the way back but starts right back up. We make it to his house and leave it there and I borrow his car.

Come back the next day and battery is dead, my mechanic said check the battery and alternator so we take the battery out and put it on the charger while I remove the alternator. Take them both to advance and they say both are good battery just needs more charge, go to auto zone and they say alternator is good but battery is bad, and lastly we go to NTB and they can only test the battery but they say it is bad but it possibly could just need a recharge since it's been out the car for an hour or more. After all that we just put everything back in and I didn't want to risk driving it on the highway again. I plan on getting it towed to my house so it's closer for me too look at and I have no car to drive over there when I'm off work.

Sorry for the long story but I figured I'd say exactly what happened. I plan on trying method number 1 tomorrow but this whole ordeal is frustrating. Guy at NTB says take it to a dealer but I have no extra cash right now due to getting this fuel pump. I'm not car savy at all and only took the alternator out due to a helpful youtube video but I'm gonna try some methods on this thread but if anyone has any guesses or assumptions please let me know
mcp2009 is offline  
post #75 of 429 Old 06-21-2013, 02:00 PM
Oldfrog
Registered User
2007 WK 
 
Join Date: Feb 2008
Location: Louisiana/Texas
Posts: 5,091
Dont take it to a dealer because you'll get charged up to $1500 and in most cases it wont even be fixed. Go through Zeejays list on this thread, one by one. Then report back to us on your own thread, not this one.

2007 5.7 Hemi, Ltd. QD II -
1997 ZJ, 4,0 select trac, Up country, track lok.
Oldfrog is offline  
Reply

Tags
grounds , hesitation , no start , stalling , wiring

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
95 ZJ stalls? longtravel1 ZJ Grand Cherokee Forum 2 09-06-2011 10:12 PM
Stalls when low on gas. sk8tgk ZJ Grand Cherokee Forum 3 10-08-2010 12:34 PM
stalls toolman401 ZJ Grand Cherokee Forum 1 02-18-2010 06:19 PM
95 4.0 stalls when off the gas liredneck ZJ Grand Cherokee Forum 8 04-20-2009 06:45 PM
Please HELP my 95 Zj stalls wrestlerobx ZJ Grand Cherokee Forum 43 05-18-2008 08:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome