JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   ZJ Grand Cherokee Forum (http://www.jeepforum.com/forum/f13/)
-   -   12 Things You Can Do When Your ZJ Stalls (http://www.jeepforum.com/forum/f13/12-things-you-can-do-when-your-zj-stalls-1407423/)

ZeeJay1997 08-19-2012 09:29 PM

12 Things You Need To Do When Your ZJ Stalls
 
This gets a little long winded, so if you have a short attention span, read the bold print.

A lot of people come to the forum looking for simple answers to their stalling/hesitation/bucking/no starts. This is about as simple as it gets. I wrote this because I don't type well enough to recommend the same maintenance actions in individual threads to everyone who has a stalling problem. If i referred you to this in your thread, I'm not being mean, just practical. :) If you don't plan on doing any of this, you could throw parts at it until you fix it, give up on it and sell it, go stark raving mad, or pay someone more than it's worth to figure it out. If you like doing yourself favors, keep reading. Then, just do it. If you're intimidated by it, take it to shop and have them do it or phone a friend. This doesn't require much technical know how, but is very important to the drivability of your Jeep. It will not fix itself and any advise you get on possible causes will be compromised.

Finding a stall problem is akin to finding a needle in a haystack. Accomplishing the following will greatly reduce the size of the haystack. You'll want to do these with a determination that you’re going to solve the problem without changing a sensor. There are common causes for these problems and simple methods to eliminate them and/or determine if they may be affecting your vehicle. Let's call them the "dirty dozen". Most of the items are routine maintenance that often get overlooked. All are are possible causes of no-code stalls. They may eliminate spending an exorbitant amount of resources that would be better spent on something more tangible, like a good multimeter or scanner, lift kit, or a new stereo.

This information is derived from my personal experience of owning an I6 ZJ for 15 years, solving my own problems with the aid of a factory service manual, helping people with their problems, some knowledge of all things electronic, and reading intently trying to figure out how to keep my vehicle on the road without breaking the bank.


NO STARTS: Most of the dirty dozen apply to no start conditions as well. If you have no start, check out Ratmonkey's (RIP) approach to no start conditions. Check to see if the CEL comes on for three seconds when the switch is is placed in the ON position. If you know that the CEL was functioning prior to the problem you are having, but it is not coming on now, the PCM is dead. Check for a blown fuse in the PDC. (if you don't know what these are, keep reading) If a fuse is blown, get under your vehicle and do #9. A dead PCM can also be caused by a shorted crank sensor or O2 sensor. Sometimes, if you are lucky you can disconnect the wiring to one of these sensors and the CEL will start its 3 second check again. Of course it will not start without the crank sensor, but will run without O2 sensor. If it runs for a few seconds then shuts off, the security system is suspect.

The charging system is a major cause of no starts and you should follow the link in #4 to get some good advice on checking your system.

If you are proficient at using a meter and have no start, check out this step by method to determine where the problem may lie. Note: All sensor voltages from the PCM should be 5 volts on the 96-98 system. Earlier models may be per the above link, but I have found that the 93 varies from "8 Volt Supply Testing". See schematics here.

if you just bought a non running unit with a 4.0, someone may have misaligned the distributor. To eliminate this as a cause, check the alignment.

This may seem sort of silly, but if you *think* you have 1/4 tank of fuel, run down to gas station with your mower can and pick up a couple of gallons and put in in your ZJ. They have a tendency to show 1/4 tank when it's really empty. There was a recall on 97s but that doesn't preclude other models from similar behavior.

CODES:
Check for codes regardless of the Check Engine Lamp (CEL). Diagnostic Trouble Codes (DTC’s) are the results of a system or circuit failure, but do not directly identify the failed component or components. If the code is not emissions related or has not occurred a set amount of times, the light will not illuminate. Do not assume because the lamp was on and the PCM turned it off, there are no codes stored. It takes 40 cycles for it to dump the code out of memory.

Some auto parts stores will read the codes for you, or you can do the “key trick” to get the two digit trouble codes to display on the odometer or count the flashes of the CEL. The “key trick” is cycling the ignition key On - Off - On - Off – On within 5 seconds, works on everything but a 98, and can represent several different possibilities of diagnostic trouble codes (DTCs) or P codes. So it’s better to get the P code to begin with. If you can spring for it, do yourself a favor and pick up a cheap code reader. You’ll be better off in the long run, keep it under your back seat. There are numerous discussions posted on the Jeep Forum about possible solutions to every imaginable code.

See this post for a description of non-monitored circuits.


Things you will need:
  • An open hood :D
  • Problem solving skills
  • PATIENCE
  • Bright light (and mirror)
Things you may need:
  • Combination wrenches up to 15mm or 9/16
  • Couple of screwdrivers
  • Contact cleaner
  • Dielectric grease
  • Soft bristle brush
  • Small steel brush
  • Fine sandpaper or crocus cloth
  • Fuel pressure tester
  • Can of fuel treatment
  • Tune up kit
  • Multimeter
  • 2x4" x swinging length
  • A helper

One of these is just as likely to cause a stall as the other, so the list is random. I do not address timing or severity of the stalls caused by each problem because only a couple have unique effects.

#1. "THE BRAIN": Behind the coolant reservoir on the firewall there is black box. This is "the brain". This colloquial metaphor probably makes some of you highly trained and pedigreed mechanics cringe, but what the hey...Two types of "brain" were produced for the ZJ, 93-95 has a unit that controls only the engine (you may see it called ECM, ECU, or PCM), and 96-98 has a combined unit that controls both the engine and transmission (PCM) and each type unit has its own set of common failures. For the older models, there is a proven method of repair that could heal a variety of problems from no start to stalls and cost all of five dollars.

The following applies to the later models and this problem generally presents itself as bucking at cruise or just dieing out of the blue with no CEL. It can cause a problem with any circuit related to the engine or transmission.

Start engine (if it won't start, get someone to hold the key to start position) and gently rock and pull on each connector and listen for changes to the way the engine is running (or see if it starts). Then use a screwdriver handle or small wrench to tap the case of the PCM all over. You are trying to send the vibrations to the inside of the case, but not to extent that you are marring or mutilating the case. If you hear changes, this is a problem. One of two things is wrong. Either the PCM has deteriorated solder joints inside (very likely), or the contacts in the connectors are loose or need cleaning.

To clean the connectors:
  1. Disconnect battery.
  2. Remove the coolant reservoir. Three screws, bracket and all, sit on covered battery.
  3. There should be two locking tabs on each connector, one on top and one on bottom that you can’t see. Pinch the two tabs together and pull straight out while rocking the connector.
  4. Spray Electronic contact cleaner in and on all plug contact area and PCM contact area. Use soft (horsehair) bristle brush to scrub the pins as you flood with cleaner. Allow to dry for 4-8 minutes. Use air if you have it.
  5. Put Dielectric Silicone Compound on all contact areas and plugs.
  6. Plug back in firmly being careful not to bend the pins and be sure the locking tabs snap on.
  7. Reinstall reservoir, be sure to route the hose back through the hole in the fender well.
  8. Reconnect battery.
Start it up and try the wiggle test again. If you are very lucky, you just solved your problem. If not, it will either start its antics immediately or wait a few days to rear its ugly head again. If wiggle check fails after a few days or even weeks, no amount of re-cleaning will help.

There is also the possibility that the contacts in the connectors are worn out. You can go one of two routes to eliminate this as a cause. If you have the resources, the contacts can be replaced or you can try to restore the tension of the contacts inside the connector

A caveat to the wiggle test: just because it passes does not mean the PCM is good, but you have eliminated the most common failure mode of this type PCM.

If you want to take the risk of running with a temp repair, a lot of times installing large zipties vertically around the back and over the connectors in a fashion to excerpt enough pressure on the connector to cause the solder joints or contacts to “make” again will give you some joy. Use large Zip Ties (get them at the HVAC section of big box home improvement) to secure the connectors tight enough to prevent the connector from moving with light hand pressure. Just remember not to depend too much on your vehicle if you add the zipties and the symptoms go away.

http://www.jeepforum.com/forum/attac...rokee-vac2.jpg

The flaky connections from the wiggle test can be repaired if you or someone who can be bribed with six-pack has the technical talent and tools to pull it off. One of our more technical savvy members has generously posted an awesome do-it-yourself repair for the 96-98 that can be a used to bring you joy. JS97ZJ put a lot of time and effort into figuring all of this out and posting it up so don't forget to say thanks when you save yourself a wad of cash.

Here is a list of things from Chrysler (Mr. Mopar) that attribute to mis-diagnosis of PCM on 96-98 models. If you have the technical skills, use this as a checklist before you bite the bullet and buy a PCM. I elaborate on some of these elsewhere in the article.

Common failures that cause mis-diagnosis of JTEC Controllers (PCM):
• Intermittent grounds; Loose or corroded grounds may cause false sensor
readings. Verify all sensor grounds terminate at PCM cavity A4 (BK/LB wire). See #2
• Manifold absolute pressure (MAP) sensor and Throttle position sensor
(TPS) voltages; check voltage over the entire range, not just the extremes.
Whenever possible use an oscilloscope to check MAP sensor
and TPS sensor output voltages for noise spikes.
• Verify minimum TPS voltage. Minimum TPS voltage should be approximately
0.5 to 1.5 VDC.
• Idle Air Control (IAC); Shorted windings or intermittent connections.
If IAC codes are present, check to ensure motor windings or related
connectors are not shorted to ground.
• Heater voltage for upstream and downstream oxygen sensors. Verify
battery volts +/-1 volt at all oxygen sensor connectors, DG/OR wire.
• Charging system malfunction; Alternator defective or battery not fully
charged. Check alternator output to ensure there is not excessive ripple
voltage. Verify battery volts +/-1 volt at PCM cavity A22 (RD/WT wire).
• Sensor voltage supply. Check for approximately 5 volt output from PCM
cavity A17 (VT/WT wire) to MAP and TPS sensor, with ignition switch on.
• Distributor voltage supply. Check for approximately 5 VDC output from
PCM cavity A17 (VT/WT wire), or to cam/crank connector(s) with ignition
switch on and while cranking.

Wiring colors may vary. These are for 96-98. If you dont know how to check these items and you
have meter and know how to use it, reply to this post or start your own and ask the questions.

Troubleshooting Tips --- Other things to consider
• Auto-shutdown (ASD) relay; Corroded wires or faulty relay.
• Minimum air flow; check for air leaks or airflow obstruction.
• Vacuum system; Contaminants or leaks in vacuum lines.
• Fuel pressure and leak down.
• Vehicle speed sensor operation.
• Crankshaft and Camshaft sensors; Some aftermarket sensors have
not worked properly with Mopar engine controllers.
• Splices and Fusible Links; check for open and/or shorted wires.
• Damaged connector terminals; Always ensure holding tabs are securely
seated.
• Excessive current on certain connector pins may damage the PCM. Use
of a test lamp or a short in the wiring harness of the vehicle can cause this
condition. Always use a DVM when checking the unit/system.
• Check Technical Service Bulletins according to model year and system
malfunction

http://www.jeepforum.com/forum/attac...okee-black.jpg
http://www.jeepforum.com/forum/attac...okee-white.jpg
http://www.jeepforum.com/forum/attac...rokee-gray.jpg


If you want to replace your PCM, a reman may or may not be your answer. You never know what you'll get when you order a PCM online; reman, refurb, whatever; I'm not sure any of them actually rework the solder joints on the connectors. I have personally had four PCMs on my vehicle. Some of the repair and return shops and internet PCM exchange houses are roll of the dice and I do not recommend using them, though some users are satisfied. Most auto part store sell A1Cardone and some sell Standard. They come with a years warranty and I had to utilize it. I finally got an A1Cardone to hold. Send Kolak a PM and see what options he offers.

I can't let this go unsaid: There is a website out there somewhere that offers to send you a fix for your stalling problems. Don't get suckered into this. If you want to give away 20 bucks, give to a charity or homeless person. The information they send you is available in this write-up, except this write-up doesn't propagate myths (the two screws, notice i say this in small font so maybe no one will mistake it for a fix) or pretend that you've permanently fixed your problem.

:ranton:Every now and then some poor misguided person will pop in swearing that the two screw fix is the Be-All End-All fix to the PCM problems. If you are one of those people, I personally request that you disassemble the PCM and explain to me how a screw that holds two pieces of plastic together and internally touches nothing but plastic can have any relevance to the electrical characteristics of the PCM. What happens is that the connectors must be moved in order to get to the screws. In turn, this sometimes temporarily solves an intermittent loose connection. End of story.:rantoff:


#2. Grounds:VERY IMPORTANT! The grounds for the charging system, PCM, and O2 sensors get corroded. Don't just look at them with a curious glance. They corrode and gather oil/dirt where you can't see while assembled. Disconnect battery. Find three system grounds, take them apart and clean them. Make them shiny.

On the passenger side of block, below the head, there are two studs with wires terminated. One shares a stud with the coil bracket and the other shares a stud with a wire bundle clamp at the dipstick tube. Take these nuts off, spray the area with brake cleaner, use your steel brush to clean the stud, nut, washers, and all of the terminals. The PCM grounds at the forward stud. Then just outboard of the battery, there is a bolt in the fender where the battery grounds. Clean this one too. The alternator case grounds through the mounting bolts and mating surfaces on the engine. If you can’t check it electrically, take the alternator off and clean the mating surfaces and bolts. If removing the alternator you may also want to remove the alternator bracket since you may find the back of the bracket glazed/corroded. Iron plus aluminum = corrosion. NOTE: The locations specified above are for 97 with 4.0 engine. Yours may have a slightly different configuration. Best bet is to take any stud you find apart and clean as outlined above. If you have accurate location information for earlier model / different engines, please PM me an I will make edits to include. I know the 93 4.0 PCM ground is at the battery terminal. Help me make a list.

#3. Power Distribution Center: – The PDC is directly behind the battery and has a direct feed (which is also corrosion prone) from the battery. It has lived in a harsh environment for all these years and is susceptible to corrosion. Inside the PDC are the primary power sources for the fuel pump, injectors, coil, transmission, and PCM.

The first thing you want to do before you take the cover off, while the engine is running (if it's running), just give the PDC a good whack on top and sides with your hand and see if the ZJ objects. If anything changes, there's your sign. Time to repair your PDC.

Even if it is okay with you beating on it, disconnect the battery take the lid off and flip it over. Take note of the location of the relays and get a handle on which relay is which. Pull them all out and don’t get them mixed up. Clean all the legs with your fine sand paper or crocus cloth (take note if a leg looks burnt) and use contact cleaner on the sockets, Put the horn relay in place of the fuel pump relay and the intermittent wiper in the place of the ASD… or vice versa it really doesn’t matter. Once you have done this and your stall doesn’t happen anymore and horn doesn’t blow or your wipers don’t keep time with the music, you have found a potential cause of your stall.

Note: A lot of people have the misconception that a relay is a go/nogo device which is not the case. The FP and ASD relays are 100% duty cycle with heavy current draw and contacts are susceptible to carbon build up. This equals intermittent function of whatever is on the load side of the relay, depending on demand. You can use the horn relay socket to test all of the relays for go/nogo... stick it in and see if the horn works. It is an off the cuff method that can leave stones unturned, but could work in a pinch. Dirty contacts may operate the horn for a second or two, but can fail under constant load.

Pull all of the fuses out one at a time and go through the same cleaning routine as you did with the relays. If a leg on anything you remove looks charred, you will need to disassemble the PDC and correct the problem.


#4. Battery and cables: Remember just because it looks good doesn’t mean it IS good. These cause a lot of problems you would never think would cause an rpm drop, miss, or other persistent problem. If you can borrow a battery to swap and see how it runs, you’re way ahead.

First thing, pay attention to your battery gauge. Theoretically, each index mark on the gauge represents 1.25 volts. When you turn the key on, the needle should rise well past the first major index mark (11.5V). Immediately after the engine starts running from a cold start, the needle should stand up at about 14 volts. If it is not doing this, it is time to check the condition of battery. If you were able to measure it with a meter, you would be looking for > 12.65 (key off) and 13.8 to 14.3 volts (running immediately after cold start).

To get an idea if the charging system is healthy, observe the needle while gradually loading the system. Note voltage while idling, then turn on accessories. The biggest current users are the rear defroster, blower motor (high), and of course, bright lights and fog lamps. Turn these on one at a time and see if the needle drops. If it does, rev to around 2000 rpms and see if needle goes back to it's no load position. If it doesn't, something is amiss.

If you have the capability to do so, you can use the information in this thread or this post to check your system.

Regardless of how they look while assembled, clean the terminals and posts. Use your stiff brush or a pocket knife to make the inside of the terminals and posts shiny.

http://www.jeepforum.com/gallery/dat...nd_battery.JPG

While it is running and with the system loaded (turn some stuff on) very carefully wiggle and twist all of the main power cables from the battery terminals to the termination points. Listen to what the engine tells you. It may or may not change the way it runs. If you have an extra pair of eyes, put them in the driver’s seat to monitor gauge. During this inspection, if a cable feels like something is crunching or if you see (use your bright light!) white or green wire strands, it needs to be replaced and you may have found your problem. Be sure to check ALL terminations associated with the charging system carefully for signs of corrosion.

http://www.jeepforum.com/gallery/dat..._terminals.JPG

There are numerous resources available on the web and some local parts stores to help you determine if your charging system is up to par so I’m not going to go further and try to reinvent the wheel here. :google:


#5. FUEL QUALITY: Buy some good quality gasoline and use a can of fuel treatment (I like Lucas). If you can find it, try fuel without ethanol. If this helps, do #6, 7 and 10.


#6. FUEL PRESSURE: These ZJs have so many problems that could be fuel pressure related, a tester is a necessary item for your tool box. Go buy a cheap one. They all have instructions. Pressure should be 48 psi plus or minus 5 on the 96-98 and about 32 psi on the earlier models. The pressure should remain steady throughout the throttle range. If the fuel pressure is acting up, be sure the power is good before you go buying a pump. The fuel pump relay is always suspect if your fuel pressure is not normal. Quick and easy check is to swap it with the horn relay. You should also check the connector to the fuel pump for damage and corrosion.

Now would be good time to get daring and crawl under the back of the Jeep while it's running and lay your ear (or use a stethoscope) on the lowest part of the tank and listen for irregularities in the noise the pump is making. This is dangerous, don't get burned or ran over.. Use your head for something besides a hat rack. Unless you have loud exhaust, you should also be able to hear the pump run through the filler neck, but you have to get stinky gas smell on your ear. If it sounds like the motor has sand in it, it's time to change the pump. Some people have made it home by whacking the low part of the tank with something that gets the pump's attention, like a 2x4.


#7. IGNITION: The best option is do a complete tune up using OEM or equal parts if you haven't had one for 20K. Don’t buy the cheapest thing you can find. It won’t last and will cause you more pain. At minimum, get a cap with brass contacts, copper plugs (4.0 doesn't like platinum plugs). Here is Uniblurb's recommendation for parts for the 4.0.

If you have the technology, check the coil with a meter. If you don't have the technology, take it off and give it a once over. Look for cracks and signs of arcing. A bad coil can cause temperature related misses and stalls, consistent misfires, or no starts. If you want to just change something to TRY to get it going, replace the coil. It's one of the least expensive items and it doesn't hurt to have a back up if it doesn't turn out to be the problem.

The most telling indicator that the plug wires are bad is a blue glow or spark when the hood is opened at night when the engine is running. An even better test is to get someone to apply the brakes and take it up a couple hundred RPMs to put a load on the engine. Don't get ran over.

I have found that simply taking the distributor cap off and cleaning the crud out will eliminate an occasional misfire DTC. No need to disconnect plug wires, just the coil wire and maybe the two wires closest to the block. Roll the cap up where you can see inside. Check for arcing, oil, dust particles or any other foreign matter. If it has oil in it, you will need to replace the distributor. Pull straight up on rotor button to remove it and look for cracks and check the tip for pitting. Since you are this far into it, pull the cam sensor straight up to remove it and inspect it for cracks or damage of any kind. Then clean out the distributor housing while you have the cap off. Check all plug and coil wires for burned connections.


#8. CONNECTIONS: Most intermittent electrical problems are caused by faulty electrical connections or wiring. Before condemning a component or wiring assembly check the following items:
  • Connectors are fully seated.
  • Spread terminals, or terminal push out.
  • Terminals in the wiring assembly are fully seated into the connector/component and locked in position.
  • Dirt or corrosion on the terminals. Any amount of corrosion or dirt could cause an intermittent problem.
  • Damaged connector/component casing exposing the item to dirt and moisture.
With the engine running, (be careful) find EVERY connector inside the engine bay. You’re going to have to look for all of them (because I don’t type well enough to tell you where they are), but start with the ones closest to the engine. Grab each one and treat it like you’re trying to shell a peanut with two hands. While you have each side in each hand, twist, push, and pull. Don’t overdo it because you don’t want to break anything. If you find that any of the connectors cause a problem with the way the engine runs, examine it closely (with a light if you need it, take your time) and figure out how the two halves release. There are a few different type connectors and the locking tabs are easy to break. Don’t use a screwdriver to try and release the locks because they break easily. Don’t ask how I know this. Once you get it apart, inspect as stated above, then use contact cleaner on it and follow up with dielectric grease.

My personal experience is that the most common problem causers are the coil and cam sensor (near distributor) connectors. These two cause random misfires for seemingly no reason so go ahead and take them apart and clean them. The coil connector is known for having spread sockets because, best I can figure, various coil manufacturers do not control the size of pins. Do you know how many/what type coils have been used with your connector? If not, the spread sockets may be your problem. You can disassemble it and slightly elongate the sockets to assure positive engagement. If this connection fails continuously it will turn on the CEL, but if it only occurs once in a blue moon, it won’t.


#9. WIRING: There two main harnesses in the engine bay, the engine harness and a (for lack of better term) body harness. It stands to reason that if there are drivability problems caused by a harness, the engine harness will be the first thing to check. These harnesses have splice areas that you cant see unless you dig in. With engine running, start at the PCM and work your way out to the ends of the branches of each harness in the engine bay. Using your bright light, follow the bundles, check for obvious damage or chaffing and grab about every foot or so and pull and push, twist if you can (to disturb the splices and find any wires broken inside insulation). Follow all of the branches out to their termination points. pay particular attention to the area around the PDC.

The most common mechanical damage points are behind the valve cover and under the vehicle. Turn off vehicle and set brake. The bundle under the vehicle has a tendency to get caught in moving parts when a careless mechanic doesn’t finish the work. The oxygen sensor wiring is usually the victim and can cause a no start or stall, depending on which part of the O2 sensor wiring gets abused.

Due to the age of the vehicles and characteristics of the wiring insulation, engine heat can cause the insulation to break down, especially above the head/manifold area. It can lose its pliability and fuse together causing the conductors to short circuit, either intermittently or a dead short. One way way to determine if this is happening is to strip off the looms and tape and check. If you have the technical know how, you can figure this out with a meter and schematics. I found my TPS wiring was all fused together from the heat but had not shorted yet.

It has also been reported by several forum members that rodents love to nest in the engine bay so be on the lookout for chewed outer jackets on the wiring. The longer your Jeep sits around idle, the more tempting it becomes to Chip n Dale/ Jerry. If your unit does sit around where there is a population of these vermin, I recommend disconnecting the battery while stored and inspecting the engine bay prior to reconnecting the battery.

If you do not know the history of the vehicle, check all over for add on fasteners that may be punching a wire bundle. One in particular is the main harness that runs through the radiator support. Fog lights, mud flaps, screws (instead of plastic clips) attaching bumper cover are all suspect.


#10. Throttle Body: – Disconnect battery. A nasty throttle body can cause stalls and hesitation at low RPMs. Plenty of info available on forum to clean TB and the Idle Air Control. Here is write up that will show you how to start. Read all the way through so you’ll know everything that could possibly go wrong. It a lot easier to do it with the TB off the manifold, plus you don’t wash all the gunk down into the intake. Get a new gasket when you get the carb cleaner… 3 bucks.


#11. Vacuum leaks: – Start at the intake manifold and follow all of the lines to their destination, inspect carefully for cracks in rubber and plastic. It has to be a large leak to make it hesitate. With air tube installed, spray carb cleaner (have fire extinguisher at hand) around intake head mating area and listen for changes in engine. If you are uncomfortable using carb cleaner, use a misting spray of water. If you want to add a "good to have" item to your tool room, get a MityVac. They are awesome to find vac leaks with.


#12. Restricted exhaust: – Tough one… it got me… If your vehicle has been running rich or backfiring, the catalytic convertor or anything behind it may be clogged. It can fail in one of two ways. The back end can blow into the muffler, or the front end can melt and stop up the chamber. So either way there will most likely be varying amounts of loose stuff floating around in your exhaust system. About all you can do without doing exploratory surgery is to listen for a rattle, most prominent when the engine is shutting down (open the door so you cam hear it, give it a rev, shutoff key) or just banging on the exhaust pipe with a 2x4. Don't be fooled by a loose heat shield. if you hear the cat rattling, get under there and check the welds to be sure the shield is not loose. You can drill some relief holes in the pipe forward of the cat and see if it runs better and have them welded up later, or you can remove the front O2 sensor to allow back pressure to escape. This type failure may cause it to stall under load at higher RPMs, accompanied by a rise in engine temperature. The rise in temperature on mine was about 10 degrees.

So, you've hung with me and made through the list, done everything suggested, and your Jeep is still being peculiar about when it wants to run. If you still have a problem, we make our first approach to sensor land. You can disconnect the wiring to the O2 and cam sensors to eliminate them as a cause of the stall. The PCM will switch to the "open loop" mode and send default fuel pulses to injectors. Note: These should cause a code, but not necessarily a CEL. Simply disconnect the battery to clear code.
  • O2 is not required to crank or run.
  • Cam sensor (pickup coil) is not required to run.
If it stops stalling, replace sensor with Mopar or NTK parts.

If the problem persists, now we have to get technical. I suggest you take the time to become proficient at using a multimeter. If you have multi-meter and know how to use it, check the things outlined in the list above the PCM photo in section #1, but you need to eliminate the basics (the dirty dozen) first. See this great instruction from Fluke on how to check your vehicle. I've been using a meter for long time and this is the simplest and most useful instruction I've seen. If you are uncertain on how to check something, do some Google searches (be sure to use the word "Jeep [engine type]), Jeep Forum searches (upper left hand corner) or reply to this post and someone could advise you.

When you've exhausted yourself and are about to pull your hair out (if you have any), you can do one of two things:

1) Start a post
with as a many facts as you can in regards to exactly when it stalls... accelerating, decelerating, up a hill, coasting, hitting a bump, completely at random, etc. What do the instruments do? What have you checked and how did you check it? What have you already done to try to fix it? The details (but not the story of your life) are important to get your Jeep running so you can resume your life. Here is a good synopsis of how you need to approach getting help on the forum.

2) try for immediate gratification and get yourself one of these

http://i385.photobucket.com/albums/o...ps0d64d5cd.jpg

If you get it fixed, please take time to come back to your post and tell the world what fixed it.

IF you get it running the way you like it, there's lots of other problems it can cause you. It's not a matter to worry about, just know it's going to happen. When they do, take a look at Jason's list of common problems. Also, for everything you wanted to know about your ZJ but neglected to read, check out the FAQ sticky at top of page 1.

Special thanks to JS97ZJ for posting the detailed technical information linked from here and to the regulars who have put up with me while I figured all this stuff out.

If you can add something constructive that may keep someone from changing a perfectly good sensor or destroying their ZJ in a fit of madness, please do so. PM me if you have a suggestion and I'll give it consideration. I am updating as i see opportunities.

Hope this saves someone some pain. :tea:

If this article helped you, please consider donating to my membership fund

1ATony 08-21-2012 01:03 PM

Great article thanks for posting. My 97 Grand Cherokee would stumble upon take off once in a while. I ran a bottle of Chevron fuel injection cleaner through the tank and it seemed to resolve the issue.

bananaslug 08-21-2012 01:23 PM

Should definitely mention CKS and TPS are also common problems. Awesome write-up. Thanks man.

timmay5309 08-21-2012 05:03 PM

Excellent write up, thank you for taking the time to do this!

ZeeJay1997 08-21-2012 06:24 PM

Quote:

Originally Posted by bananaslug (Post 14053435)
Should definitely mention CKS and TPS are also common problems. Awesome write-up. Thanks man.

Thanks, hopefully it will keep someone from changing a sensor they don't need to change ;)

thathubcapguy 08-21-2012 07:51 PM

#13 set it on fire.

but really this is a great write up! thank you for the effort!

Uniblurb 08-21-2012 10:19 PM

Excellent ZeeJay, thanks for your time and effort!

Freestyle713 08-21-2012 11:37 PM

I wish I saw this thread three days ago. Sticky?

iser 08-22-2012 07:54 PM

yea def sticky this. so i read this last night. guess what happened this morning. yep, my jeep stalled out. and on top of that, i came down with food poisoning so i spent the entire day at the hospital.

i guess i'll be going through these 12 steps tomorrow.

sebian 08-22-2012 08:22 PM

A 12 step program for Jeepers, I love it! Thank you for putting this together, I can see it being very helpful for anyone on the forum!

papitt 08-22-2012 10:49 PM

Great Write up ZEEJAY .. I'm trying no 13 ....... As I worked for Jeep for 7 years .. I think your write up is more to the point that the TSB's we had to read. Really your sound like Test this .. no workie .. OK try This ..
.. Well as I said I'm down to no 13 .. and I've replaced all the sensors .. I'm not a mechanic but I was a service advisor and I'M ALSO 63 so I've worked on lots of cars in my past ..
... But I'm going to print off your test list and give it a new try..... These little Jeeps are too good a Vehicle to just throw them away.
..... Either someone let them over heat or we can't fix this stumbling idle won't start and Die.......
.......................
...PS mine is a 1998 What's wrong with a 1998 ....Taht was a 1st for me.

phitmein 08-23-2012 02:59 AM

Zee, you know me somewhat I think .

That said, #4 is #1 IMHO .

Phit


P.S./edit: Great post Sir and nicely done.

ZeeJay1997 08-23-2012 06:58 AM

Quote:

Originally Posted by phitmein (Post 14061669)
That said, #7 is #1 IMHO .

Yes, you are correct. When I started writing this, I intended to start with the "no tool" things to check and work down to the things that will require a trip to the toolbox, but I nixed that idea after I wrote #1 and left it all at random.

cootertwo 08-23-2012 08:45 AM

Good deal, nice write up. Thanks:cool:

CatSplat 08-23-2012 09:20 AM

Speaking of the PCM solder joints - has anyone tried reflowing the solder? I've fixed dead video cards by stripping them down to the board and heating them in a toaster oven to reflow the solder. You'd probably want to clean off all of that terrible gunk on the PCM before heating, which would be a PITA, but once you've got all that stuff off I figure it'd be worth a shot to fix a bad PCM for free.


The time now is 08:14 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.