00 GC stalled and won't start - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 02-11-2008, 11:36 PM Thread Starter
mattpm07
Registered User
 
Join Date: Aug 2004
Posts: 50
00 GC stalled and won't start

2000 Grand Cherokee w/ the 4.7l and 2wd. Going down the road today and just cut out. It turns over for about 3 seconds till it acts like it catches but it only catches for about half a second until it dies. When the key is on and all the gauge lights come on, then go off, Check Gauges light stays on. I tried messing with the pcm and such. I had it towed to a local shop to have them run the code and run the diagnostics on it. I'm leading to believe it's the Crankshaft Position Sensor. Anyone else have experience with this problem. It's like the timing or something is way off for the half second it wants to start. The fuel pump turns on when it's cranked so we're good there also.

Matt

mattpm07 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 02-12-2008, 07:47 AM Thread Starter
mattpm07
Registered User
 
Join Date: Aug 2004
Posts: 50
BTT anyone?
mattpm07 is offline  
post #3 of 5 Old 02-12-2008, 09:04 AM
00RedWJ
Registered User
2006 WK 
 
Join Date: Dec 2007
Location: Long Island, NY
Posts: 540
I had similar symptoms and it turned out to be the Camshaft Position Sensor

2000 Red Laredo WJ
4.0 with Selec-trac - Sold
2006 Black Laredo WK
3.7 with 95,000 Miles
00RedWJ is online now  
post #4 of 5 Old 02-12-2008, 01:47 PM
AgitatedPancake
Registered User
2001 WJ 
 
Join Date: Nov 2004
Location: Sac, California
Posts: 3,959
I had the same exact problem. I had no spark or anything. Replaced camshaft position sensor and crankshaft position sensor at the same time and no more problem.

To contact me, email
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

01 WJ 5 Speed Claytons LA's, 36" Iroks, 35 spline 9" rear, Custom Ruffstuff 60-9" front axle.
Build Thread:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
AgitatedPancake is offline  
post #5 of 5 Old 08-07-2009, 05:40 PM
krossfyah
Registered User
2001 WJ 
 
Join Date: Mar 2009
Location: canada
Posts: 11
where is the cam shaft position sensor locationed on the JGC 4.7? could not find it
krossfyah is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Help! ZJ stalled and won't start! aaron7 ZJ Grand Cherokee Forum 3 12-09-2008 12:44 PM
My Jeep stalled & won't start! robskeeter ZJ Grand Cherokee Forum 0 08-23-2008 05:03 PM
Put in reverse... stalled... won't start now aaron7 ZJ Grand Cherokee Forum 19 11-21-2007 09:43 AM
Stalled now wont start Jay1982 ZJ Grand Cherokee Forum 16 06-25-2006 04:20 AM
95 Gc Stalled - Won't Start Now Gas Smell phjohnso ZJ Grand Cherokee Forum 1 03-11-2004 02:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome