Yj won't start after engine rebuild - JeepForum.com

LinkBack Thread Tools
post #1 of 4 Old 07-01-2013, 10:01 AM Thread Starter
Registered User
Join Date: Feb 2013
Location: ROBERT LEE
Posts: 4
Yj won't start after engine rebuild

I rebuilt my 2.5 liter and now I can't get it to start. It would run before rebuild but had lots of blow by due to a hole in number for piston. This is the first jeep rebuild I done so I took lots of pics to ensure the assembly. Any recommendations?

TFERGUSON2005 is offline  
Sponsored Links
post #2 of 4 Old 07-01-2013, 12:07 PM
Registered User
1989 YJ Wrangler 
Join Date: Dec 2004
Location: Frederick, MD
Posts: 1,723
Start with the basics. Make sure you have fuel getting to the engine. You can pour a small amount into the intake and see if it tries to start. If so, you have spark, and no fuel. Verify voltage to the coil, check CPS connection, as well as the other sensors.
EABiker is offline  
post #3 of 4 Old 07-01-2013, 01:49 PM
Registered User
1992 YJ Wrangler 
Join Date: Jun 2013
Location: San Antonio
Posts: 93
VenomousMaximus is offline  
post #4 of 4 Old 07-01-2013, 08:12 PM Thread Starter
Registered User
Join Date: Feb 2013
Location: ROBERT LEE
Posts: 4
I think the timing is off some how I set it just as the book said but I rotated the plug wires on the cap counter clockwise a quarter turn and got it to fire and run but was holding throttle half open and it ran really rough. I guess I will take down and start overon the timing. Any little tricks to ensuring timing is done right?
TFERGUSON2005 is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome